Installed new RAM, it is not recognized

Discussion in 'iMac' started by bgbs, Apr 6, 2012.

  1. bgbs macrumors newbie

    Joined:
    Oct 17, 2008
    #1
    I have a 27" mac, and I just bought and installed some ram, but it is not recognized, I get a one prolonged "beep" sound.

    Did I install wrong ram, or is it bad RAM?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Make sure your RAM is seated properly, as always. It could be your firmware is being updated.

    iMac (Mid 2007) and later models: About startup tones
     
  3. aaronvan Suspended

    aaronvan

    Joined:
    Dec 21, 2011
    Location:
    República Cascadia
  4. bushman4 macrumors 68000

    Joined:
    Mar 22, 2011
    #4
    Be sure that the new RAM is seated properly. With the IMAC it is necessary to push hard and up to seat the RAM properly. There are seveal videos on Youtube demonstrating this.
     
  5. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #5
    The modules need more force than you would think....They are only seated properly when you hear the click as they go in....The door to the tray can be closed when the modules are not correctly seated...Which doesn't rally help. Use a little more force.
     
  6. Thebutchersboy macrumors newbie

    Joined:
    Mar 31, 2012
    Location:
    South-West UK
    #6
  7. krzykat macrumors newbie

    Joined:
    May 15, 2011
    #7
    Yeah it was surprising how much force it took to seat my new RAM a few weeks ago. Was glad that it worked. :) Good luck!
     

Share This Page