Installed SL, Cant mount my USB drive!

Discussion in 'macOS' started by fishmoose, Sep 4, 2009.

  1. fishmoose macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
    #1
    Hello,

    I installed SL today and everything seemed perfect until I tried to mount my USB HDD it's a Maxtor drive inside the case, the case is produced by Lace.

    The drive is pretty old like 3-4 years but it worked perfectly in Leopard.

    It says I should check the drive with disc utility but when I do so it finds no faults.

    What should I do? I have data that I need on that drive :(

    It's formatted in FAT32 btw, my MyBook Essential 1TB worked perfectly with SL.

    Any help is greatly appreciated!
     
  2. adamk77 macrumors 6502

    Joined:
    Jan 6, 2008
    #2
    I'm not sure if this will help, but --

    I have noticed a bug in Snow Leopard where if a CD/DVD is not labeled, it will not mount. You have to mount it manually.

    I have never used a thumb drive, so I do not know. Is it possible to label a thumb drive? For example, if I label a CD/DVD as "My DVD", it will mount under /Volumes as /Volumes/My DVD.

    You may want to try mounting it manually. Take a look at the mount command (man mount from the command line for help).
     
  3. fishmoose thread starter macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
    #3
    Thanks for the tip, didn't think of that.

    But good news I rebooted Snow Leopard and now it work again :confused: don't know why but it does.

    Strange!
     

Share This Page