Installed software crash and wont load up? error "panic: we are hanging here..."


macrumors member
Original poster
Dec 31, 2005
Newport - South Wales
Is their anyway to remove a program that I installed just before I had the following error message on/before startup?
I'm completely stuck on what to try next since I got this error message straight after installing some software:

(this is just the bottom part of the error message)
:Kernel version:
Darwin kernel version 8.7.0: Fri may 26 15:20:53 PDT 2006; root:xnu-792.6.76.obj 1/release_PPC

Panic: we are hanging here..."

The computer has run fine until I installed a piece of software called "Pocketmac pro" over another version of this software (which I thought was removed until it said in the installation window do i want to remove and overight it so I clicked yes).

After it told me to restart I got that Kernal error from boot.
I've tried booting from the installation cd then going into "disc utilities" then verify and repair, after I do that it says complete but it also says this in red text:

"Invalid leaf record count
(it should be 21 instead of 567)"

I've tried rebooting into safe mode by holding the shift key down just after the load up chime but that doesnt seem to be doing anything (it is the shift key you use isn't it?), doing that just goes straight into the error message on startup

I've tried booting into single user mode by holding in apple (command) + S on startup but that also doesn't seem to work (just goes onto the error message like the shift key does).

Is their anything else I can try to get into single user mode or safe mode?

Their seems to be alot of similar error messages to this in google when ive looked but nothing that seems to work for me, I've just been following some of the suggestions on this link:

I've only been using macs for a couple months (im more familiar with windows) so I may need any suggestions laid out in as much detail as possible. I'm hoping it doesn't require a clean install as I have quite alot of stuff not backed up on the hard drive.

appreciate it


macrumors member
Original poster
Dec 31, 2005
Newport - South Wales
My operating system is MAC OSx 10.4.something or other (It's the latest update whatever it is, I can't remember off the top of my head)

It is a Mac G4 with an 80gig hard drive with only 40gig used
550 (approx) meg ram

I've not installed any hardware since owning it, the software I installed was a program to link up a windows smartphone so that I can upload images/music etc onto the phone, I plugged that in once when installing the software when it asked me to just before asking me to restart.

That's all I can really remember without being able to load up into the Os and look in the settings


macrumors 65816
Feb 27, 2004
London, UK
Sam/B said:
Is anyone able to suggest something or is it time for a reinstall and lose all my work?
Not sure what to suggest to fix it, but if you need go grab stuff off the hard drive, try booting into target disk mode - makes your drive into a firewire drive so you can connect to it with a cable (assuming you have/can borrow another computer). You can do this by holding down t (and maybe another key - look it up) on startup.

To transfer files using FireWire:
Shut down the first computer and leave the second computer on.
Connect the two computers using a 6-pin to 6-pin FireWire cable. (If both computers have higher-speed FireWire 800 ports in addition to the standard FireWire 400 ports, you can use a 9-pin to 9-pin cable with the FireWire 800 ports to transfer data at higher speeds.)
Open System Preferences, click the Startup Disk, and click Target Disk Mode. (Or, start up the first computer while holding down the T key.)
A disk icon for the first computer appears on the desktop on the second computer. Drag files to and from the disk to transfer them.

When you finish, eject the first computer's disk by dragging its icon to the Trash. (While you drag, the Trash icon changes to an Eject icon.)
Push the power button on the first computer to shut it down and disconnect the FireWire cable.


macrumors G4
You might not have to do an entirely clean install.

It might be worth trying an Archive & Install which would keep the stuff in your user directory intact and your applications - it basically just re-installs the system stuff.

To do an A&I should take about 45 minutes - then time to update through Software Update; make sure you've got a wired connection handy though. If it still doesn't work after that, you're looking at a completely fresh install.

To do an A&I, you need to select Options (in the bottom left corner duringn the Install process)