installed windows 7 ultimate on imac but there are no internet drivers

Discussion in 'iMac' started by icanswim70, Aug 20, 2014.

  1. icanswim70 macrumors newbie

    Joined:
    Jun 9, 2014
    #1
    Hey everyone!

    I am running snow leopard on a 1 tb imac 2011. i installed windows 7 ultimate on a 340 gb partition (didnt use bootcamp, did everything manually) everything went smoothly, installed no problem. But now there are no internet drivers on the windows side. (can still access internet any everything fine on mac side) How can i get the drivers on the windows side!

    thanks:confused:
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    You need the Bootcamp drivers. Download them in OS X and copy to a USB drive, then copy from there to Windows and run the installer.
     
  3. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #3
    You didn't use Boot Camp.

    That's the problem.

    You're going to have to download the Boot Camp drivers yourself from the OS X side, and put them into a USB stick and installing them into Windows.
     
  4. p3ntyne macrumors 6502

    p3ntyne

    Joined:
    Jan 10, 2014
    Location:
    Sydney, Australia
    #4
    Use this: http://support.apple.com/kb/DL1720 to download them. Unzip and place the file on any form of external storage, formatted exfat for Mac and Windows. Then, boot to Windows, start setup, restart and that's it.
     
  5. icanswim70 thread starter macrumors newbie

    Joined:
    Jun 9, 2014
    #5
    This worked and solved my problem! Thank you!
     

Share This Page