Installer.app Package download failed: can't find host!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by netwho, Feb 12, 2008.

  1. netwho macrumors newbie

    Joined:
    Feb 12, 2008
    #1
    Guys,

    I'm useing a OOB 1.1.2 iPhone with turbosim. Worked perfectly for weeks. Know I get an annoying error when I'm trying to install/remove apps:

    Package download failed: can't find host!

    I'm useing Installer 3.0 and manually added the new Ste Packaging as sugguested in an other threat.

    I'm sure I'm not the only one and hope someone figured how to fix.

    Sorry if this is dupplicated, I searched, but couldn't find a working solution....

    Any tip is appreciated, netwho
     
  2. netwho thread starter macrumors newbie

    Joined:
    Feb 12, 2008
    #2
    Found a hint on ipodtouchfans.com.
    Changing the permission made it (the error message from installer.app din't help a lot...)

    chmod 755 /Application/Installer.app/Installer

    made it.

    Cheers, netwho
     
  3. cschwab18 macrumors newbie

    Joined:
    Feb 13, 2008
    #3

    I'm getting the same error. I have an OOB 1.1.2 upgraded using iBrikr and
    http://iclarified.com/entry/index.php?enid=604 to 1.1.3. I no longer have the SSH button (not sure where that went)...can anybody help out someone feeling stupid?
     
  4. boobear macrumors newbie

    Joined:
    Feb 13, 2008
    #4
    And believe me, by reseting your phones a million times or playing around with queing/unqueing installs, it won't...

    Ste (admin of Istaller app) has moved the repository from one site to another. So, you're getting the package download failure notices because most of the files simply AREN'T THERE anymore.

    The only thing to do is to change the URL of "Ste Packaging" to http://repo.smxy.org/iphone-apps/ in the Sources section of Installer app.
    Or (preferred) simply install Community Sources (can be found in Sources among the installs) it does the same automatically.

    If you've installed Community Sources or changed the URL manually, you'll be able to get those installs

    just go to the list of installs and click community, this drove me mad for ages then the answer really was that simple, now i'm installing with no problems
     
  5. cschwab18 macrumors newbie

    Joined:
    Feb 13, 2008
    #5
    It won't let me install community sources, I get the same error. I don't have an option for changing the URL of Ste Packaging in the sources...how do I do that?
     
  6. boobear macrumors newbie

    Joined:
    Feb 13, 2008
    #6
    have you updated through installer recently? if not go to installer and "click" updates
     
  7. germen macrumors newbie

    Joined:
    Feb 13, 2008
    #7
    Delete & Add source in installer

    Go to "Sources" in Installer.app.

    Then tap the "Edit" button. Click on the "-" icon over "Ste Packaging" source line in order to delete it.

    Tap the "Add" button and type the right new URL for STE Packaging source:

    http://repo.smxy.org/iphone-apps/

    Enjoy and be happy installing lotsa applications to your (awesome) iPhone.

    PS: I highly recommend to install both "Community Sources" and "BossTool" (in "Utilities" category) and run the "Free Disk Space" inside BossTool in order to relocate Fonts, Ringtones and Applications to the main disk partition and be able to install a lot of applications without space lack problems. Note: do it in the recommended order first Fonts, then Ringtones and Applications at last.

    Be cool guys!
     
  8. cschwab18 macrumors newbie

    Joined:
    Feb 13, 2008
    #8
    thanks!

    back up and running appreciate the help!
     
  9. wuwu macrumors newbie

    Joined:
    Feb 16, 2008
    #9
    did these but had this error ''refresh failed; could not refresh sources! '' and i have lost ste packaging. Anyway out
     
  10. EdRoche macrumors newbie

    Joined:
    Feb 16, 2008
    #10

    Same here, after deleting the "Ste Packaging" Source and picking add I have the above URL but under a heading of 'uncategorised'. We cant download community resources due to same error - Package download failed: can't find host! All the Ste Packaging apps have gone also. Any ideas?
     
  11. Jinkenz macrumors newbie

    Joined:
    Feb 16, 2008
    #11
    Update Fail error.

    the URL is case sensitive. iPhone auto corrects iphone to iPhone. The URL should be all lower case.
     
  12. EdRoche macrumors newbie

    Joined:
    Feb 16, 2008
    #12
    Thanks pal,

    for the thread-

    Going to the “Sources” page in Installer.app and deleting the current entry for “Ste Packaging”.
    Add the new repo URL of: http://repo.smxy.org/iphone-apps/ (Make sure you include that final slash! Also make sure that your iPhone doesn’t capitalize the “p” in “iphone”. Going to that URL with your browser won’t work BTW - you’ll just get redirected to this blog site.)
    You will know you have the new repo, as the tagline for it is “New, and Improved!”
    You may need to manually refresh it once, after Installer.app adds the repo and does it’s own refresh. The site will show up as “Uncategorized” (at least, it does for me), but that’s ok.

    When Nullriver updates the “Community Sources” package, and you update to it, I don’t know if it will just move my repo to the “Community Sources” category, or if you will wind up with it listed twice. If it does get listed twice, and one is in the “Uncategorized” category, then just delete that one. If you wind up with two of them in the “Community Sources” category, then just pick one and delete it.
     
  13. Jinkenz macrumors newbie

    Joined:
    Feb 16, 2008
    #13
    I think shutdown and restart of the phone will/should clear up the double/wrong listing of the resources. It do for me.
     
  14. Rudenik macrumors newbie

    Joined:
    Feb 20, 2008
    #14
    still seeing the same issue

    hey I've tried updating the URL (checked uppercase and that the slash is at the end/) and i still get can't refresh sources and still seeing the package download failed: can't find host! error.

    I've heard that the guy who develops the Installer.app has started working with apple and has abandoned this project.

    Does anyone have any suggestions on what to do?
     
  15. Compile 'em all macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
    #15
    better late than never. to fix this..do

    chmod u+s Installer.app/Installer

    assuming you are in the Applications/ dir already.
     
  16. Frankenn macrumors newbie

    Joined:
    Oct 15, 2007
    #16
    Can you explain to me exactly how to do that, it doesn't make much sence to me.. :/

    nevermind it's working now :)
     
  17. kevinwiz macrumors regular

    Joined:
    Feb 1, 2007
    Location:
    socal
    #17
    i did all this and it still gives me "error: package download failed" when i go to update my apps or install new apps or even uninstall apps.
     
  18. netwho thread starter macrumors newbie

    Joined:
    Feb 12, 2008
    #18
    As mentioned previosely - check/change the permission of the installer.app (ssh/terminal).

    Worked for me, netwho
     
  19. chris N macrumors newbie

    Joined:
    Mar 5, 2008
    #19

    Umm, where do I change this? ssh /terminal thing? Sorry, I'm really at a lost. Someone please help? :(
     
  20. multicam macrumors newbie

    Joined:
    Mar 20, 2008
    #20
    it's also happen to me many times, all i do is restart my iphone, and unplugged my router then plug again or reset router, et voila ,ready to download and install again
     
  21. shlowy1125 macrumors newbie

    Joined:
    Mar 23, 2008
    #21
    I Fixed It!

    OK, just re-jailbreak your iphone/touch (using ZiPhone) and before doing anything else, download community sources from all apps in installer...

    all fixed!
     
  22. Filmdirector macrumors newbie

    Joined:
    Mar 25, 2008
    #22
    Help Please Can see package but wont open

    I'm so frustrated with this i phone. I have followed the directions, but I keep getting this stupid "package download failed! I went to source and did what the instructions told me. I can see the new STE packaging New and Improved from the url I was told to type, but its still not working. I have reset my phone and refresh the source, it continues to give me a message. And the worse part of it all I have a new update on the installer called Open Shh version 4.6p1-1 but can't open that up. If anyone could please!!!!!!!!!!!!!!!!!Help me.
     
  23. CurtisPrometric macrumors newbie

    Joined:
    Mar 26, 2008
    #23
    I cure for me. Maybe you too.

    :)
    I was just as frustrated. Then I tried using Ziphone while itunes was running. Download Ziphone, then Start Ziphone ( Click where is says "Click here to show Advanced Features", there you will see a button that says "Fix NVRAM". Click on this. 2-3 minutues later the ipod touch/phone is working properly with installer.
    I did this on an 8 gig ipod touch with jailbroken 1.1.4. I didn't loose any data or anything. Time will tell if this is a permenant cure. Cheers
    Curtis Legroulx
     
  24. CyanAether macrumors newbie

    Joined:
    Mar 26, 2008
    #24
    Sweet!

    I was having the same problem (more or less), I was getting "package download failed" with no reason. It would happen on every download. I tried retyping the source URL, no luck, so I did "check NVRAM" with the ZiPhone and that worked perfectly.

    Thanks Curis. :D You rule!
    P.S. I am very impressed with the functionality of Installer and jailbreaking and all that..... I remember the days when I was hacking my PSP, and that was NOT pretty. I nearly bricked it a few times I'm sure. ;)
     
  25. Filmdirector macrumors newbie

    Joined:
    Mar 25, 2008
    #25
    Nvda

    hey thanks for your response but I'm using ziphone on mac and I go to the advanced options and I don't have the option to fix nvda. Is there another solutions.
     

Share This Page