Installer corrupt, leopard disk wont even install!

Discussion in 'macOS' started by natn22, Apr 2, 2008.

  1. natn22 macrumors newbie

    Joined:
    Mar 16, 2008
    #1
    I think i'm in trouble. Anyone help would be greatly appreciated. It all started when i couldn't complete any software updates - it would just hang and hang. I couldn't go to the apple (or any other site) to download - it would just hang at the point when i clicked 'install'. I tried to load a third party app from a CD and still it just hangs.

    i have repaired permissions.

    i have tried to stick the leopard installation disk in to do a fresh install, or even reapir but again it just hangs after i click 'restart' which kickstarts the installer.

    i have tried to install using the pacifist, but that hangs too.

    i don't know what else to do!

    am i doomed?!
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    If you wish to perform a reinstall of Leopard but can't get the installer to start, try this:
    1. Insert the Leopard DVD in your drive
    2. Ignore the window that appears, and choose Restart from the Apple menu instead
    3. When you hear the startup chime, and the computer reboots, hold down the Alt/Option key
    4. Wait for all the bootable volumes to be detected
    5. Choose the Leopard DVD as the volume to boot from
    6. Proceed as normal with installation
     
  3. natn22 thread starter macrumors newbie

    Joined:
    Mar 16, 2008
    #3
    hi. Thanks for this. I did do this and the re- install said it completed successfully however I did note it never gave me any install options eg archive and install etc. It did require 11gb of space tho which seems a lot but I can't remember what it was last time.

    Anyway the problem is that since the install I can't get into my machine. When it starts up I'm taken to the desktop but then I just get the spinning beachball and I can't click on anything.

    I have a legit DVD copy of leopard.

    Any help would be MUCH appreciated.

    Natalie
     
  4. mgsarch macrumors regular

    Joined:
    Jan 19, 2008
    #4
    Boot in verbose (hold 'v') so you can get more info about what's really going on. There are so many different that could cause this. Have you played with the EFI at all? (boot camp, reefit?)
     
  5. natn22 thread starter macrumors newbie

    Joined:
    Mar 16, 2008
    #5
    hi there. thanks for the post. I am not sure what EFI is, so I wouldn't have touched it on purpose.

    I was really at a loss with what to do so i turned to the 'genius bar' at the apple store. somehow miraculously i got the last appt of the day yesterday and the 'genius' in there fixed it. when he did it, it gave the option to do an archive and install (but this is the default process anyway he said), which also said it completed successfully. Then we had the spinning beach ball thing for a ages. The store was closing so he advised that i go home and keep the laptop on overnight. Apparently there was indication that the hard drive was doing something (indicated by activity in the magnifying glass in top right hand corner of screen) and perhaps it needed some time to run to complete its re-indexing.

    He said if this didn't work then I should plug my machine into another mac and boot to that machine (hold down 't' when you start up laptop) get all the files i needed of it, then just do a complete erase and install. And if that didn't work i should look into getting a new hard drive.

    BUT luckily i got home and plugged it in for a little while and my machine came back to me!

    I'm only detailing the above in case anyone else has the same issues.

    thanks for all the help!

    natalie
     
  6. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #6
    Just out of curiosity, did the Genius Bar guy try running any disk diagnostics, like Disk Utility?
     

Share This Page