Installer language selection

Discussion in 'OS X El Capitan (10.11)' started by Synchromesh, Jan 9, 2016.

  1. Synchromesh, Jan 9, 2016
    Last edited: Jan 9, 2016

    Synchromesh macrumors 6502a

    Synchromesh

    Joined:
    Jul 15, 2009
    Location:
    SF
    #1
    I recently bought a Mac with a Korean keyboard. Basically it's no big deal as it still has standard QWERTY markings. But the issue I have is in the OS X installer. It defaults to Korean and since I can't read it - it's a bit annoying. Is there anyway to change the installer default language? I know previous installers had a language selection menu at the beginning but the current EC one doesn't seem to do that and I can't find any options to do so.

    Yes, I know there is an input option on the right side of the top menu but that only changes input. The screens are still in Korean.
     
  2. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    I do not know of a way to add the language selection back for the El Capitan installer.

    Have you taken a look at the System Preferences?:
    Language & Region>Preferred Language - What does it show?
    Keyboard>Input Sources & Text - What does it show?
     
  3. Synchromesh thread starter macrumors 6502a

    Synchromesh

    Joined:
    Jul 15, 2009
    Location:
    SF
    #3
    I was able to change the language inside the OS after the install. My trouble is default language in the installer itself. I think there is a setting on the logic board somewhere that triggers the language selection in the installer. I wonder if it can be reset to English.
     
  4. CoastalOR, Jan 9, 2016
    Last edited: Jan 9, 2016

    CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #4
  5. Synchromesh thread starter macrumors 6502a

    Synchromesh

    Joined:
    Jul 15, 2009
    Location:
    SF
    #5
    I tried what it says in there. It didn't help. I think that's for setup on earlier OSs and only AFTER the install, not before.
     
  6. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    How are you launching the installer? If you make a USB drive using the createinstallmedia tool, then I think you'll be asked to select language on boot (unfortunately I wiped my drive yesterday so can't double-check). If you're getting to it some other way, then I'm not sure.
     
  7. CoastalOR, Jan 9, 2016
    Last edited: Jan 9, 2016

    CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #7
    I thought the purpose of this thread was to change something that would change the language used by the installer.

    You still have not answered the question I have asked twice about what you saw when checking the System Preferences.

    I launched the full 10.11.2 installer in the Application folder, in fact, it did not ask for a language, like previous OS installers did before El Capitan. The first screen is a window that asks if you want to install El Capitan and there is only one button to select and that is "Continue". The install app can be Quit in the app menu or command+q.

    I'm using OS 10.11.2 and I did open terminal and entered "sudo language setup" (without quotes) and it did give me language choices after entering my admin password. You didn't say if there was a problem using the terminal command, so I will assume it worked, but you still have a problem with the installer and you must be launching the full installer to test.

    I'm done, good luck.

    EDIT: I did try booting from a 10.11.2 USB installer and selected Install OS X and it did not ask for a language.
     
  8. Synchromesh thread starter macrumors 6502a

    Synchromesh

    Joined:
    Jul 15, 2009
    Location:
    SF
    #8
    Thanks. I tried the sudo language setup just after going into terminal after install. It says "command not found". I tried a few variations with and without sudo but it's a no go. Either I'm doing it wrong or that command doesn't exist.

    The installer is downloaded directly from Apple and was put onto a USB disk using this command:
    sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction
     
  9. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #9
    I just tried booting to my El Capitan installer.
    It bypassed the language selection (saw it briefly in the menubar), and then opened to the installer screen.
    And - you would normally click on Continue, OR you can then click on the Back button. Did you see that?
    That then takes you (back) to the only possibility: And, voila! the Language chooser screen...

    How's that for a backwards entrance? :D
     
  10. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #10
    I did not find the back button, but I did find when booting from the USB installer>OS X Utilities>File>Change Languages...

    That was not available when running the Install OS X El Capitan app from the Applications folder.

    Interesting. Thanks for the clues. Learn something every day.
     
  11. Synchromesh thread starter macrumors 6502a

    Synchromesh

    Joined:
    Jul 15, 2009
    Location:
    SF
  12. nuxx, Jan 2, 2017
    Last edited: Jan 2, 2017

    nuxx macrumors member

    nuxx

    Joined:
    Jun 5, 2007
    Location:
    Tokyo
    #12
    Had the same problem as the OP but with a Japanese MacBook Pro and the macOS Sierra installer.

    Was able to set the language using sudo languagesetup in Terminal, but this had no effect on the installer. Was unable to find the back button in the installer as DeltaMac suggested, but thanks to CoastalOR I changed the language using the Japanese equivalent of File > Change Language...; the 3rd menu option from the left in the installer and the 1st menu item of the resulting sub-menu.

    Thanks.
     

Share This Page