Installers- unix executable file???

Discussion in 'macOS' started by hotdog, Apr 9, 2004.

  1. hotdog macrumors newbie

    Apr 9, 2004
    Hi chaps, am new to this and have just come from pc world to mac.
    new G5, panther. want to install flash, dreamweaver etc
    have a disc with MX studio. a few files in each folder.. pdfs, text with serial etc. and a file that has no extension. when I go "get info" says.
    kind: unix executable file
    when I double clik on it... get an alert box that says...
    " there is no default application specified to open the document 'flash MX Installer' "
    and then the choice of 'Cancel' OR 'choose application'

    have maybe thought I have to type in the file extension .exe so puta will understand it?

    any clues? help?
    mucho apprecited, thanx, 1st time user of this v helpful site.

  2. MisterMe macrumors G4


    Jul 17, 2002
    If your UNIX executable is not in PPC code, it is not going to work anyway.
  3. DNH macrumors member

    Oct 15, 2003
    Halifax, NS, Canada
    Have you looked at the pdfs? Is there a readme or install.pdf, or something of that nature? A unix executable could be run from terminal, but I would think there would be a mac installer package somewhere on the disc.
    a. exe is a windows executable file extension. Unix does not require them.
    b. If it is on a cd, as I suspect it is, you will not be able to change the file extension. CDs are not writable.

    If the CD is legit, installing should be fairly straightforward, otherwise, I agree with the above posters. Get a legit copy.

    On a related note, why not just ditch dreamweaver and flash altogether. Flash pages suck anyway. Generate clean html...use vi.
  4. ElectricSheep macrumors 6502


    Feb 18, 2004
    Wilmington, DE
    methinks that wherever you got these files, they are not for the Mac versions of the programs you want. If you know that they are the Mac versions, either someone screwed something up royal, or compressed them using a PC-centric self expanding program.
  5. etsudesign macrumors newbie

    Oct 30, 2004
    I have the same problem...

    I bought a legit copy of Macromedia Studio MX, the only thing is that it is the OEM version. It came sealed and labeled by Macromedia with a legal Serial Number etc...

    And I cannot install Dreamweaver or Freehand... Flash, Coldfusion, and Fireworks all are .dwg installers and work fine... but Dreamweaver and Freehand are both UNIX EXECUTABLE FILES and don't work..

    Sorry to bring this topic back up, but does anyone know the answer to this? I just got my package today, so if nobody knows the answer, I will contact the reseller on Monday. Thanks guys!
  6. jesa98 macrumors newbie

    Nov 6, 2004
    Did you receive help?

    Just wondering if you were able to solve your problem...
  7. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    When I installed MX Studio 2004, there was a flash application that ran the various installers--perhaps, there is something equivalent with MX Studio.
  8. superbovine macrumors 68030


    Nov 7, 2003
    me too
  9. paintypants macrumors newbie

    May 22, 2007
    unix files

    I'm going throught the same problem with a program i'm trying to load as well.

    I have crossover which allows you to install some things but not the program works but the data is in this unix executable file format...

    One site offered some help but it didn't work for me...I'm not familiar with this os either i'm new to it.

    You have any answers please feel free to email me at

  10. mksamuelson macrumors newbie

    Aug 20, 2007
    Unix Executable File

    I am so happy to see that I am not the only one who is having these files.
    I had used an external hard drive to back up my files.
    After getting a new harddrive, going from old 10.3 to new 10.4 OS I am not able to open these Unix Executable File.

    The one thing that is similar to all the files is they do not have any tags.
    Some were AOL letters, Excel, ect. As long as it doesn't have a tag it won't open.

    I did try giving it a .txt tag and was able to view but it also have extra characters. I am able to recreate the file by eliminating the extra characters.

    I added .xls to my Excel file and they opened. If it was originally a WORD document I gave it .doc and it opened.
    I haven't tried everything yet - but this is a good start.

    So, I don't know if this is the answer to all, but give it a tag and see what happens.
  11. NanBee macrumors newbie

    Aug 29, 2007
    woo-hoo me too

    Thanks Karen!

    I received a logo from a client in the Unix format and found this forum.

    After trying your method of adding .doc and .txt and was able to view the image in the Text Edit application finder but after opening it, the file was in goblety-gook (an artist's interpretation of Unix programming).

    Per chance, I typed .jpg after the file and was able to open it in Photoshop and voila! I've got logos... woo-hooooo.
  12. SimonTheSoundMa macrumors 6502a

    Aug 6, 2006
    Birmingham, UK
    Open terminal, drag and drop the executable from finder into terminal, and then in terminal hit return. The executable should then run.
  13. mksamuelson macrumors newbie

    Aug 20, 2007
    unix excutable file

    From your post I am assuming that you think the file is a program to install where mine are all documents with no tags that will not be recognized until a tag is added.

    Sometimes it works and other times nothing.
  14. lawrkphd macrumors newbie

    Sep 27, 2007
    Unix executable files successfully opened

    When I updated operating systems, my old FileMakerPro files were converted magically to Unix Executable files that would not open. What worked was selecting the file, hitting Command-I to open the Information window, changing the "Open With" drop-down tab from "none" to "other" and then selecting FileMakerPro. Easy (when you know how)!

Share This Page