Installing Apps on First Gen vs 3G

Discussion in 'iPhone' started by ubersalad, Aug 2, 2008.

  1. ubersalad macrumors 6502a

    Joined:
    Feb 26, 2008
    #1
    My 3G phone has once again freeze at the Apple logo when I tried to download a simple program straight from my phone. So I swapped my phone while restoring the damn thing, and started playing with the first gen.

    First thing I did was tried downloading Tap Tap to mess around, and for a second I thought my eyes deceived me. The game was downloaded and installed within 10 seconds, and it was ready for playing! So I tried again with another program, this one was smaller, so it took even less time!

    My question is then, how exactly is 3G different that I cannot install/update apps direct from my phone without crashing and restoring?
     
  2. II VOKAB macrumors newbie

    Joined:
    Jul 31, 2008
    #2
    It's the buggy 2.0 software trying to work with 3g.

    Just wait for an update.
     
  3. ubersalad thread starter macrumors 6502a

    Joined:
    Feb 26, 2008
    #3
    That's what I am asking. What component in 3G is causing the crash, whereas first gen is working fine.
     
  4. ivtecDOu macrumors 6502

    ivtecDOu

    Joined:
    May 24, 2008
    Location:
    mass
    #4
    its cheap??? but seriously people are having just as much trouble on the first gen also, i am not but some people i know are having trouble doing basic functions. its the software.
     
  5. kornyboy macrumors 68000

    Joined:
    Sep 27, 2004
    Location:
    Knoxville, TN (USA)
    #5
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5A347 Safari/525.20)

    Who knows? My 3G installs Apps fine from the App store directly from the phone and so did my first gen iPhone. It has something to do with the 2.0 firmware being buggy. Maybe something with you iPhone is causing it to behave that way even tough it isn't really broken.
     
  6. ubersalad thread starter macrumors 6502a

    Joined:
    Feb 26, 2008
    #6
    We all know it's the damn firmware. It just doesn't make sense that the biggest selling point for new 3G is the ability to download apps. First gen is doing it perfect, and 3G will take 10 minutes to install with risk of freezing your phone.

    I am very interested to find out why.
     
  7. ubersalad thread starter macrumors 6502a

    Joined:
    Feb 26, 2008
    #7
    I am not asking those without the answer, I am hoping to see a response from someone that might...
     
  8. DiamondMac macrumors 68040

    DiamondMac

    Joined:
    Aug 11, 2006
    Location:
    Washington, D.C.
    #8
    I got 3 errors just today trying to update apps

    My iMaze update isn't working thus now I can't use it
    My CrashBandit update gave me errors but I reinstalled it and it now works
    I forgot my 3rd program error but it was that green ball game TakeTwoPong or something
     

Share This Page