Installing Linux on MBP

Discussion in 'Windows, Linux & Others on the Mac' started by ACagliano, Feb 10, 2013.

  1. ACagliano macrumors newbie

    Joined:
    May 10, 2012
    #1
    Hello! I have a Macbook Pro model 7,1, operating system version 10.8.2. I am trying to create a 120gb partition and install a Linux distribution on it. This Linux OS is preferably BackTrack, but may be Ubuntu as well. I have tried Linux USB Builder for Lion. It creates a bootable install disk for Ubuntu but freezes on BackTrack. Any other procedure that supposedly works, I get a message "the disk you inserted is not readable by this computer" when done.

    When using the USB drive, which now has a bootable Ubuntu installer on it, I am able to boot into Ubuntu, use gparted to create my Linux partition. Then, I run the installer and install the operating system. Once it completes, I then attempt to reboot into the Ubuntu partition. I get "No bootable device found. Insert a boot device and press any key".

    *** Report for internal hard disk ***

    Current GPT partition table:
    # Start LBA End LBA Type
    1 40 409339903 Linux ext4
    2 409602048 940812503 Mac OS X HFS+
    3 940812504 942082047 Mac OS X Boot
    4 942082048 944130047 Linux Swap
    5 944130048 944539647 EFI System (FAT)

    Current MBR partition table:
    # A Start LBA End LBA Type
    1 1 976773167 ee EFI Protective

    MBR contents:
    Boot Code: Unknown, but bootable

    Partition at LBA 40:
    Boot Code: None
    File System: ext4 with journaling
    Listed in GPT as partition 1, Linux ext4

    Partition at LBA 409602048:
    Boot Code: None
    File System: HFS Extended (HFS+)
    Listed in GPT as partition 2, type Mac OS X HFS+

    Partition at LBA 940812504:
    Boot Code: None
    File System: HFS Extended (HFS+)
    Listed in GPT as partition 3, type Mac OS X Boot

    Partition at LBA 942082048:
    Boot Code: None
    File System: Unknown
    Listed in GPT as partition 4, type Linux Swap

    Partition at LBA 944130048:
    Boot Code: None (Non-system disk message)
    File System: FAT32
    Listed in GPT as partition 5, type EFI System (FAT)

    Please help!!
     
  2. monkeybagel macrumors 65816

    Joined:
    Jul 24, 2011
    Location:
    United States
    #2
    Have you tried to use dd go write the image to the drive?

    Note - I have not tried this on BackTrack so unsure of outcome.
     
  3. ACagliano thread starter macrumors newbie

    Joined:
    May 10, 2012
    #3
    Yeah, dd gives me the "the disk you inserted was not readable by this computer". but, i actually got ubuntu working...
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    It's normal to get the "disk not readable" message; OS X can't read whatever the Linux format is (ext4?). It should still be bootable as obviously that bypasses OS X.

    So Ubuntu works on a 7,1? I tried it just for kicks on my 8,2 and ended up with no AirPort, the keyboard backlight stuck on (even OS X wouldn't turn it back off until I reset the PRAM!) and the trackpad was almost unusable. Does that all work on your 7,1? Are you using the trackpad or an external mouse?
     

Share This Page