Installing macOS Sierra results in error: "The installer payload failed signature check."

Discussion in 'macOS Sierra (10.12)' started by nomore, Sep 21, 2016.

  1. nomore macrumors member

    Joined:
    Feb 11, 2005
    #1
    I've tried doing a clean install of Sierra multiple times, and every time, the installer gets to the end and then shows the message "The installer payload failed signature check". This leaves the computer without a bootable version of macOS.

    I have tried recreating the installer USB stick with a fresh download.

    So, Apple support guy said to do an internet recovery. The problem there is it tries to install El Capitan, but never completes. The count-down timer gets to 0, then goes back up to ~30 minutes. It just keeps doing that for hours and hours.

    The second Apple support guy I talked to said to do a regular restore (CMD+R), but it always goes to internet recovery. I'm guessing there's no restore partition.

    The computer does have Windows 10 installed on to a Bootcamp partition, and that seems to work fine. I just cannot get macOS installed.

    The computer is a mid-2015 15" MacBook Pro. I use the installer Disk Utility to format the Macintosh HD partition. I have used the El Capitan installer terminal set the correct system time. I have tried installing using a different USB port.

    I would greatly appreciate any help.

    Video of El Capitan Internet recovery issue:

    Screenshot of Sierra install issue: http://imgur.com/k79us9q/
     
  2. harmo macrumors newbie

    Joined:
    Oct 23, 2016
    Location:
    Canberra
    #2



    Hi there,



    I found that if time date/time is (very) wrong on your mac, you get this error. To make your life more difficult, booting from an Sierra OS X installer disk/USB drive doesn't necessarily show a clock in the top-right corner of the screen. So if you have the same experience as I did.. it took me a while to notice this discrepancy.



    For me, I disconnected the battery while installing a new hard disk, so my clock was set back to the Apple default (which is years ago)... to fix the time/date I:

    1. Connected to the nearest Wi-Fi/Network connection.
    2. Used the terminal utility in the recovery system (Utility Menu > Terminal) to update the clock using the ntpdate command and specifying an appropriate time server. If you're connected to the internet, you can use the command below, and then restart the OS X installer.

    ntpdate -u time.apple.com

    If you have no internet, another approach is to set the date manually from the command line by using the “date” command string, where date is in the [mm][dd][HH][MM][yy] format, which is Month Date Hour Minute Year without any separation. This looks something like:

    date 0712122318

    Once you've set the time again, you can start the installer again. From experience, I can safely say that it worked fine for me.

    I really hope this helps you (and anyone else who comes across this page).


    Good luck!

    Hamish
     
  3. rkhasda macrumors newbie

    Joined:
    Dec 17, 2016
    #3
    Hi Hamish,

    I was trying to encrypt my mac which caused error in the system. Whenever I was trying to charge my mac, it would hang due to the encryption process. I found a technique in the internet to stop the encryption process through terminal, but I was not sucessful.

    So next, I tried to reinstall os through the recovery partition, but sometimes the Internal Apple SSD showed up and sometime not. So, I installed the OS in my external hdd which removed the recovery partition. After installing I created a USB bootable installer and tried to reinstall the OS in my Apple Internal SSD. Now, I am having the same problem as Nomore. I tried your technique but it still shows up the error. Do you know what other problems can cause this error ? And how to come over it ?

    Thanks in Advance,
    rkhasda
     
  4. todesto macrumors member

    todesto

    Joined:
    Jan 5, 2015
    Location:
    Fullerton, CA
  5. Glee217 macrumors member

    Glee217

    Joined:
    Jun 20, 2016
    #5

    Wow it works!!! now I have 10.12.5 thanks! I actually unplugged the battery from my early 2015 mbp 13" and I typed ntpdate -u time.apple.com on the terminal and reinstalled the OS using the usb drive. Thanks to you or where ever you got the info from!!!!
     
  6. mauriciojornalista macrumors newbie

    mauriciojornalista

    Joined:
    Oct 7, 2017
    #6
     
  7. mauriciojornalista macrumors newbie

    mauriciojornalista

    Joined:
    Oct 7, 2017
    #7

    Thaks!!!! Solve my problem!
     
  8. simone31 macrumors newbie

    Joined:
    Nov 3, 2017
    #8
    If the date solution does not work, it is maybe because some file on your bootable usb drive has not been correctly copied.
    Here are all the steps for a clean install from a usb drive. The solution concerning the bad file on the usb drive can be found at the end of step 4. Installation :

    First be careful, the new macOS versions erase the installer once installed.
    => Copy the installer somewhere else than Applications before launching the install!

    Steps:

    1.Download Sierra from the Purshase tab in the Apple Store. Quit the installer. Copy the installer somewhere else.

    2. Create a bootable usb device
    Format the usb device (needs to be at least 8Go) with a GUID partition
    then, type in a terminal window:
    sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/SierraInstaller --applicationpath /Applications/Install\ macOS\ Sierra.app --nointeraction &&say Done
    => your bootable key is set.

    3. Formatting your mac hard-drive:
    Before your format your hard-drive, make sure that you have copied/backup it on another device! and especially that you have copied the sierra installer on another accessible computer in case installation fails.
    start your mac when pressing cmd R or cmd alt R
    go the disk utility
    choose your hard-drive and erase

    4. Installation:
    shut down your mac.
    insert your bootable usb device
    start your mac and concurrently press alt to be able to boot on the usb device
    in the utility menu open the terminal
    to check the date, type: date
    if not up to date, change it to the day when you downloaded sierra with the following format (month day hour minutes year), type: date MMDDhhmmYY
    quit the terminal
    choose sierra installation
    => if the signature problem still appears:
    shut down everything
    recheck your bootable usb device on your other computer where you kept the sierra installer, by typing in a terminal window:
    diff /Applications/Install\ macOS\ Sierra.app/Contents/SharedSupport/InstallESD.dmg /Volumes/Install\ macOS\ Sierra/Install\ macOS\ Sierra.app/Contents/SharedSupport/InstallESD.dmg
    if files are different, copy the file again by typing:
    sudo cp /Applications/Install\ macOS\ Sierra.app/Contents/SharedSupport/InstallESD.dmg /Volumes/Install\ macOS\ Sierra/Install\ macOS\ Sierra.app/Contents/SharedSupport/InstallESD.dmg
    now you can restart all the steps detailed in 4. Installation. The signature problem should not appear again!
     

Share This Page