Installing OS X on DELL XPS M1330 with SSD

Discussion in 'macOS' started by rshomali, Aug 25, 2009.

  1. rshomali macrumors newbie

    Joined:
    Aug 25, 2009
    #1
    Hi OS X experts,

    The XPS M1330 laptop is one of the most popular laptops to find guides, reviews, solutions for installing different packages of OS X. Yet, I can't get to the installation wizard due to a kernel panic.

    From what I understood from googling, specially through InsanelyMac forums, this kind of panic ( ex. "IOAPIC Version 0x20 Vectors 0:23" ) can be of four causes:
    1) unsupported hardware
    2) unsuccessful ISO burn, bad DVD quality or corrupted ISO.
    3) Incorrect kernel switches on F8
    4) Incorrect BIOS settings

    1- unsupported hardware:
    From the guides and reviews, hunderds of people if not more successfully installed OS X on the M1330 with the same CPU, video card as mine.
    Here is my specs:
    XPS M1330, Intel Core 2 Duo T9300(2.5GHz, 800Mhz, 6M L2 Cache)
    4GB, DDR2, 667MHz 2 Dimm
    128MB NVIDIA GeForce 8400M GS
    SAMSUNG RBX Series 128GB Solid State Drive
    Broadcom BetLink Fast Ethernet
    Dell Wireless 1505 Wireless-N Mini-card
    Dell Truemobile 355 Bluetooth Module (2.0+EDR)
    DVD MATSHITA
    SegmTel High Definition Audio

    2- unsuccessful ISO burn, bad DVD quality or corrupted ISO:
    I downloaded through BitTorrent the following:
    Kalyway 10.5.2
    Leo4All v3 10.5.2
    iATKOS 5i
    iATKOS v7
    iPC 10.5.6. Universal PPF5 Final

    BitTorrent checks the files after downloading, I also checked the MD5 for each ISO and made sure they match with the attached MD5 file
    I tried different DVD brands, different machines to burn the ISO files I even tried to burn at 2x with verifying data after burn.

    3- Incorrect kernel switched on F8:
    I tried many combinations of the following
    -v
    -x
    -s
    -f
    mach_970
    toh
    cpus=1
    paltform=ACPI|XPC86
    busratio=20

    4- Incorrect BIOS settings:
    On my DELL XPS M1330 I have A15 Bios, I tried the following options:
    Integrated NIC - OFF
    Media Card and 1394 - OFF
    SATA Operations - ATA
    Flash Cash Module - OFF
    CPU XD supoort - Enabled (Default)
    Multi Core Support - OFF
    Dynamic Acceleration- OFF
    SpeedStep Enable - OFF
    Virtualization - OFF
    Internal Bluetooth - OFF
    Internal Wi-Fi - OFF
    Internal Cellular - OFF (I don't have WWAN card)

    I tried to play with the above options, turn some on and some off.

    Result:
    I get stuck at the begining of boot process before the installation wizard starts with:
    a) IOAPIC Version 0x20 Vectors 0:23
    b) panic(cpu 0 caller...ACPI AcpiOdFree"@...

    Any Help is appreciated.

    Thanks,
    Roy
     
  2. trance2 macrumors member

    Joined:
    Nov 7, 2004
    Location:
    Quito, Ecuador
    #2
    Easiest...

    Here is the easiest fix... If you want to run Mac OS X then go by a Mac (ebay can net you some good deals). You can pull your hair out, try to hack all day but in the end you are just wasting your time. Mac OS X on a "hackintosh" is not going to run perfectly.

    If you enjoy hacking then carry on... but do not post about it here in the MacRumors forums but rather go over to the forums that deal with specifically that
     

Share This Page