Installing OSX Mavericks Mid 2009 Macbook Pro

Discussion in 'OS X Mavericks (10.9)' started by lovelldr, Oct 30, 2013.

  1. lovelldr macrumors newbie

    Joined:
    Mar 13, 2010
    #1
    Hi guys.

    So, I wanted to upgrade to OSX Mavericks, and downloaded the app on to my OSX Lion.

    But, I wanted to upgrade the HDD currently in there from a 500gb to a 750gb. The 750gb had previously been in a Windows 8 Machine, and is a Western Digital, wd7500bpvt-16hxzt3.

    So, I created the USB installer from the downloaded Mavericks app. I've tried 2 different methods of creating the USB. I've tried using the terminal to create it with the sudo command, and I've tried using the mount of the InstallESD.dmg and creating the usb with that method...

    With both methods, I've managed to installed OSX Mavericks (first time, I had the issue of incorrect image or whatever it was, but got a good download in the end!). However, after it's finished installing, and wants to reboot, it comes up with the grey screen of death, with the apple logo, and the spinning icon to say it's loading.

    I've left it for a couple of hours, but each time, the HDD seems to stop spinning. So, I've powered down the MBP, and tried powering up again. This time, after a short while, the Apple Icon changes to the No Entry icon.

    If I then try loading the USB, it does not show the HDD. I can then either boot via usb to my old HDD, and do a Disk Utility to delete the HDD Partitions, or I've even tried connecting to Windows, and completely removing all partitions, changing back to MBR, and then when re-installing re-confuring to GPT and setting the partitions again. But, it does the same loops.

    I tried resetting the PRAM and NVRAM, and didn't seem to make a change.

    Then, I found out about pressing COMMAND+V on boot, and this is what it sticks to:

    [​IMG]

    This was after a power off, and it gave the No Entry sign... But, I'm getting fed up of trying to do a fresh install!

    Any ideas of what I can do to sort this out???

    Cheers
     
  2. Rj. macrumors newbie

    Joined:
    Oct 30, 2013
    #2
    I'm also having similar issues like you after trying to upgrade to Mavericks from Snow Leopard last week. I also have a Mid 2009 Macbook Pro, I tried various solutions but ended up going back to Snow Leopard. Hopefully we'll find a solution to this problem soon.
     
  3. philly33flyers macrumors newbie

    Joined:
    Jul 14, 2008
    #3
    Good Luck

    Good luck! I really hope you find the answer to this question as I am in the same boat as you.

    I have a mid-2009 Macbook pro with the same exact 750gb hard drive that I upgraded back in the snow leopard days.

    Same exact issue as you when trying to upgrade. Infact, my computer doesn't take any update past 10.8.2.

    I started this thread in hopes of finding an answer to not being able to update to 10.8.3 or beyond but received no responses that solved the issue: http://forums.macrumors.com/showthread.php?t=1559557

    The hard drive is not corrupt as it states as I can install any OS starting with 10.8.2 and prior without any issue at all. Once I try to put anything past that starting with 10.8.3 I start to get the same errors as you.

    The grey screen of death followed by the "No Entry" logo. Disk repair is hit or miss and as I said earlier my disk never gets corrupted with any version prior to 10.8.2 and below.

    Hopefully someone has a solution. I've gone from Snow Leopard to Lion To Mountain Lion 10.8.2 without any issues until the most recent updates and Mavericks.
     
  4. Rj. macrumors newbie

    Joined:
    Oct 30, 2013
    #4
    Yeah, good luck to you all, I hope someone figured it out.
     
  5. scottyd1119 macrumors newbie

    Joined:
    Oct 18, 2012
    #5
    I used Disk Maker X (formally Lion Disk Maker) to create a bootable usb drive and did a clean install on my mid 2009 MBP 17". Its been running fine. It might have to do with the way you're creating the usb drive. According to the creator of Diskmakerx, Apple changed the way it works with the maverick install app. and needs more than just the InstallESD.dmg file to create a usb installer. I highly recommend DiskmakerX. I've used it on Lion, Mt. Lion, and now Maverick with no issues.

    To do the fresh install, just boot up with the usb drive and away you go if using a new hard drive. If you're not going to replace the drive and reuse your current one boot up into recovery and use diskutil to erase the drive first and then boot up using the usb drive.

    Hope that helps.
     
  6. Rj. macrumors newbie

    Joined:
    Oct 30, 2013
    #6
    Thanks for your help and input but I did not create a bootable usb drive, I just went to the app store to upgrade Mavericks and used no other devices but hopefully your solution will help the others who are using a usb drive. In the meantime i'll keep an eye out on these forums, hopefully all of us with these similar issues will be finally upgraded to Mavericks soon.
     
  7. lovelldr thread starter macrumors newbie

    Joined:
    Mar 13, 2010
    #7
    Not that I expect it to make any difference, but I'm just downloading disk maker x now to see if it will do anything different...

    I've also just read about resetting the SMC. So, I will do a reset of SMC and the PRAM & NVRAM... Then, will use the Disk Maker X created USB, and see if there's any difference?!
     
  8. philly33flyers macrumors newbie

    Joined:
    Jul 14, 2008
    #8
    Update

    Just an update to this thread:

    I decided to try to install Mavericks on the old stock 250Gb hard drive that came with my computer. I didn't remove my current WD 750GB hard drive, I just hooked up the old drive with a SATA to USB cable and booted directly to the drive.

    The drive had 10.7 installed on it and the update to Mavericks went flawlessly.

    For some reason I still think it has something to do with the WD drive itself. The OEM drive is a Fujitsu 250GB drive and didn't give me any of the intstall errors I experienced with the 750GB WD drive.

    Unfortuntely this is not a good solution for me as the 250GB drive is way too small for all my data. I am willing to purchase a new drive if that would solve my issue but am not sure which one would be compatible or which ones would cause the same issue as the WD.

    Any other ideas on why the update would work just fine on the Fujitsu drive and not the Seagate drive?

    Could it be the Nvidia SATA controller on the mac itself? This drive was hooked up by USB.

    Thanks for any ideas you guys/gals can come up with.
     
  9. philly33flyers macrumors newbie

    Joined:
    Jul 14, 2008
    #9
    Another Update

    Hey all, just giving another update on what I've tried:

    I updated the EFI firmware to 1.7 on my mid 2009 15" Macbook pro. In the past the 1.7 EFI firmware update was known to cause problems with freezing and constant beachballs so I always stayed at the 1.6 EFI firmware.

    I was able to update the EFI to 1.7 without any issue. This allowed my 750GB WD drive to show up as 3.0Gbps in system information instead of 1.5Gbps.

    After the EFI update to 1.7, I attempted to update to Mavericks and the update performed successfully without any issues at all.

    I have yet to let the computer sleep or wake from sleep so I do not know if I will experience issues in the future, but I was able to get it installed and boot into the OS which is a step further than I was able to get before.

    Hopefully this will help others with the Mid-2009 Macbook Pro.

    I suggest updating to EFI 1.7 before attempting the update.
     
  10. katmeef macrumors 6502

    Joined:
    Jul 20, 2010
    #10
    Hah I remember that problem with efi1.7 on my old 09 MacBook Pro, at the time they even did a spoof about it on family guy :) That has been fixed for a few years now though!

    http://youtu.be/HyA6UXi0v6g
     
  11. Patrick J macrumors 65816

    Patrick J

    Joined:
    Mar 12, 2009
    Location:
    Oporto, Portugal
    #11
    I have the mid-2009 13" Pro. I installed mavericks from the Store and it rebooted, and after 49 minutes it hung with about a millimeter to go on the progress bar. I could hear there was no disk activity. I let it stew for a while and then forced the computer off.
    After restart all worked well, Mavericks is running with no further problems.
     
  12. Rj. macrumors newbie

    Joined:
    Oct 30, 2013
    #12
    I hope it's working for you now. Thank you for a possible solution but I upgraded to EFI 1.7 about 10-15 minutes ago and then I was experiencing freezing and constant beachballs. I downgraded back to 1.6 now and the freezing and beachballs have stopped.
     

Share This Page