Installing Panther with XPostFacto

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Dave1982, Dec 28, 2004.

  1. Dave1982 macrumors newbie

    May 24, 2004
    Not that I am expecting anyone to know, but.......

    Has anyone here been able to install OS 10.3 Panther on a "legacy" PowerMac using XPostFacto? My uncle purchased a copy of Panther (and opened it, thus making it non-returnable), and I have been struggling mightily trying to get it to install on his beige G3 PowerMac (300 MHz) with no success. And most frustratingly, the XPostFacto tech forum is down.

    I was able to install 9.2.2 on his computer without a problem, then installed XPostFacto, and when attempting to install Panther using it, it reports an error attempting to copy the extensions directory and then quits.

    If anyone has gotten Panther to install on one of those computers, I'd appreciate any tips you might have.
  2. crazzyeddie macrumors 68030


    Dec 7, 2002
    Florida, USA
    I would try to format the entire drive start over, if you didnt do that first. Also, if this is a Beige G3, make sure you have a partition within the first 7GB (or is it 8GB) of the hard drive. I've never seen the error copying extensions, could you be a bit more specific?
  3. MacNeXT macrumors 6502

    Jun 21, 2004
    Yeah, I succesfully used it to install Panther on an old PowerBook Wallstreet. I didn't find it to be difficult but iirc I had to use a slightly out-of-date version because the latest one had a bug affecting the Wallstreet. Luckily, I found that out BEFORE I tried the latest version.

    Regarding the tech forum: I just checked it and it's not down. Maybe you didn't notice it's read only. You can only write when you have registered XPostFacto. However, I didn't have a registered version, but I found every question I had to be already mentioned in the forum (or the FAQ, obviously). Maybe a search with your error message gets you something useful.
  4. Dave1982 thread starter macrumors newbie

    May 24, 2004
    Well, I'll try and explain what happened in more detail, but I'm no longer in front of that machine, so I'm not in a position to recreate the error.

    I first installed OS9 (the machine had been running 8.5 prior to my visit), upgraded it to 9.2.2, and got everything working properly under 9. I installed XPostFacto, inserted the first Panther CD, and ran XPF. XPF started copying files to the harddrive, and just as it appeared to finish doing so, it abruptly stopped and reported that it "was unable to complete copying the extensions directory." There was also a second error message after that one, but I don't recall exactly what it was, unfortunately. Something along the lines of installation failed because.....

    And yes, I am aware that the forums are read-only, but I couldn't access the site at the time (I was getting time-out errors). I'll try again and see if I can find something that will help

    The machine has only an 8GB hard drive, so I don't believe it should be necessary to partition it, although if I'd had the right software to do it, I would have (I hadn't even thought to bring it, stupid).

  5. MacNeXT macrumors 6502

    Jun 21, 2004
    I should be sure that it really doesn't exceed the exact limit. Your harddrive might actually be 8,1 GB or someting. iirc, I once created a partition of 7,99 GB and it failed. Then I created a 6 GB parition, just to be sure, and it worked. But I'm not sure this is actualy causing your problems.

    You really should read the tech forum, and you could ofcourse also consider registering your copy and get access to the tech forum.
  6. rock6079 macrumors 6502

    Jan 6, 2004
    i did on one of those old black powerbooks... 233mhz, i had a problem at first, it would boot up and go to a command line type interface and say there was some sort of problem, but i dont recall what it was. i just randomly went into xpostfacto and clicked and unclicked some of those options at the bottom, i think it might have had something to do with video? , it was in the first collumn none-the-less. anywase i got it to work reasonably, at least a lot better than i expected on 233 with i think a 4 or 8 mb video memory
  7. mms macrumors 6502a

    Oct 8, 2003
    Somewhat OT, but...
    Do you really need to install Panther on the original G3? Sure, it's possible with XPostFacto, and I've seen it done. But there's a good reason why Apple doesn't officially support it; it's just far from usable. Even a Lombard (333MHz G3), which is supported, was barely usable for the most mundane tasks. Perhaps you would be better off sticking with OS 9, even if it is less stable.

    My .02.
  8. rock6079 macrumors 6502

    Jan 6, 2004
    actually it was pretty usable on my 233 PB. but i understand what you're saying. i would never try to open (actually i probably don't even have enough HD space to install) photoshop on that computer. os 9 is probably better.

Share This Page