Installing Problem

Discussion in 'Mac and PC Games' started by MacSib, Apr 14, 2011.

  1. MacSib macrumors newbie

    Joined:
    Apr 14, 2011
    #1
    Hey all,

    I have a little problem installing AC2 for mac..
    A while ago I downloaded the game assassins creed2 for mac, I installed it and it would work due to some registration key problems..

    So what did I do? I moved it to thrash and deleted it.

    Just recently I decided to buy myself the actual version of AC2.. So I did, and today it finally arrived. I wanted to install it and my mac said that the file was already installed, and I had to run an uninstall and rereun the installer..
    I tried, but the uninstaller opened a program called 'Terminal' which didn't do anything. So I started googling finding that I had to remove the remaining files in the /Library/Cache Preferences, application support etc. I have removed them all but I am still not able to run the installer...

    What is there left to do? I ran out of options.. Are there a few ways to bypass this problem so I can install or are there places I still be able to find missing snippets which solve the problem?
    thanks..

    (p.s. I don't use time machine...)
     
  2. deadwulfe macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #2
    What was Terminal doing when it opened for the uninstall? Did it have a command prompt, showing your computer name and login name followed by the $ sign, or did it look blank or what?

    Terminal is part of Mac OSX and based on a guess, you closed it while it was doing something. Programs ran through the Terminal interface don't always give you any kind of progress indicator. I would try the uninstall again and give it time to finish.
     
  3. MacSib thread starter macrumors newbie

    Joined:
    Apr 14, 2011
    #3
    Last login: Sat Apr 16 12:54:59 on console
    /Volumes/Assassin\'s\ Creed\ II/UninstallAC2 ; exit;
    MacBook-Pro-van-Casper-de-Haas-7:~ Casper$ /Volumes/Assassin\'s\ Creed\ II/UninstallAC2 ; exit;
    2011-04-16 13:41:28.897 defaults[323:903]
    The domain/default pair of (com.ubisoft.AssassinsCreed2.GameUpdate, execPath) does not exist
    2011-04-16 13:41:28.979 pkgutil[330:903] PackageKit: *** Missing bundle identifier: /Library/Receipts/UM2USBDriver.pkg
    2011-04-16 13:41:29.040 pkgutil[333:903] PackageKit: *** Missing bundle identifier: /Library/Receipts/UM2USBDriver.pkg
    2011-04-16 13:41:29.098 pkgutil[336:903] PackageKit: *** Missing bundle identifier: /Library/Receipts/UM2USBDriver.pkg

    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.

    To proceed, enter your password, or type Ctrl-C to abort.

    Password:



    This is what my terminal said, problem is I can't enter any sort of password, and whenever I hit enter this shows up:

    "Sorry, try again.
    Password: "
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    The password isn't shown as you enter and the "cursor" does not move forward as an indication of entering a password.
    Just enter the password and press ENTER.
     
  5. MacSib thread starter macrumors newbie

    Joined:
    Apr 14, 2011
    #5
    Yes I found it out, and it worked..

    But now a new problem has occurred.. I installed the game and registered online, but when I try to open it it 'quits unexpectedly' and I have no idea why or how to bypass this...
    Because when I had the torrent version (which is now fully uninstalled and gone) It let me open the game.. Then I just didn't have a registry key... which I do now..
    But I have no idea how to let the game open this time...
     
  6. deadwulfe macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #6
    You should try contacting Ubisoft, but in the meantime while waiting for a response from them, my guess would be to try another uninstallation and before reinstalling, do a spotlight search for anything assassins creed related and to check under the /Library/Preferences/ folder in your home folder and the /Library/Application Support/, also in the home folder, to delete anything Assassin's Creed II related and then reinstall.

    It just seems like something from your torrent install is still around somewhere and the legitimate copy doesn't like it.
     

Share This Page