Installing SBS on 3.1.2 3GS pinwheels nonstop

Discussion in 'Jailbreaks and iOS Hacks' started by utwarreng, Oct 15, 2009.

  1. utwarreng macrumors 6502

    utwarreng

    Joined:
    Aug 8, 2009
    #1
    After successfully jailbreaking to 3.1.2 with pwnagetool 3.1.4 I try and install SBSettings, and the terminal screen goes through the normal install, but once I tap "Restart Springboard" it just pinwheels nonstop. Let me preface the rest of this by saying that I have been Jailbreaking this phone since 3.0, and do have my SHSH on file with Saurik.

    The first time I did it I was at home, and just redid the restore with my cracked 3.1.2 firmware. Today though I'm at work, and unable to do that. I've tried holding down the power button for over a minute, and nothing. The display isn't refreshing, and still says "10:38am", and the battery % has not gone down from the 95% it was displaying, leading me to think it is all locked up; except for the "pinwheel" icon is still running in the middle of the screen.

    I did a search, but have not been able to find any reported problems with 3.1.2 and SBS, but I'm still wondering if anyone else is having these problems. The last thing I noticed from the terminal was "Couldn't stat("/System/Library/LaunchDaemons/com.bigboss.sbsettingsd.plist"): No such file or directory"
    Does this help at all? I haven't paid attention to previous installs to know if that is normal or not. Should I have installed BigBoss first?

    Thanks in advance for any help.

    P.S.
    I have had no problems with installing other things from Cydia, but SBS and any related SBS things cause this to go nonstop.
     
  2. utwarreng thread starter macrumors 6502

    utwarreng

    Joined:
    Aug 8, 2009
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    Have you tried a full reboot of the phone since the install ?
     
  4. jamesapp macrumors 6502a

    Joined:
    Mar 7, 2008
    #4
    The same thing happened to me. I don't know if it was sb settings, sb settings was one of the first things I downloaded from cydia, but once in cydia I got a spinning wheel and my iPhone wouldn't respond. I tried hitting home button, and then I tried to hit the power button. But my phone wouldn't let me power off. I was told that when cydia says restart springboard to just hit the home button and respring from sbsettings. I guess I got lucky and was able to restart my phone before having to restore my phone. Hope that helps.
     
  5. utwarreng thread starter macrumors 6502

    utwarreng

    Joined:
    Aug 8, 2009
    #5
    I wasn't able to use the power button to turn it off, and since the phone had 95% battery life left at the time, and it was the start of my day, I wasn't able to let the battery run down and die before I would need it again. I may try installing SBS again Tuesday night before I go to sleep, and see if I can run the battery down if it stops. I tried holding the power button down for almost a minute multiple times, and nothing.

    Jamesapp, when you say that you were "able to restart your phone before having to restore" how did you restart it? Did you just wait for the battery to die, and then plug it in?
     
  6. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #6
    I've had this happen twice. I restored the first-time then held home and power for 30+ seconds the second-time.
     
  7. utwarreng thread starter macrumors 6502

    utwarreng

    Joined:
    Aug 8, 2009
    #7
    Didn't that just put you into DFU mode?
     
  8. utwarreng thread starter macrumors 6502

    utwarreng

    Joined:
    Aug 8, 2009
    #8
  9. utwarreng thread starter macrumors 6502

    utwarreng

    Joined:
    Aug 8, 2009
    #9
    After using cydelete to get rid of Icy I have had no problems. I installed SBS last night with no issues at all.
     

Share This Page