Installing Snow Leopard: error when restoring dmg to USB flash drive

Discussion in 'macOS' started by Youngfun, Sep 17, 2012.

  1. Youngfun macrumors newbie

    Joined:
    Sep 17, 2012
    #1
    Hello everyone,

    I'm trying to install Snow Leopard (yep... cause I have a 2008 MBP) through a USB flash drive.
    My flash drive is 8 GB (but in reality 7 GB) and the DMG image is 6.2 GB.
    With "Disk Utility" I have erased the flash memory with "Mac OS extended (Journaled)" file system.
    Then I wen on the "Restore" tab, I set the DMG image as source, and the flash memory partition as destination, then I checked the box "Erase destination".
    Then I clicked on "Restore" and it gave me this message: "Restore error - Not enough space on /dev/disk1s2 for the restore".
    (The messages I write here could not be the exact strings as I'm not using the OS in English, I just translated them)
    Why not enough space??? The DMG image is 6.2 GB and the flash memory is 7 GB!!!

    If instead I un-check the "Erase destination" it says: "Restore error - Operation not supported by the device".

    Instead of erasing the USB drive, I also tried to partition it, with "Mac OS extended (Journaled)" file system, and with GUID partition table, but the same thing happends.

    I've also tried to do "Analyse image for the restore" but it's useless.

    I hope someone could help me to find a solution, otherwise I have wasted money to buy a 8 GB flash drive...

    Thanks everyone.
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    The DMG is 6GB, but did you check the uncompressed size? Double-click it so it mounts and Get Info on the mounted disk. It's probably about 8.4GBs, IIRC. There may be a way to resize it, I can't recall, but since a DL-DVD is 8.5GBs, the image made of it is the same size, even though the amount of data stored on it may be less.

    On second thought, try Carbon Copy Cloner to make the transfer. It may not care how big the image is, only how much data is being transferred.

    jW
     
  3. Youngfun thread starter macrumors newbie

    Joined:
    Sep 17, 2012
    #3
    Hi Mal,
    Thank you very much, I have solved the problem thanks to your suggestion.

    Indeed I mounted the DMG file and it was 7.3 GB, exceeding for a little bit my 7 GB flash drive... So when using Carbon Copy Clone I excluded the optional installations, thus saving space, so I succeeded to restore the image to the USB drive.
    But that was the image of a OS X 10.6.7, which came together with a MacBook Air 2011, and coudn't be installed on my MacBook Pro 2008.

    So I took the DMG image of a retail version OS X 10.6 and when mounted it was smaller: 6.74 GB. So I succeeded mount this latter image to the flash drive, even without excluding the additional files.

    Now I have this 10.6 happily installed, but I have to do a lot of updates :p

    Thank you very much, Mal!
     

Share This Page