Resolved Installing Snow Leopard shouldn't be this frustrating!

Discussion in 'MacBook' started by ubertome, Nov 28, 2012.

  1. ubertome, Nov 28, 2012
    Last edited: Dec 10, 2012

    ubertome macrumors newbie

    Nov 28, 2012
    Hey guys,

    I'm new to the forum here, so I'm sorry if I'm repeating an old problem but I've spent many hours scouring the web about my problem with no success.

    My problem: I want to install a Retail Mac OS X 10.6.3 SL onto a new SSD on my Macbook2,1 (2006) but I just can't get it to install.

    I've tried installing from the DVD drive but at around 28 minutes it fails. Since it's old, I figure the DVD drive is faulty; after ripping an image of the disk on another mac with no problems, I can say I'm pretty sure of it.

    That being the case, I've also tried installing via USB Flash Drive but I can't for the life of me get it to boot from USB! For that I used both Carbon Copy Cloner and Disk Utility to restore the install disk as a backup. I set it to boot from USB under Startup Disk, and I even blessed it:
    bless -folder /Volume/MyVolume/System/Library/CoreServices -setBoot
    but it still refuses to boot.

    PRAM has also been reset several times but it didn't seem to help.

    My Macbook Specs:
    1.83Ghz Intel Core 2 Duo
    2.25GB RAM
    8x Combo Drive
    60GB 5400RPM SATA ===> OCZ Agility 3 120GB SSD

    I just don't know what's wrong :confused: I really appreciate any help and I hope others with the same issue share what worked/didn't work.

  2. aziatiklover macrumors 68030


    Jul 12, 2011
    Location: and
    Have SL on a usb and boot it from there? What does it do when you tried?
  3. Jaben3421 macrumors regular

    Sep 18, 2011
    Did you make sure your MacBook can support that type of SATA? I think the new agilites are SATA 3, but your MacBook has SATA 1 if I'm not mistaken. I don't know. Might be wrong. I can't remember if the hard drives have backwards compatibility. My guess, however, is that your MacBook can't support it.
  4. boneskid1 macrumors member

    Sep 19, 2012
    The ssd is not an issue it very well might be your drive but instead of trying to boot from usb , plug the USB into the macbook and go into finder within the USB drive and find the DMG for SL and click on it. It should allow you to install from there if not I apologize for being wrong.
  5. ubertome thread starter macrumors newbie

    Nov 28, 2012
    Thanks for the prompt reply. I put Snow Leopard onto USB and tried to boot it with that, but it's completely ignored at startup.

    From what I've read online, SATA should be backwards-compatible... it'll just be bottlenecked

    I figure it wouldn't hurt to mention all the facts, just in case. Do you mean the Snow Leopard icon on the installer itself? I tried clicking it to restart my mac with the installer, but that wouldn't work either :(
  6. T5BRICK macrumors G3


    Aug 3, 2006
    If you have a 2nd Mac with a known good optical drive, put the SL DVD into it and reboot this computer in target disk mode(press and hold "T" before it chimes).

    Use a firewire cable to connect your MacBook to the other computer and boot the MacBook while holding down the option key.

    I've done this in the past and the disk in the other computer shows up on the connected computer as if it were connected to an external optical drive. It may not still work this way, but it's worth a shot.
  7. DewGuy1999 macrumors 68040


    Jan 25, 2009
    You didn't say if the USB you were referring to was a hard drive or a flash drive, I don't know about if this applies to flash drives or not but some external hard drives (both Firewire and USB) are not bootable.

    When trying to install from the DVD did you try running Disk Utility on the SSD to see if it checks out as okay?

    When trying to install from the DVD did you try formatting the SSD (Mac OS Extended Journaled w/GUID Partition Table) with Disk Utility before installing the OS?

    Lastly, it's always possible that the OS X 10.6.3 disc is defective.
  8. chrfr macrumors 604

    Jul 11, 2009
    Make sure that your USB drive is partitioned as GUID and formatted as Mac OS Extended Journaled, then restore the DVD to it.
  9. ubertome thread starter macrumors newbie

    Nov 28, 2012
    I'm using a Kingston USB Thumbdrive and yes, I have formatted it with GUID partition table and Mac OS Extended Journaled. As far as I can tell, the SSD and disc are in good working order as well.

    I haven't tried booting with another mac, but I'll give that a shot.

    @DewGuy1999 That's definitely possible, apparently it's happened before too:

    Anyway I'll try both methods and post my results here soon.
  10. minifridge1138 macrumors 6502a

    Jun 26, 2010
    How are you selecting the USB drive when you want to start off of it?

    Are you holding the 'option' key at startup?
  11. ubertome thread starter macrumors newbie

    Nov 28, 2012
    Yes, I tried starting up holding the ALT/Option key but the usb drive never shows up there. Holding 'C' doesn't work either.
  12. T5BRICK macrumors G3


    Aug 3, 2006
    Have you tried the target disk mode I mentioned above?
  13. ChrisMan287 macrumors 6502


    Nov 18, 2012
    Once the internal drive shows up, remove then reinsert the USB drive and see if it shows up.
  14. DewGuy1999 macrumors 68040


    Jan 25, 2009
    Like I said earlier the drive may not be bootable by a Mac, maybe you could try installing from the DVD again?
  15. ubertome, Dec 7, 2012
    Last edited: Dec 7, 2012

    ubertome thread starter macrumors newbie

    Nov 28, 2012
    Great success!!

    I got it to work!

    So I went out and bought an HDD docking station and formatted an old SATA1 drive lying around with GUID partition table, OS X extended journaled, etc. and lo and behold, it finally boots from USB.

    Everything else was smooth sailing :D

    I'm convinced that USB booting on this macbook needs to be from some powered USB device like an external drive, which is weird because the USB ports read about about 5V the moment I boot, according to my multimeter.

    Anyway thank you guys for your help, hopefully this thread saves someone else a lot of frustration.
  16. chrfr macrumors 604

    Jul 11, 2009
    That shouldn't be the case, unless something is broken on the computer. I have seen some USB thumb drives which are more than a little erratic, though.

Share This Page