Installing SSD...ugh....

Discussion in 'MacBook Pro' started by peetyrd, Oct 8, 2011.

  1. peetyrd macrumors newbie

    Joined:
    Feb 11, 2011
    #1
    I have a 2006 macbook pro core duo. I bought an OCZ SSD drive and physically installed it. So I boot it up and get the question mark...so I realize it is unformatted. I tried booting from my snow leopard DVD...no marbles. I try to do target disk mode to my other mac....no marbles.

    Is the only solution to take the drive back out, buy a hard drive enclosure, hook it up to my other mac and reformat that way? Is there any way to format it while being inside the macbook pro itself.

    Thanks for the help!
     
  2. awer25 macrumors 65816

    awer25

    Joined:
    Apr 30, 2011
    #2
    Booting to a disc should work. If it's not, swap the old one back.
     
  3. Runt888 macrumors 6502a

    Joined:
    Nov 17, 2008
    #3
    Are you holding down the "c" key when booting?

    Try holding down option to see all the boot devices - your cd drive should show up.
     
  4. peetyrd thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #4
    I know my mac OS X install CD works, tried it with another machine.

    When holding down the C button, I still get the question mark.

    When holding down the option key, I get a picture of a lock. Doesn't show me the option to boot from the CD.
     
  5. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #5
    Seems like you drive is a dud. It shouldn't be preventing you to boot off of a CD. Did you also try the grey disc that came with your mac?
     
  6. peetyrd thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #6
    Ok so the craziest thing has to be going on.

    I put the old hard drive back in. It booted fine. I verified the super drive is working. So then I took the SSD and put it in my newer(2009) MBP, was able to boot from DVD, format it, and install snow leopard on to it. Great!

    So now I put the SSD back in to my 17" Core Duo MBP(2006). Get the question mark screen. hmm........ So I put the old hard drive back in it. Boots up fine. I put the SSD in the 2009 MBP. Then I put it in target disc mode. I go in to the start up disk preferences of my 2006 MBP and tell it to restart from the SSD target disc mode. LO and Behold, it actually boots the SSD through firewire target disc mode. What the heck is going on!?!?!?!?!?!

    I also tried putting in the stock 320GB 5400RPM drive that came with the MBP 2009 in to my MPB 2006, and it gave me the question mark.
     
  7. peetyrd thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #7
    What ridiculousness. The problem was with the "Firmware Password Utility." Apparently it disables the start up short cut keys, hence why pressing "c" didnt even let me boot up from the DVD....and it also prevents from booting up from a different disk. Disabled that, and everything works fine.
     

Share This Page