Installing the 2.0 beta firmware on iPod touch/iPhone

Discussion in 'iPod touch Hacks' started by boramora, Apr 7, 2008.

  1. boramora macrumors member

    boramora

    Joined:
    Mar 7, 2008
    #1
    I'm not sure if there have been other posts about this, but it seems that some people have been having trouble with installing the 2.0 firmware on their iPod touch/iPhones. Keep in mind I will only be providing help for installing the firmware, assuming you already have a copy of the 2.0 firmware. I will not provide links or references as to where you can acquire a copy of it.

    To install the 2.0 firmware, you must have a copy of both the 1.1.4 and 2.0 firmware.

    1. Download the iPod touch/iPhone PwnageTool v1.0 at http://www.iphone-dev.org/

    2. When you have the application running, click "Browse .ipsw". Select the 1.1.4 firmware and allow the application to recognize it.

    3. Once it has recognized it, click iPwner and follow the instructions.

    4. Now click "Browse .ipsw" again and select the 2.0 firmware. Let it recognize it.

    5. Click "IPSW Builder" and let the application create a new custom firmware with the original 2.0. You should probably save it separately from where your original firmware is located.

    6. Now you can exit out of the Pwnage Tool. Open iTunes.

    7. Put your iPod touch into restore mode (hold power and menu buttons till it restarts and when it does, let go of the power button but keep holding the menu button till the Connect to iTunes shows up).

    8. Select the new custom 2.0 firmware you just created (alt/option + Restore).

    Your iPod touch/iPhone should now have have the 2.0 firmware loaded in it! Congrats.

    I did this on my MacBook Pro Intel Core2Duo with Leopard 10.5.2, 2gb ram. I'm not sure how similar it is on 10.4 Tiger or on a PC. Please let me know if I have forgotten to include any steps or if you have anything to add. :rolleyes:

    Edit: I have not tried the new 2.0 beta version (build 5A240d) that was just released 4/8/08.

    Good luck! :D
     
  2. imachack macrumors newbie

    Joined:
    Mar 24, 2008
    #2
    does your music work?

    i tried using the 2.0 beta and my music did not play...
     
  3. boramora thread starter macrumors member

    boramora

    Joined:
    Mar 7, 2008
    #3
    Hmm, that's strange it worked for me, although the only major problem I had was the UI was extremely laggy and some of the apps would randomly crash.

    I've heard a lot about the "no music playing" problem and it seems that most people have fixed it by restoring and reinstalling the firmware again.
     
  4. SirithX macrumors 6502

    SirithX

    Joined:
    Feb 21, 2007
    Location:
    San Francisco
    #4
    Cool, but is there any practical use to it at this point? Does it fix any bugs in our current firmware?
     
  5. Mikey B macrumors 65816

    Mikey B

    Joined:
    Jan 4, 2008
    Location:
    the island
    #5
    Music and Video's play, but not if they're DRM protected. Purchased media, except from iTunes Plus, is a no-go. Maybe on the new build perhaps.
     
  6. boramora thread starter macrumors member

    boramora

    Joined:
    Mar 7, 2008
    #6
    Well I haven't seen any major fixes to current bugs on the 1.1.4 firmware, but the only backdraw is that it doesn't have the iTunes Store or the App Store cause Apple deemed them useless in the beta 2.0 firmware so they were taken out after the first seed. The only reason why I see anyone would put the 2.0 firmware on their iPod touch/iPhone would probably be cause they either wanna show off 2.0 or want the Microsoft Exchange feature.

    I haven't gotten Installer to work on mine since there isn't full support in 2.0 yet. So there's really nothing special about the new firmware lol I'm probably gonna downgrade back to 1.1.4 since I miss all the extra applications from Installer...

    I have been able to play all my purchased music/videos from iTunes and the wireless store though.
     
  7. razorianfly macrumors 65816

    razorianfly

    Joined:
    Oct 16, 2007
    Location:
    Cheshire, United Kingdom
    #7
    The 2.0 beta firmware is for developers.

    Thats right, Developers, only. Its meant for development on a non every-day iPod/iPhone. It has no use for the general iPod touch user, especially installing this on an iPod touch or iPhone you use daily. I'm part of Apple's Developer Program, and have a legal copy of the latest 2.0 firmware build in my possession. At it's current state, it's nothing worth talking about. If you use this method, please, when the firmware expires, don't come crying.

    R-Fly
     
  8. brandonzar macrumors regular

    Joined:
    Mar 18, 2008
    #8
    WPA2 encription

    Does the 2.0 firmware support wpa2 encryption? that is about the only reason I could see going through all the trouble.
     
  9. boramora thread starter macrumors member

    boramora

    Joined:
    Mar 7, 2008
    #9
    Well razorianfly aren't you special. Go get yourself a cookie.

    Uh, brandonzar I'm not sure if it supports WPA2 encryption cause I haven't tried it... but I think you're better off sticking with 1.1.4 firmware cause it's a lot more stable than 2.0. When I was using the beta firmware, certain applications would constantly crash and it got really laggy overall.
     
  10. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #10
    By the way, holding home and power and letting go of power puts your iPod touch in DFU mode which is NOT "Restore Mode". DFU mode is "Device Firmware Upgrade" and there's no way out of DFU without a restore... so don't use DFU mode.

    Now, to put your iPod touch into "Restore Mode" or "Recovery Mode" all you have to do is unplug your iPod touch, then hold down Home and plug it back in while still holding down home until your iPod shows the "Connect to iTunes" indicator.

    Why don't people understand that when Pwning your iPod, you need to use Restore Mode and not DFU.
     
  11. boramora thread starter macrumors member

    boramora

    Joined:
    Mar 7, 2008
    #11
    I dunno, letting go of the power button has brought me to the "Restore Mode" and I have been able to do anything I want like downgrade/fresh reinstall/upgrade/etc. I guess most people have been doing it and it's been working... :confused:
     
  12. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #12
    Nope, that's not restore mode, it's DFU mode... trust me. Restore mode is when you hold home while plugging the iPod into the computer.
     
  13. boramora thread starter macrumors member

    boramora

    Joined:
    Mar 7, 2008
    #13
    Haha alright, well either way it still worked when I held down the power/home buttons. I was able to do whatever in that mode.
     

Share This Page