Installing VMware Tools in Ubuntu 8.10

Discussion in 'Mac Apps and Mac App Store' started by gusanitoverde, Nov 18, 2008.

  1. gusanitoverde macrumors 6502

    gusanitoverde

    Joined:
    Jun 12, 2003
    Location:
    Northern California
    #1
    I am totally new to Linux. I have a MacBook Pro Intel 17" with Dual booth using Bootcamp (Mac/Win). I have been a Mac/Windows user and became very good at using both. Now, because of my job, I need to learn as much as I can and as fast as I can about Linux, specifically Ubuntu and later open Suse. So, I decided to target Ubuntu first.

    My first question is:
    What is the best way to run Ubuntu in a Mac?

    I decided to use VMware Fusion 2.0 since all resources I found in the internet were quite complex or needed some degree of understanding in "Linux" language and modisms, which I am totally new at.

    So, I ventured, I installed Ubuntu 8.10 and I was pretty successful, but now I am left to install VMware tools. I have no idea how to do it. I searched all over the internet. I have not been able to find anything to help me. I don't speak "Linux" but I am willing to learn.
    My second question is: Can anyone give me some light in how to install VMware tools in Ubuntu?

    This may well be the very first useful resource for newbies in installing Vmware tools and Ubuntu. I could not find anything simple enough to help me.:(

    Thanks!
     
  2. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #2
    To install VMWare Tools in Ubuntu while using VMWare Fusion:

    Go to the "Virtual Machines" menu and select "Install VMWare Tools". A volume named "VMWare Tools" should appear on your desktop.

    Double click this volume and a window should appear with an item named "VMwareTools-x.x.x-xxxxxx.tar.gz" where "x.x.x-xxxxxx" is a set of 9 alphanumeric charactes. For example, mine says "VMwareTools-e.x.p-116369.tar.gz". Copy this item to your desktop.

    Now let the fun begin. Assuming you are using GNOME, go to the "Applications" -> "Accessories" menu and open "Terminal". At the prompt type:
    Notes:
    1. If you see <tab>, this means press the Tab key. This will cause the shell to attempt to autocomplete the command/file name.
    2. The ` character in the below apt-get command is the backtick; it is just to the left of the '1' key (assuming you are using a standard US keyboard layout)
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install linux-headers-`uname -r` build-essential
    cd Desktop
    tar -zxvf VMWareTools-e.x.p-<tab>
    cd vmware-tools-distrib
    sudo ./vmware-install.pl
    While the script is running, go ahead and just hit the enter key where-ever it asks you for something; the default values should be fine for you. Once the install completes just restart the VM and you should be good to go.
     
  3. gusanitoverde thread starter macrumors 6502

    gusanitoverde

    Joined:
    Jun 12, 2003
    Location:
    Northern California
    #3
    I am stuck...

    But yet, I am excited. Thanks for the reply!

    I am getting somewhere, let me tell you what I did:
    I installed VMWare tools from the menu. A CD image appeared. I double clicked in the CD and the item VMwareTools-7.9.3-128865.tar.gz appeared. I copied this folder to the desktop. A box like icon with a lock appeared.

    I opened terminal (I am using GNOME)

    I wrote in terminal:

    "sudo apt-get update" and pressed enter, and there were quite a bit of processes started. At the end, I entered:
    "sudo apt-get upgrade" I hit enter again and some more processes went on... Later, I entered the following:
    "sudo apt-get install linux-headers-`(my username) -r build essential" and pressed enter and some more processes went on, however among all what was there, it read somewhere: "Package linux-headers is not installed, so not removed". All else went fine. It ended with "Setting up build essential (11.4)..."

    After, I did "cd Desktop" and it changed to
    "(my username@mycomputername):~/Desktop$

    After this, I typed "tar -zxvf VMWareTools-e.x.p-" and pressed "tab" and it did not complete the file, so I wrote:
    "tar -zxvf VMWareTools-e.x.p-<tab>" and it read: "bash: syntax error near unexpected token `newline`

    After that I tried all and couple combinations of the rest of the script and nothing worked. I kept on receiving errors like "No such File or Directory" "Error is not recoverable: exiting now"

    What am I doing wrong?
     
  4. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #4
    uname should be uname not your username; it's a utility that gives info about your current system. Also if the tab completion does not work, just enter the filename by hand
     
  5. gusanitoverde thread starter macrumors 6502

    gusanitoverde

    Joined:
    Jun 12, 2003
    Location:
    Northern California
    #5
    Done!

    Thank you. I had to play around a little bit with the codes.

    It was a wild ride. I am done now and I thank you for taking the time to guide me.

    There was a part that it asked where to install the binary files, and I also learned that by just pressing "enter" the default values kick in.

    I guess I am now in the "Linux" world and I got to find my way to get familiar with the OS. I hope I get to like it. So far it has been quite difficult...
     
  6. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #6
    I found VMWare Tools to be rather unreliable with Ubuntu 8.10. The mouse pointer in particular loses focus. As a result I've removed them for the moment. Awaiting news of a fix before I try installing them again.
     

Share This Page