Installing Windows 7 64-bit on iMac problems! Please help!

Discussion in 'Windows, Linux & Others on the Mac' started by mrobison, Dec 24, 2009.

  1. mrobison macrumors member

    Joined:
    Sep 18, 2007
    Location:
    AR
    #1
    Okay, I'm about to go crazy over this. I have a 24" mid 2007 iMac; 2.4 C2D. I purchased a legal msdn download of Windows 7 Professional; 64-bit with my education discount. I currently have Windows XP on my bootcamp partition. I knew that I would have to do a clean install, but I've been unable to do anything. First, I burned the ISO onto a dvd using microsoft's utility. When I restarted and booted, it came up with:

    1.

    2. Select CD-ROM type

    ...and hangs there. I looked up a lot of stuff, and then burned the ISO in another imaging app. I've tried installing from boot camp setup assistant, booting from the disk, even tried installing inside of VMWare Fusion. Nothing has worked. I would do the USB thumbdrive installation, but from what I understand, the EFI doesn't permit you to boot from USB. Any help would be greatly appreciated. Thanks so much, and Merry Christmas!
     
  2. Zortrium macrumors 6502

    Joined:
    Jun 23, 2003
    #2
    Here's how I upgraded the Boot Camp partition on my iMac from Vista 64 to W7 64 (via a clean install using an MSDN iso image):

    1. Used Boot Camp Assistant to delete my Boot Camp partition.
    2. Burned the iso image to a DVD (think I used Toast, might've used Disk Utility, but definitely didn't use any kind of Microsoft utility for this).
    3. Recreated the Boot Camp partition with Boot Camp Assistant, then restarted and installed from the DVD. The installation went off without a hitch and everything worked fine.

    I definitely didn't need any voodoo to get this to work -- my guess is that your DVD isn't getting burned correctly.
     
  3. sivart6 macrumors newbie

    Joined:
    Dec 30, 2009
    #3
    i had the same issue as the OP. It doesn't seem to be anything to do with the way the DVD is written... it looks like the Win7 64-bit installer does not recognise or have the drivers for the DVD drive in the iMac.

    i gave up and installed the 32-bit version instead, which means I can only use 3GB of my 4GB installed mem! :(

    i was waiting for the official Apple support for Win7, but I doubt thats going to make a difference. Would be great if someone had a solution!
     
  4. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #4
    Win 7 64 bit is the first MS OS to support EFI. However,the installer doesn't like the 32 bit only EFI on some Macs.

    Search the forums to find the directions to modify your install disc to make this work right.

    B
     
  5. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #5
  6. All Taken macrumors 6502a

    Joined:
    Dec 28, 2009
    Location:
    UK
    #6
    Install rEFIt on your mac here: http://downloads.sourceforge.net/refit/rEFIt-0.13.dmg?use_mirror=

    Make a bootable Windows 7 USB drive

    Hold ALT whilst booting the Mac and simply select the USB Drive

    Problem Solved

    Regards
     

Share This Page