Installing Windows XP - Boot Camp partion not recognized

Discussion in 'Windows, Linux & Others on the Mac' started by TiggerDick, Apr 18, 2009.

  1. TiggerDick macrumors newbie

    Joined:
    Apr 18, 2009
    #1
    I know there are hundreds of posts on this topic, but after 2 days of searching/googeling online I still have no solution:

    I have a brand new iMac 3GHz (I am a Mac newbie) and I originally installed parallels and Windows XP Prof with no problem - except that the performance was so poor most of my games didn't work.

    So I thought about using Boot Camp, created a 99GB partition with Boot Camp and tried to install Windows XP Prof SP2. I admit it, the first time I didn't bother reading any instructions since I though the Mac is so intuitive (yeah right...). It went horribly wrong and I went through and solved 20 different problems thanks to posts, but still no success.

    So reading all the instructions and posts I narrowed the problem down to one issue: Windows does not recognize the Boot Camp partion (I only see one). Now I know I have a bootable Windows CD SP2 since I used it before in Parallels, and I have already erased all the empty space on the hard disc so that my many unsuccessful previous attempts don't interfere with Windows, but I am simply stuck that I cannot select the correct partition during the Windows installation. I have used the disc utility to check in Mac OS that everything is OK and from the Mac side the partition looks just fine.

    Help please :)
     
  2. steveza macrumors 68000

    steveza

    Joined:
    Feb 20, 2008
    Location:
    UK
    #2
    If you run disk utility and check the format of the partition you want to use for boot camp. You could reformat the partition as FAT (MS-DOS) which should be detectable from the XP installation. Just BTW I've never tried this so it is a suggestion not a promise of success.
     
  3. TiggerDick thread starter macrumors newbie

    Joined:
    Apr 18, 2009
    #3
    Thanks Steveza, just finished the formatting (was already MSDOS FAT but hey) including zeroing out (just to be sure - took 2h) but to no avail. What is so strange is that what Windows shows makes no sense at all, cause it shows one partition with 130GB, while in Mac OS there are 2 partitions (360GB and 99GB) :confused:
     
  4. Matek macrumors 6502a

    Joined:
    Jun 6, 2007
    #4
    So what exactly DO you see in the partition list after the windows installation starts?
     
  5. RedRaven571 macrumors 65816

    RedRaven571

    Joined:
    Mar 13, 2009
    Location:
    Pennsylvania
    #5
    I thought FAT partitions were limited to 32 GB?
     
  6. bkap16 macrumors member

    Joined:
    Jan 11, 2009
    #6
    No- that's just a bug in the partitioning tool on the Windows CD. They can actually be 2TB.
     
  7. GeeYouEye macrumors 68000

    GeeYouEye

    Joined:
    Dec 9, 2001
    Location:
    State of Denial
  8. evilted macrumors newbie

    Joined:
    Dec 9, 2007
    #8
    Not sure if this is the same issue I had, but the version of Windows XP Pro I installed on my partition does not include an option for FAT32. So after I'd have Boot Camp partition the volume, I'd attempt to install Windows XP onto the pre-created volume partition without reformatting. I did this instead of trying to format NTFS because I had read someplace that Boot Camp wouldn't let OS X copy files from an NTFS Boot Camp partition. The XP setup would never complete as it would hang on the first reboot.

    Anyway, the fix for me was to reformat the partition as NTFS, and then install. Once I did that, Windows XP booted correctly.

    Prior to reformatting, when I tried to boot from the Boot Camp volume I'd get some error (which I don't recall), Windows setup wouldn't continue, and I'd have to boot back into OS X to do anything.

    Hope that helps.

     
  9. Illicit macrumors 6502

    Joined:
    May 14, 2007
    Location:
    Waterloo, ON
    #9
    That is incorrect.
    FAT32 is limited to 32GB on all formats after Windows 2000 and up to 127GB on Windows 98.

    HFS+ and NTFS are limited to 2TB.

    src: http://technet.microsoft.com/en-us/library/cc938432.aspx
     
  10. dthudon macrumors newbie

    Joined:
    Oct 20, 2009
    #10
    I am having this exact issue with my mbp when attempting to install WinXP pro. Did you finally come up with a solution?
     
  11. GeeYouEye macrumors 68000

    GeeYouEye

    Joined:
    Dec 9, 2001
    Location:
    State of Denial
    #11
    Boy aren't they looking silly now with their "2 TB is a reasonable practical limit" bit...
     
  12. CTeditor macrumors newbie

    Joined:
    Oct 25, 2009
    #12
    Hey guys I had this exact same problem which ultimately formatted my entire drive and I had to start all over, reinstalling Everything! It sucked but I was a noob and didn't know what was going on.
    Anyway, had my own thread going on another mac site
    http://www.macworld.com.au/forums/index.php?showtopic=5491

    I found a solution eventually, which was my XP disk didn't actually contain SP2, so I slipstreamed SP2 into the XP Pro disk and everything went perfectly along with what the manual says.

    I see you are 100% sure its an SP2 disk that you are using, and you've used it before so maybe there is another problem- a scratch or corrupt file somewhere? Either way I suggest you look at this link to make sure again
    http://forums.macnn.com/109/alternative-os-reference/322430/really-xp-sp2-disc-how-tell/

    My friend used the disk he gave me to put windows on his MB Air, but he used fusion ware or something, so maybe bootcamp is the only one that requires SP2 disks? I don't know, but somehow he did it and I couldn't until I slipstreamed it.

    Check out the threads and see how you go
     

Share This Page