Installing XP with SP3 in bootcamp 3.0

Discussion in 'Windows, Linux & Others on the Mac' started by msalganik, May 9, 2011.

  1. msalganik macrumors newbie

    Joined:
    Jun 21, 2009
    #1
    Hi all,
    I'm trying to install XP in a bootcamp partition on my unibody MBP. Running 10.6.7. The XP disc that I have already has SP3 on it. Thus far I've gotten through the entire installation, up until windows (blue install screen) reboots the computer. At this point it tries booting off of the CD again and takes me back to the original install/repair screen. If I take the CD out and hold down the option key when restarting I can pick between OSX/Windows, however if I pick windows it just tells me disc error, press any key to restart (i end up having to hold down the power button actually). Is what I'm experience related to SP3 or am I just screwing up something? Sorry if it's something basic and thanks for any help.
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    Which Unibody MBP?

    The latest ones only support W7 out of the box, so this could be a contributing factor.

    B
     
  3. msalganik thread starter macrumors newbie

    Joined:
    Jun 21, 2009
    #3
    older

    actually mine is the first version unibody MBP... the one with the removable battery/HD and express card slot. I got it back in the leopard days and upgraded to SL once it came out. So am I screwed or can I install windows with SP3 (already on the disc) in bootcamp 3.0 on this older machine? If there's any tricks that'll make it work I'm all ears.
     
  4. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
  5. msalganik thread starter macrumors newbie

    Joined:
    Jun 21, 2009
    #5
    once XP gets done the initial copying of files for installation (blue screen) it goes to restart which is normal I think (haven't played with Windows in a LONG time). Once it restarts however, it doesn't pick back up with the installation but rather boots of the XP cd and takes me back to the blue screen where I can either do a fresh install of XP or enter the windows repair console (which is useless). I also tried holding down the option key once the MBP restarted and entering the windows partition (which does show up) but whenever I do that all I get is a black screen with the message "disc error. press any key to restart". I get this message regardless of whether or not the XP cd is in the drive and pressing any key doesn't actually work for restarting... I actually have to hold down the power button to turn it off.
     
  6. maccompaq macrumors 65816

    maccompaq

    Joined:
    Mar 6, 2007
    #6
    I tried to install XP Pro SP3 on my Core i7 Hackintosh, and it would not install. So I bought Windows 7 Home 64 bit, and the Install worked fine.
     
  7. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
    #7
    Does XP SP3 have native Intel AHCI/RAID support?

    If its missing the controller drivers that's probably what the error is.
     

Share This Page