Installing Yosemite on a Hybrid Drive in a Mac Mini

Discussion in 'Mac mini' started by wncmacs, Feb 25, 2015.

  1. wncmacs, Feb 25, 2015
    Last edited: Feb 25, 2015

    wncmacs macrumors newbie

    Joined:
    Jan 6, 2004
    #1
    I recently purchased a Mac Mini (mid-2010) and upgraded the hard drive to a Seagate ST1000LM014-1EJ164 1 terabyte drive. The company I purchased the machine from installed the drive and put OS X 10.7.5 (Lion) on it.

    I set up the machine and went in to the Application Store to upgrade to Yosemite (10.10). The file downloaded, but would not install. It gave an error message and suggested I re-download the file. I did this 2 more times to no avail. I tried to re-boot into Lion but the machine would not start up.

    I then built a bootable USB flash drive with the Yosemite installer. I started up the Mini off the drive and tried to start the process. It failed. I then went to Disk Utility, selected the drive (which shows as a 1 terabyte drive) and formatted it. I tried to re-install again. It failed.

    I'm looking at Disk Utility now and it shows 1 terabyte drive labeled as Media and as being formatted Mac OS X (Journaled). There are 2 other drives showing:

    disk2 that has OS X install ESD that is formatted Mac OS Extended

    disk3 OS X Base System that is formatted Mac OS Extended

    There are no indications as to the size of either of these disks, nor can I format them.

    My questions:

    1. Do I have to use something other than Disk Utility to format the drive for OS X Yosemite?

    2. Am I wasting my time trying to get Yosemite to run on the computer? It has 8 Gb of RAM with the hybrid drive.

    3. Do I need to buy any other software packages to make this thing work?

    According to Disk Utility, the drive is listed as 1 partition that is GUID. It is shown at the top of the screen in Disk Utility, with the disk2 listed underneath as an Apple Partition Map at 5.40 Gb Mac OS Extended Journaled. The disk3 is labeled as a startup partition and that I cannot erase it. It is 1.29 Gb in size. and is Mac OS Extended.

    The error message when the Yosemite install fails says "An error occurred while extracting files from the package "Essentials.pkg". Quit the installer to restart your computer and try again."
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Boot to your USB installer.
    Run Disk Utility, select the drive (the line that shows the model number, etc.)
    Then click the Partition tab
    Click the Partition Layout drop-down, and select 1 Partition.
    Click OK.
    Click on Options, and make sure it is set for GUID format, and not something else. Click OK again.
    Name the new partition, if you like.
    Finally, click the Apply button.
    That will reset the partitions on the drive to just one. That process should finish within 10 seconds or so, then Quit Disk Utility, which will return you to the main screen.
    Select Reinstall OS X, and follow the prompts. Should go this time.
    If you get an error - write the exact error down, and come back here.
     
  3. wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #3
    I ran the Disk Utility. There is 1 partition listed, but Disk Utility shows 2 other "disks" in existance:

    disk2 OS X Installer ESD (5.4 Gb that is an Apple Partition Map)

    disk3 OS X Base System (1.29 Gb that I am not allowed to format)

    When I run the installer, it quits and posts the following error message:

    "An error occurred while extracting files from the package "Essentials.pkg". Quit the installer to restart your computer and try again."
     
  4. wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #4
    Also, I am not allowed to modify or unmount disk2 or disk3.
     
  5. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    Yes
    Exactly right... and, you don't need to do anything with those disks.
    If you follow the steps in my post above, that will clear all the other partitions on your hard drive. disk2 and disk3 will disappear when you change Partition Layout to 1 Partition, then click Apply.

    Be sure that you don't have other storage devices attached to your mini.
    Particularly, unplug external USB hubs, or any firewire device. Leave the only device attached your display, mouse/keyboard, and your USB flash drive, connected directly to the mini.

    If that doesn't change anything - how did you make your USB installer?
    Perhaps yours is not properly made, and you need to do that again. Make sure that you follow good directions to do that, or even easier, download DiskmakerX. That does a great job (in one step without needing to use the terminal for anything)
     
  6. wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #6
    Disk Utility Update

    I did the 1 partition of the drive with GUID and Disk Utility says it is complete. But, in the list of drives on the left, the drive2 and drive3 are still showing in the list. They apparently were not removed.

    I am using a USB installer that worked to install Yosemite on 2 MacBook Pros successfully. Does the Mac Mini require some different configuration in order to install from a USB onto it?

    Finally, I keep reading about TRIM. I understand that Apple disabled this in Yosemite through kext. Do I need a TRIM program to work with this drive or does that even matter here?
     
  7. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #7
    TRIM is not relevant to what you want to do.

    Your mini should be OK for any supported OS X install, the same as installing on any other supported Mac.

    Does your Disk Utility show those "other" partitions directly underneath the drive listing? Or, are those other partitions listed underneath a divider line in that window? If under a divider, you can just right-click, and choose Remove from the list in the right-click window.

    (probably not what is affecting your install, anyway)

    Restart your mini, Reset PRAM while you restart (hold Option-Command-P and R until you hear the boot chime sound. Keep holding the same 4 keys until you hear the boot chime 2 more times, then release the keys. Restart again holding the Option, so you can boot to the installer :D
     
  8. wncmacs, Feb 25, 2015
    Last edited: Feb 25, 2015

    wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #8
    No Option To Remove

    I have opened Disk Utility and the two drives appear below the line. The first in the list, disk3, has a Disk Image icon by it. If I right-click on the disk3 or the named drive (OS X Install ESD), all I am allowed to do is either eject or unmount. There is no option to remove, and if I choose either eject or unmount, I am told that the action has failed that the disk could not be unmounted. The same thing happens for disk4, which has an icon of the Earth atop a drive and is named OS X Base System, except it gives me *no* option to do anything to this part of the disk.

    I am having no problem getting the drive to format in Disk Utility, but it will not allow me to get rid of these other two disks.

    I have tried to zap Parameter RAM but the machine continues the boot and does not re-set the PRAM.

    The drive appeared to be working fine when I first started it up. It had Mac OS X 10.7.5 on it and I originally tried to install Yosemite through the App Store, giving up after it kept telling me that the file was corrupt in some manner. That is when I used the USB drive that I built with Yosemite for installs on MacBook Pros to boot the system.
     
  9. DeltaMac, Feb 25, 2015
    Last edited: Feb 25, 2015

    DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #9
    The two drives are just virtual images, and I think you can ignore those.

    Plug in to an internet connection, and try the internet recovery. That will likely allow you to reinstall Lion, or it could give you a quick method to update the system installed on your mini.
    If no system is now installed, you can boot to the internet recovery system by restarting while holding Command-R. You should see a world icon, telling you that you mini is connecting to Apple's servers for the download.
    When that finishes booting, you will see a download screen, telling you what OS X version will be downloaded. Could be Lion, and if you are OK with that, just let it install. Could also be a newer system, sometimes others will be presented, but you shouldn't expect more than Lion at this point.

    Check this firmware, download and try to install.
    http://support.apple.com/kb/DL1479

    I suspect that you will get an error, because it has already been updated with that firmware - so not a real problem. However, it may also install, giving you an EFI update that might help with upgrading to 10.10.

    Some non-Apple keyboards may NOT support the boot commands, like resetting PRAM.
    Typically, those are the generic replacement keyboards, and may have a Windows key, rather than a Command or Apple key.
    If you have one of those generic USB keyboards, you might want to try a different USB keyboard, Apple-brand if you have one available.
     
  10. wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #10
    I have managed to get to the Internet install. It is going to let me install Lion. After I check the firmware per your recommendation, should I try the Yosemite install again? Should I do it through the App Store or should I use the USB drive? I am re-building it with DiskmakerX.
     
  11. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #11
    I have had good success with DiskmakerX. I have used all OS X systems that are supported through that software, and for Yosemite, I have probably installed on 10 different Macs. You should expect it to work for you, too.
    However, if there's STILL a problem with that, then you have an alternative with the App Store, too.
    Come back when it's working (or not :D )
     
  12. Che Castro macrumors 603

    Joined:
    May 21, 2009
    #12
    Wnc I have a similar problem with the same 2010 Mac mini , so let me use your thread


    I upgrade the mini to an ssd , the heat sensor cable that connects to drive is just glued on , and I removed the cable from the old drive to put on the ssd , it would not stay on just kept falling off , so I used regular scotch tape
    Did not have electrical tape around
    Is that going to be a problem over time ? I used the strong clear tape like the ones you use for boxes

    The black cover that was over the original drive the adhesive on that was not strong either,so I did not put that on the ssd

    The mini is working good now
     
  13. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #13
    I had multiple and multiple installation fails with Yosemite and finally found a thread saying to restore my RAM to the stock configuration.
    In my case I dropped from 4GB back down to 2GB.
    After that the next installation attempt finished without a problem.
    After Yosemite was installed I was then able to bump it back up to 4GB.
     
  14. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #14
    I ran into this problem on a different occasion with Snow Leopard.
    I did restart the computer and the installer picked up from where it left off.
    It would chug along for a few more minutes and then I'd get the error again.
    It took about 4 restarts but the installation finally finished successfully.
     
  15. wncmacs, Feb 25, 2015
    Last edited: Feb 25, 2015

    wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #15
    Update

    DeltaMac, here is what I have tried.

    First, I tried Internet recover Wednesday afternoon. I managed to connect, but after 2 1/2 hours, the installer did not finish and I shut down the Mac Mini and took it home from work.

    There, I attempted to connect to the Internet Recovery again. After zapping the PRAM, I got the machine to try and connect, but it was never successful.

    I also created a bootable USB stick using DiskmakerX. It said it was completed successfully, but it does not show up in the list of bootable drives when I select to choose a startup disk. I put the drive together on my MacBook Pro (which runs Yosemite). Might that be my problem?

    So, basically, I am now at a standstill. I still haven't managed to get an OS installed not it. I have a Leopard installer on DVD which will boot the Mini, but I don't want to run that OS.

    I haven't tried the firmware update. I thought I would copy it to my USB drive and try to install it, but since the drive won't show up on the Mini, it is useless.

    What should I try next?
     
  16. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #16
    Does your USB with the Yosemite installer show up in Startup Disk when you insert it in your MacBook Pro?

    If it DOES show up on your MacBook Pro, then there should be no reason it shouldn't show up on your mini.

    Also, try to boot from your USB installer on the MacBook Pro. You are just testing to see if it will boot successfully to ANYTHING. Booting to that drive won't change anything until you actually choose to continue with the install.
    You can simply quit from the installer, and restart to its normal boot system.
    If the boot is successful, move the USB installer back to your mini.
    Shut power off on the mini, then insert the USB drive.
    Reset PRAM on the mini. Let the boot chime sound twice before releasing the keys, and then immediately hold the Option key so the startup disks will appear. You should see your Yosemite installer - which may be listed there with a different name - maybe something generic like EFI boot. Choose it, then press Enter.
    Do you boot to the installer this time?
    Continue on with that...
     
  17. wncmacs, Feb 26, 2015
    Last edited: Feb 26, 2015

    wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #17
    Update...

    I managed to get the USB stick installer to work, but the install failed, giving the previous error message.

    I zapped the PRAM and held down the option key. Surprisingly, I now had an option of choosing an OS X 10.10.1 Recovery disk in addition to my USB stick installer. I chose the recovery disk and continued the boot. It took me to where I could do a new install of OS X Yosemite through the rescue disk. I selected that and it has begun downloading the installer from Apple. Right now, it says it will take 42 hours to complete (I'm hoping it's being overly conservative with its estimate) but I'm thinking that by installing from the drive, things will go better for me.

    I will post what happens next.
     
  18. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #18
    OP wrote above:
    [[ What should I try next ]]

    If you continue to "get nowhere", I would advise you to take the new drive OUT of the Mini, and re-install the original drive back into it (assuming the drive was working when you took it out).

    Now, you will have a bootable Mini -and- the new drive "in your hand".

    Next, get a USB3/SATA docking station, put the new drive into it, connect it to the Mini, and work on it "from there".

    I -ALWAYS- advise to "prepare and test" a new drive via an external connection BEFORE one attempts to install it internally.

    Can save going through a whole lot of trouble, as your problems in this thread illustrate....
     
  19. wncmacs, Feb 28, 2015
    Last edited: Mar 1, 2015

    wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #19
    I purchased the Mini used from a retailer who upgraded the RAM to 8 Gb and the hard drive to the Seagate terabyte hybrid drive, so I don't have the original RAM and hard drive for the machine. They put OS X 10.7.5 on the drive originally, but I wanted to upgrade it to Yosemite so I would have all my machines on the same OS in the house. According to Apple, the Mini is perfectly capable of running Yosemite, and I was thinking that the 8Gb RAM upgrade would help it run the OS more smoothly. After having a discussion with a technician, the company told me I could send it back to them, but if there was nothing wrong with the drive, I would be charged for a software install (no details on the cost, but the company is a couple of hundred miles away.). I think they should fix it and I'm not sure I'll ever do business with them again (they are a rather notable used Mac reseller), but I feel that this is something I should be able to accomplish. I've been on Macs for 22 years, from OS 6 through Yosemite and I have installed OSes on a variety of machines. I've never had anything like this to happen. This is the first hybrid drive I've ever tried to use.

    I don't think there's anything wrong with the drive. It formats and verifies OK, so I hate to send it back due to the potential cost, plus I don't want 10.7.5 on the machine...I want 10.10.

    The installer fails at some point during the download. The Mini puts the screen to sleep so I don't ever catch the particular time she failure occurs. I just know it never finishes installing. I have tried using both a wireless and an ethernet connection to my network to try and expedite the process but nothing has worked.

    The Mini was seeing the USB install flash drive that I created to install Yosemite, but now, it isn't even showing up in the list of bootable drives. I don't know what happened there. I haven't removed it from a USB port on the machine since it managed to complete a partial install of Yosemite and gave me the recovery drive partition to boot off of, but it now doesn't show in the boot list where I can choose the startup disk.

    Early this morning, I am trying the install again. I have opened the log window and left it running in an effort to see where things are hanging up. This whole thing has been crazy. It makes me wish I had never purchased the hybrid drive in the first place.
     
  20. wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #20
    Update

    The installer is still failing.

    Today, I'm directly connected to a gigabit ethernet connection to the web with the Mini. I'm trying the Internet install again. It stops and says that Yosemite failed to download, to use the Purchases page to try again.

    I'm trying to do this as a Reinstall Mac OS X from the emergency disk. Any ideas on how I can get around this roadblock?
     
  21. marzer macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #21
    Given all installation attempts have failed, Internet recovery and external stick, I suggest there's either something wrong with the drive or a flaky data interface, like the SATA channel. Use you MBP to install to an external device: HD/SSD, SD card or USB stick will do for the sake of troubleshooting. Or if you've got the cables (FW or TB) put your MBP in Target Disk mode and boot the mini from its drive. The point is, I'd do whatever I could to get the mini to boot a full installation even if it was external or an older OS version.
     
  22. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #22
    Curious if this might help -https://bensmann.no/changing-system-date-from-terminal-os-x-recovery/

    You have tried most "fixes" that others have reported.

    I agree with the last post.
    I would ALSO be suspicious that the company that refurbished your "new" mini didn't actually install OS X on the installed hard drive, but used another, external method, then transplanted the new hard drive into the mini that they wanted to sell, with the system already installed. That would save them some time, if they don't have to install software while assembling a system.

    Did the company include a copy of Lion, so you can at least reinstall if you had problems with the system? I have a hunch that they did not, as you haven't said anything about that yet.

    Even though you don't want to run Leopard - it's still an option that you can choose, just to see if you can install ANY OS X system.

    Anyway, I would try once more, resetting partitions with Disk Utility, and reinstalling OS X. Do that, after the hard drive is prepared (partitions in Disk Utility), then power off, restart with a PRAM reset, then continue on booting to the DiskMakerX USB installer. THEN, continue with the OS X install.
    I would also try it after reseating the RAM that is installed, or even removing one of the sticks just to try an install (RAM seems to be mentioned fairly often as a fix for the error that you see!)
     
  23. wncmacs, Mar 2, 2015
    Last edited: Mar 2, 2015

    wncmacs thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    #23
    I installed Yosemite on an external USB hard drive, then booted the Mini off the drive.

    The Mini booted into Yosemite fine.

    I then logged in to the App Store to download the Yosemite install to see if I could make it work from the external USB drive. The Mini was connected to the Internet with Ethernet. It began the download, pulled down about 200 MB of the installer, and then said it couldn't complete the download, to try from the Purchases pane of the App Store again. I re-started the download. It again failed. I then switched to wi-fi for the connection and re-started the download. It again failed with the message to again try downloading from the purchases page. After two more attempts, the App Store froze.

    I rebooted the machine using the external drive and it again starts up the machine to Yosemite.

    What would be stopping the download to the external drive?

    After another attempt, the Mini had a kernel panic and re-started. It rebooted with the USB drive into 10.10.

    This is beyond infuriating!!!
     
  24. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #24
    I hear you about the infuriating.
    In my experience, install issues (where you get common errors like yours) can often be caused by RAM problems. The RAM may even test good, but something about how the installer uses the memory can be a real test of the memory, and some will just fail. And, I think the kernel panic that you have had a few times is also pointing to the memory.
    Replace both sticks. Make sure that you get memory that is known to work in Macs. Crucial is a good choice here. And, just to make sure, you know that the memory sticks should be PC3-8500 SODIMMs
    Good stuff here.
    If you already have Crucial, or another known brand, those will generally have a good warranty, and you can ask for replacements directly from Crucial, etc.
     
  25. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #25
    OP wrote:
    [[ I installed Yosemite on an external USB hard drive, then booted the Mini off the drive.
    The Mini booted into Yosemite fine. ]]


    Please try what I describe below before going further. You are flopping around and around like a fish out of water.

    You now have (on the USB flash drive) an OS that can boot up the Mini, is this assumption correct?

    OK, then....
    ......Stop right where you are now.
    No more downloading installers, no more "attempts to install" to the Mini.

    Instead, do this:

    Boot up from your flashdrive, get connected to the net if you haven't already done that.

    Go here:
    http://bombich.com/download
    ... and download the most recent version of CarbonCopyCloner.
    CCC is FREE to download, and it is FREE to use for the first 30 days.

    Put CCC onto your USB flashdrive.

    Open Disk Utility and ERASE the internal drive.
    You don't need to "zero out" the drive, just do a quick erase so that it's empty.

    Now, launch CCC.
    Set the flashdrive as your "source", set the internal drive as your "target".
    Choose to do a "full clone".

    Now, let CCC do its thing. It will "clone" the contents of the flash drive to the internal drive.

    When done, power down, all the way off, and remove the flash drive.

    Now, reboot, and hold down the option key and KEEP HOLDING IT DOWN until the startup manager appears.

    Do you now see the existence of a "bootable drive" on the internal?
    If so, click on it with the pointer to select it and hit return.

    What happens now?

    Again, I strongly suggest you try EXACTLY what I've posted above being going further....
     

Share This Page