Instant Hotspot Feature No Show in Wifi Menu

Discussion in 'iOS 8' started by nobodyjustwalks, Oct 20, 2014.

  1. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #1
    Just wondering if anyone else is having trouble with the Instant Hotspot feature. I have T-Mobile, do have hotspot as part of my plan, have both wifi and bluetooth on, am signed in to the same iCloud account.

    Lastly, I tried using the feature with Personal Hotspot both set to "on" and "off"....and nothing. Still donʻt see my phone in my Wifi drop down menu.

    Suggestions?? Thanks!
     
  2. kage207 macrumors 6502a

    Joined:
    Jul 23, 2008
    #2
    I can get the Personal Hotspot to work.

    I haven't been able to get Instant Hotspot to work. I've forced my phone and Mac to forget my WiFi. I still don't see. I've even followed the support document by Apple. No luck.
     
  3. nobodyjustwalks thread starter macrumors regular

    Joined:
    Jan 23, 2013
    #3
    Right. Same here, I can (and know how to use) get Personal Hotspot to work. But not Instant Hotspot. All my settings seem to be correct. Wonder whatʻs missing??
     
  4. mattdub619 macrumors newbie

    Joined:
    Sep 17, 2014
    #4
    I was having issues with it on 8.0.2. It seemed to work right after rebooting the iPhone. Then after a few minutes the iPhone would no longer show in the wireless chooser on the MBA.

    Updated iPhone to 8.1 and now it appears to be working better. With the hotspot feature turned off and the phone display off it shows pretty consistently in chooser.
     
  5. nobodyjustwalks thread starter macrumors regular

    Joined:
    Jan 23, 2013
    #5
    Thanks for your response. Instant Hotspot was not available in iOS 8.0.2, as stated on Appleʻs website. I also just updated from 8.0.2. Itʻs suppose to be implemented in iOS 8.1. Or so they say. hahah...


    Good to hear that with the Hotspot feature turned off and phone display off it is showing up in your Macbook Airʻs Wifi menu. Would you mind uploading a screenshot of your wifi dropdown?
     
  6. iDac macrumors member

    iDac

    Joined:
    Sep 12, 2014
    Location:
    France
    #6
    I'm in the same boat here.

    Updated to 8.1 on both iPhone and iPad, still no Instant Hotspot.

    I can use Personal Hotspot, but can't see the iPhone as a separate hotspot ( with 3G signal and battery level)...
     
  7. lazarusr macrumors newbie

    Joined:
    Jul 31, 2013
    #7
    Is there actually any official statement from Apple that confirms that Instant Hotpsot is in iOS 8.1?
     
  8. nobodyjustwalks thread starter macrumors regular

    Joined:
    Jan 23, 2013
    #8
    Finally~!

    Okay so Iʻve got this thing working:

    1. You need to have the Personal Hotspot feature as part of your cellphone plan. I do with T-Mobile.

    2. Donʻt know why, but I had to toggle my iPhone and rMBP Wifi "ON" and "OFF" a few times to get things going. Instant Hotspot finally started working after power-cycling my iPhone and reactivating Wifi and Bluetooth.

    3. Yes, Wifi and Bluetooth both need to be enabled for Instant Hotspot to work.

    4. Make sure Wifi and Bluetooth are both "ON," but Personal Hotspot is "OFF." Donʻt try to use the Instant Hotspot feature with Personal Hotspot set to "ON" on your iPhone. It seems, Instant Hotspot is made to work, only if Personal Hotspot is set to "OFF." Explanation at the bottom of my post.

    5. This is the lucky part I guess, but if you have the right hardware and nothing else is "bugging" out. If you look in your Wifi drop-down menu you will see a section directly below "Turn Wifi On/Off" labeled: Personal Hotspot.

    6. As weʻve all seen, this section will display "____name___iPhone" then off to the right, signal strength indicator dots, LTE, battery display, circular links (representing hotspot).

    7. Choose your iPhone from the Personal Hotspot section in your Wifi drop-down menu.

    8. Hopefully if all goes well, your Mac should connect to your iPhone. ;)

    9. Key step for me was, I think, power-cycling my iPhone "OFF" and "ON" after the update. Go figure...:rolleyes:

    Interesting Observations >>>

    I noticed that, now, if I go into Settings > Personal Hotspot, and attempt to toggle Personal Hotspot "ON," it immediately turns Wifi "OFF" on the iPhone. Iʻm assuming that since both the iPhone and MBP are communicating with each other via Bluetooth, that the iPhone defaults to shutting down Wifi on the iPhone as this is how the Instant Hotspot feature is supposed to work.

    If you turn "OFF" Bluetooth on both your iPhone and Mac, then youʻll once again be able to toggle Personal Hotspot "ON" and "OFF" on your iPhone. And then of course youʻll see it show up normally in your Wifi drop-down, along with any other Wifi networks your Mac detects.

    Hope this helps!
     

    Attached Files:

    • 1.png
      1.png
      File size:
      102.7 KB
      Views:
      832
  9. kenkamm macrumors regular

    Joined:
    Oct 25, 2008
    #9
    What are the mac hardware requirements for this? I'm using an old machine - late 2008 macbook pro.
     
  10. nobodyjustwalks thread starter macrumors regular

    Joined:
    Jan 23, 2013
    #10
  11. lazarusr macrumors newbie

    Joined:
    Jul 31, 2013
    #11
    I'm still getting nowhere with this.

    rMBP late 2013 - OS X Yosemite 10.10
    iPhone 6 - iOS 8.1 - contract permits tethering/personal hotspot (I use it all the time)

    bluetooth and WifI turned on on both devices

    Personal Hotspot off on the iPhone

    Lots of switching on and off of devices, wifi, bluetooth, rebooting.

    Nothing happens.
    BTW, Mac to iOS AirDrop (which I suspect is a related feature) works just fine.

    nobodyjustwalks - do you think there is something else you did to get this to work that you didn't mention?

    Whatever, this is hardly Apple 'it just works' territory.
     
  12. cjake macrumors member

    Joined:
    Sep 12, 2014
    #12
  13. RangerXML macrumors regular

    Joined:
    Jul 4, 2009
    #13
    Darn it. AT&T likes to block this kind of stuff from me.
     
  14. nobodyjustwalks thread starter macrumors regular

    Joined:
    Jan 23, 2013
    #14
    I agree with you. It certainly isnʻt "It Just Works," more like "Get It To Work" and then if youʻre lucky things will be okay.

    It seems youʻve tried everything I did. The only thing that worked for me was turning my iPhone OFF and ON again. Then like magic, it suddenly appeared in my Wifi drop-down.

    If anything else, give it some time. Perhaps itʻll somehow kick on for you as well. Good luck!
     
  15. kenkamm macrumors regular

    Joined:
    Oct 25, 2008
    #15
  16. Antoni Nygaard macrumors 6502a

    Antoni Nygaard

    Joined:
    Jun 23, 2009
    Location:
    Denmark
    #16
    Handoff and instant Hotspot requires:

    Macbook Air (2012 or newer)
    MacBook Pro (2012 or newer)
    iMac (2012 or newer)
    Mac Mini (2012 or newer)
    Mac Pro Late (2013)
     
  17. tklein macrumors newbie

    Joined:
    Oct 20, 2014
    #17
    That's certainly true. I STILL can't get this to work on my system.

    I actually have the "Personal Hotspot" section on my Wifi dropdown and my phone is there. Bluetooth is active and obviously I'm using the correct hardware and software (iOS 8.1 and Yosemite on a 2014 MacBook Pro and iPhone 6)... It just won't connect. I keep getting the error message: Failed to enable Personal Hotspot on "Tim's iPhone" - Check to see if the tethering device is turned on and in range of your computer.

    Of course, the device is turned on and in range. I know how this is SUPPOSED to work because it worked fine between my iPad and my iPhone... WorkED being the key phrase there... it was perfect and smooth on 8.0.2; Even turning Personal Hotspot back off once the iPad disconnected. NOW, the iPad is only sporadically able to connect and it leaves the Personal Hotspot on once it's finished. Interestingly, I can use the iPad to turn on Instant Hotspot and since it no longer turns Personal Hotspot off on my phone, I can then connect my MacBook, all while leaving my phone in my pocket.... I don't think this is what Apple had in mind though so I'd really like to get this functioning correctly.

    ---
    Tim
     
  18. kage207 macrumors 6502a

    Joined:
    Jul 23, 2008
    #18
    Still doesn't work for me. :/

    I know I have tethering on my plan. I know it should work as I have a 2012 MBA and an iPhone 5s.
     
  19. nobodyjustwalks thread starter macrumors regular

    Joined:
    Jan 23, 2013
    #19
    Hmm..not following what you meant by turning ON Instant Hotspot using iPad. If it leaves Personal Hotspot ON, on your iPhone, and youʻre then connecting your Mac to your iPhone, because Personal Hotspot was left on by your iPad, then this would be the normal way to connect correct?

    If I am understanding correctly, then yes, youʻre right, itʻs still not functioning properly. Itʻs frustrating alright. Please post back if youʻre able to figure it out.

    ----------

    And youʻve power-cycled your phone and reactivated Wifi and Bluetooth? And then tried again?
     
  20. 8CoreWhore macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #20
    Just works

    Apple has their heads up their xxx. Turn off Hotspot if you want "hotspot" to work. How the heck are ordinary people supposed to figure this stuff out? Nothing works. 150 billion in the bank, buying dozens of companies, but we have to put up with hair pulling nonsense.

    If it doesn't work, it's because the one leg you're standing on while patting your head is the wrong leg.
     
  21. nobodyjustwalks thread starter macrumors regular

    Joined:
    Jan 23, 2013
    #21
    HAHAHA....after reading your post, I realized how ridiculous it is to turn off Hotspot to enable Hotspot.
     
  22. lazarusr macrumors newbie

    Joined:
    Jul 31, 2013
    #22
    Well I finally got it to work. I 'fiddled' with just about every setting I could find. It suddenly appeared when I was changing the name of my iPhone in General... About... Name... I don't know if this is coincidence or not.

    But, oh boy is it buggy. The name of my iPhone is now back to 'Robert's iPhone' but in the drop down menu on my rMBP network settings it is just called 'iPhone' (which is not helpful). Also when my iPhone shows that I am connected to a 3G network, the rMBP shows it as LTE (which is wrong whatever naming convention you prefer).

    For me, it makes no difference whether Personal Hotspot is set to on or off on the iPhone. But if Personal Hotspot is off, it turns it on and then seems to turn it off again a little while after the hotspot session is finished.
     
  23. tklein macrumors newbie

    Joined:
    Oct 20, 2014
    #23
    I was basically just joking, but yes, it would be the "normal" way to connect. I was just pointing out that, if I have all 3 devices, I could manage to connect "Without having to remove my phone from my pocket" (as the Apple sales pitch goes).

    And Yes, I've tried toggling, resetting, restarting just about everything I can. I've also logged out of my iCloud account on all the devices (deleting all the settings when asked) then back in because this helped me when I had issues a few weeks ago with getting my email accounts to all sync back up... So far, still no go.

    I'm working from a coffee shop right now but when I get home later I'm seriously considering the dreaded "Restore" option on my phone and maybe even the MacBook. I'm not sure why this bothers me so much since I usually have the phone sitting right next to me when I'm working and turning "Personal Hotspot" on is just about the easiest thing in the world... It does though so I'm sure I'll stupidly end up logging at least a few more hours on the issue...

    ---
    Tim

    ----------

    Interesting... I went through this phase at one point. Something I did (I believe it was when I reset my network connections from the General Settings menu) changed my phones name to just "iPhone" too. I ended up renaming it back to Tim's iPhone but my Wifi dropdown kept showing it as just "iPhone" for nearly another half hour until it suddenly switched.

    Unfortunately, it never started working though. I just keep getting the same message that it can't enable the hotspot.

    ---
    Tim
     
  24. nobodyjustwalks thread starter macrumors regular

    Joined:
    Jan 23, 2013
    #24
    Oh! loll....didnʻt catch that. Youʻre right though...Iʻm not sure why it bothered me so much that it wasnʻt working either, when I could activated it the previous way very easily.

    One thing Iʻm curious about, and Iʻve posted this recently on the 10.10 forum, is how do these Wifi dependent features work at your local coffee shops, libraries, and schools? I know the Instant Hotspot feature isnʻt working for you, but are the others?

    Call handoffs and non-imessage text messages?

    thanks!
     
  25. tklein macrumors newbie

    Joined:
    Oct 20, 2014
    #25
    Ok... This seems to have helped me a bit.

    As I mentioned above, at one point my phone was renamed to just "iPhone"... I didn't do it manually in the settings like you did but it happened automatically. I reset it back to Tim's iPhone and continued to have problems.

    Just now, I logged out of iCloud, then reset my network settings and then logged back into my iCloud account. After that the phone was renamed back to just "iPhone". At this point, Instant Hotspot worked. I was able to activate it from the Wifi dropdown and it turned Personal Hotspot on. When I disconnect though, Personal Hotspot doesn't seem to have any idea I've disconnected. It not only stays on, but the blue banner is still flashing that there is "One Connection" nearly 15 minutes later. Needless to say, it also doesn't shut Personal Hotspot off as I think it should (at least that's the way it worked from my iPad to my iPhone for the past couple weeks when I was on iOS 8.0.2).

    I'm going to give it a while longer to see how long it takes for my phone to realize there's no one connected then I'll try changing the name back to Tim's iPhone and see if it still allows me to connect as an "Instant Hotspot".

    ---
    Tim
     

Share This Page