Instant Hotspot, Handoff & Continuity

Discussion in 'iOS 8' started by michelg1970, Oct 22, 2014.

  1. michelg1970 macrumors regular

    michelg1970

    Joined:
    Jul 26, 2011
    Location:
    Gouda - The Netherlands
    #1
    Dear All,

    Since yesterday I am having a Windows-deja-vu.

    iPhone 6 Plus on iOS 8.1
    rMBP Late 2013 on OS X 10.10

    Both handoff enabled, both logged into same iCloud account, both have bluetooth and wifi on.

    Did all the resets I have found on this forum and on the internet, logged out and in into iCloud on both devices, turned off and on wifi etc, in all various sequences.

    - SMS Relay is working (now)
    - Calls from rMBP are working
    - Continuity (picking up safari e.g. on the other device) is working

    BUT, WHY ON EARTH CAN'T I GET Instant Hotspot working?

    My rMBP sees my iPhone in the wifi network list but every single time I get the message:

    " Failed to enable Personal Hotspot on "Michel's iPhone 6 Plus" Check to see if the tethering device is turned on and in range of your computer "

    Could anyone be so kind to tell me what I am missing???

    Thanks!
    Michel
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    I noticed that if you tap on your iphone hotspot from a Macbook or iPAd it doesn't enable the hotspot feature on the phone itself. Is the hotspot feature enabled on your phone before you try connecting to it?
     
  3. michelg1970 thread starter macrumors regular

    michelg1970

    Joined:
    Jul 26, 2011
    Location:
    Gouda - The Netherlands
    #3
    Ya well - that's the confusion a bit.

    If I keep it turned of on my iPhone then the iPhone shows up on my Mac in Wifi as a separate item also showing signal strength, battery life and network: a Personal Hotspot, to which the connection fails.

    If I switch on the personal hotspot feature on the iphone then the iPhone shows up on the Mac in Wifi as just one of the wifi networks.

    I thought I read a few times that INSTANT hotspot requires the iPhone to be not into personal hotspot mode. Otherwise, there is nothing new because this already worked since iOs 5 or 6 as far as I can remember....
     
  4. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #4
    Youʻre right. For Instant Hotspot to work, it requires that the Personal Hotspot feature be set to OFF. Then you will see it show in your Wifi drop down as weʻve all seen in the demo.

    Try this....I had the feature working before a carrier update resulted in it not working again, and then I was able to fix it....again.

    Like you, I performed all the resets to no avail, so I connected my iPad to my iPhone and that went through fine. Then I tried my laptop again, and voila, it connected as usual. Weird, but it worked yesterday, and Instant Hotspot is still working today.
     
  5. michelg1970 thread starter macrumors regular

    michelg1970

    Joined:
    Jul 26, 2011
    Location:
    Gouda - The Netherlands
    #5
    Will give it a try. I feel pity for all those people without an iPad if this is really the fix. Will report later. Thanks for now.
     
  6. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #6

    Oops! Wasn't even thinking you might not have an iPad to try this with. Apologies! Since you do, I hope it works.
     
  7. michelg1970 thread starter macrumors regular

    michelg1970

    Joined:
    Jul 26, 2011
    Location:
    Gouda - The Netherlands
    #7
    iPad gives me the same... Can see it as a separate item above the available wifi networks BUT when I try to connect it gives an error telling me it is unable to connect...

    Maybe a carrier update from my provider in The Netherlands (KPN) is required to make this work?
     
  8. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #8

    Possibly. Carrier update for me bricked my feature. Sorry to hear it's not connecting. Hope you can get it sorted out.
     
  9. michelg1970 thread starter macrumors regular

    michelg1970

    Joined:
    Jul 26, 2011
    Location:
    Gouda - The Netherlands
    #9
    Strike that! I hard reboot (home button + off switch) my iPad and THAT one is now working. So it is not the carrier settings.

    MacBook still not working... strange. Windows 95 and beyond all over... Endless trying with zero result. Re-install Yosemite on my rMBP maybe?
     
  10. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #10
    Reinstall would be the nuclear option, but no guarantee that it wouldn't mess up another feature.
     
  11. michelg1970 thread starter macrumors regular

    michelg1970

    Joined:
    Jul 26, 2011
    Location:
    Gouda - The Netherlands
    #11
    Haha. Yup I agree especially since I did a full clean install (without TM backup) when the final Yosemite came out.

    I was always used to having my Apple stuff just working out of the box. Spending to evenings in a row without success really sends me back in time...

    Success comes at a price maybe? Just bit disappointed.
     
  12. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #12
    Yes. It seems like there have been a lot of issues with Yosemite. I wonder how people who are not as tech savvy are able to fix their machines? Most MR members know a variety of troubleshooting methods. Wonder what happens if you just want to buy an iDevice and use it? Must be frustrating for those people. At the end of the day, hopefully we're the small minority, this is a forum after all. Hahah...
     
  13. Darrensk8 macrumors 6502

    Darrensk8

    Joined:
    Apr 22, 2010
    #13
    I was having the exact same problem....after reading above I tried a hard reset on my iPad and it's just connected :)
     
  14. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #14
    This isn't quite true. I always have my phone's personal hotspot enabled, and the "instant hotspot" works for me (with my iPad; my Mac isn't new enough to support it). It used to be that the phone wouldn't show up as a wifi network unless the phone's screen was on and set to the personal hotspot screen; with instant hotspot, the phone's screen can remain off. I wasn't aware that it would work if the personal hotspot feature was turned off - that sounds more like a bug than anything else.
     
  15. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #15
    That's the point in this feature! You don't want Personal Hotspot to be on all the time because you'd a walking wireless router whether you'd use it or not. You just want it to be on only when you need to use it. The point in this feature is that because your iPhone knows who your Mac and other devices are, it can advertise itself to only those, so if you wanted to connect, it'd let your iPhone know to enable Personal Hotspot all without you having to touch your iPhone.
     
  16. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #16
    Instant Hotspot, Handoff & Continuity

    Right. Whether your iPhone is sleeping or not you're supposed to be able to turn on Instant Hotspot.

    Most of the posts I've read have stated that Personal Hotspot must be "disabled" for the Instant Hotspot feature to work. This makes sense because if Personal Hospot isn't disabled, then your Mac will show your iPhone as another Wifi connection in the drop down. It will not show up in it's separate section labeled Personal Hotspot.

    Also, the point of the feature is to be able to toggle your Hotspot ON. Otherwise, if you already had it ON, it would've already been showing in your Wifi drop down, as this is how Personal Hotspot normally works. Prior to Yosemite.

    Are you certain you're using Instant Hotspot and not simply connecting to your iPhone because you have the Personal Hotspot feature set to ON. If you've left the feature ON then it will show in your drop down as a Wifi connection, along with any other available networks. If you have Instant Hotspot, it should show your iPhone battery life and signal strength etc. in it's own section.

    ----------


    Exactly!
     
  17. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #17
    That's not how it worked. In order for your iPhone to broadcast a wireless network, you needed to have the phone screen turned on and specifically set to the Personal Hotspot page. Otherwise, no wireless network was broadcast. If you left the page or turned the phone screen off before making a connection with another device, then the wireless network would be shut down. That's what makes the "instant hotspot" so appealing - fumbling with two devices was unwieldy and inconvenient. Now you only need to use one.
     
  18. acctman macrumors 6502a

    acctman

    Joined:
    Oct 26, 2012
    Location:
    Georgia
    #18
    Personal Hotspot does not have to be turned on (or a carrier feature) nor do you have to be on that screen. You do need "bluetooth on" on both devices. Do you have any customized bluetooth restrictions or changes on the Mac. If everything is at default and never changed then it should work
     

    Attached Files:

Share This Page