Intall Application from App Store - Strange Behavior

Discussion in 'iPhone' started by leons, May 23, 2009.

  1. leons macrumors 6502

    Joined:
    Apr 22, 2009
    #1
    I didn't realize it, but I have all 9 pages of applications full. (I know, too many, but that's another thread!) :)

    Anyway, I went to the App Store and tried to download another App. It "tried" to download, but it just returned to my Home Screen (presumably because there is no more room for Apps).

    But here's the weird thing. If I return to the App Store, it shows that new App as "Insalled" (it is not).

    So, did it put "something" on my Iphone. (If so, how do I take it off)? Or, is it just the App Store that is confused. If so, how do I "un-confuse" it?
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Have you tried deleting another app to see if the new one appears?
     
  3. leons thread starter macrumors 6502

    Joined:
    Apr 22, 2009
    #3
    GENIUS! I managed to find one amongst my 144 Apps that I could delete. :D

    Reset the phone, and there appeared the new mystery App.

    Thanks!!! :)
     

Share This Page