Integrated and Discrete color change

yusukeaoki

macrumors 68030
Original poster
Mar 22, 2011
2,550
6
Tokyo, Japan
Hi guys.

I recently noticed that when I switch to my Discrete or AMD Radeon, the color on my display turns a bit blue.
It puts like a screen of blue over my screen.

And when I switch back to integrated, it goes away...

Btw, I havent used gfxcardstatus due to my VMware Fusion but I started using it again and this is what I get.

Have any of you seen this before?

If you guys dont know what Im talking about, let me know, Ill record a video.

EDIT: I did some research and people with the NVIDIA or the 2012 MBP has this problems.
Some say its apple's fault but Im not certain.
Some also said its the SSD's fault.
 

wytwolf

macrumors regular
Apr 23, 2012
160
8
Mine did this last week, I have the late 2011 2.2GHz MBP with ATI/AMD card running 10.8.1 on a Seagate HD. I rebooted and everthing was fine. Calibrating before the reboot just made things worst because when the dedicated as calibrated fine, it would go a horrible yellow/orange when it switched back to integrated. Mine has been ok ever since.
 

aleshh

macrumors newbie
Nov 26, 2012
2
0
The Fix

gfxCardStatus lets you override the system and stay on the integrated GPU, but that sucks.

The fix, amazingly, is to log out and back in. Then you can switch GPU's and the color shift is gone.
 

yusukeaoki

macrumors 68030
Original poster
Mar 22, 2011
2,550
6
Tokyo, Japan
gfxCardStatus lets you override the system and stay on the integrated GPU, but that sucks.

The fix, amazingly, is to log out and back in. Then you can switch GPU's and the color shift is gone.
Im not a huge fan of using HD3000 only since they are horrible...
But after 3 restarts, it stopped doing it whatsoever.