integrated graphic card = grey screen

Discussion in 'MacBook Pro' started by Tex-Twil, Jul 11, 2012.

  1. Tex-Twil macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #1
    Hi,
    I have a 2010 MBP and suddenly when I switch to the integrated (Intel) graphic card and distorted, the screen becomes grey. (see pictures below). It was working fine until now.

    It happens when I switch using both the gfxCardStatus or the Preferences.

    [​IMG]

    [​IMG]

    what's wrong?
     
  2. Aodhan, Jul 11, 2012
    Last edited: Jul 11, 2012

    Aodhan macrumors regular

    Joined:
    Jun 16, 2012
    #2
    It looks like your graphics chip has danced its last tango.
     
  3. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #3
    :(

    Will Apple Care replace it? I replaced the original HD with a SSD... shall I switch it back before going to Apple Care?
     
  4. Aodhan macrumors regular

    Joined:
    Jun 16, 2012
    #4
    If you have Apple Care and it isn't expired, they will replace it. If it is the integrated graphics, I'm pretty sure it's on the motherboard, so that will be a fairly major repair.
     
  5. BlazednSleepy macrumors 6502a

    Joined:
    Apr 15, 2012
    #5
    Having an SSD won't affect apple care in any way.
     
  6. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #6
    I"m also using an Optibay ... what about that?
     
  7. jbzcar macrumors regular

    Joined:
    May 11, 2012
    #7
    Probably gonna want to switch that out.
     
  8. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #8
    ok thanks
     
  9. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #9
    After a complete power off/on (I was rebooting until now), it seems to work again ...
     
  10. eyron macrumors newbie

    Joined:
    Jul 1, 2012
    #10
    I also have a 2010 15" MBP and have been getting the same problem occasionally when changing to Integrated from Discrete graphics, but not all the time.. hoping a clean install of Mountain Lion when it comes out will fix it as my current installation seems pretty tired all round. It has been happening on 10.7.4 and 10.8 GM since upgrading.
     
  11. d4rklamp macrumors regular

    Joined:
    Jan 17, 2009
    #11
    I'm getting the same problem since yesterday as well!!!! I have a Macbook Pro 2010 and been using it perfectly until yesterday. I updated to the latest gfxcardstatus and since then I'm starting to see this tray screen. I thought it's because of the latest version of gfxcardstatus, but I just clean installed Lion again, and the grey screen appeared in the login window. Had to restart. Seems a problem with the Intel HDm, if I force it via gfxcardstatus. Anyone help?

    Btw, I'm on 10.7.4 and also upgraded to Mountain Lion GM. Same thing happens when it switches graphics.
     

Share This Page