Intel iMac will not boot past gray screen

Discussion in 'macOS' started by Casey Burns, Nov 24, 2007.

  1. Casey Burns macrumors newbie

    Joined:
    Nov 24, 2007
    #1
    Intel iMac will not boot past gray screen

    my system:
    new (month old) 24" intel imac, 2.8 ghz, 4 gb ram.
    running: leopard (upgraded from tiger, which was pre-installed at purchase), installed 10.5.1 update right before this huge problem occurred.
    install discs on-hand: two-disc tiget set, single leopard upgrade disc.

    what led to this:
    i wanted to install windows using bootcamp on a 50 gb partition.
    at this point i was running leopard 10.5
    i followed all bootcamp instructions, printing out the guide, as well. once i got into the windows setup, i was prompted to choose a partition to install windows. unlike the bootcamp guide, which showed three partitions, one clearly labeled "bootcamp", i saw only one partition. not wanting to risk writing over my mac partition, i quit the setup and rebooted the mac os. after some googling around, i looked for firmware updates (didn't need any), and then software updates. i decided to try updating to 10.5.1.
    i then ran through boot camp again, deleting my previous windows partition, creating a new one, and moving forward as before. once again, i was only shown one partition to choose from in the windows setup. i exited the setup again to reboot through the mac os, but this time, i was only given a blank gray screen.

    here's what i have tried so far:

    booting from a CD, holding down the C or D keys: no response (in fact, i have to restart the computer holding down the mouse button to be able to eject the CD)

    booting with option key held down: gray screen

    booting with option key held down with external bootable firewire drive attached: the firewire drive appears as a boot icon, and i can click on it within a five second window, but then the screen freezes after that time period, and nothing changes

    booting into target mode while attached to another mac: gray screen (no firewire icon, and drive never shows up on other mac)

    resetting NVRAM: i'm able to hear the boot chimes, but no difference in performance. gray screen every time

    Safe boot: nothing but a gray screen

    Verbose mode: gray screen

    Single user mode: gray screen

    Single user mode with firewire drive attached: occasionally (not every time), i am able to get the white on black terminal to show up. from here, i'm able to run fsck, but it appears to only be checking the firewire drive. i have tried several times to boot from here, and once it took me to a blue screen with movable arrow cursor, but it never went beyond this.

    I have also tried removing my third party ram, and booting with the 1 GB chip that shipped with the machine. No difference.

    is there anything else left to try before taking it to apple?

    any help would be greatly appreciated.

    thanks,

    Casey Burns

    _____________________________

    Casey Burns Illustration and Design

    http://CaseyBurns.com
    _____________________________
     
  2. AndyClarke macrumors regular

    AndyClarke

    Joined:
    Mar 6, 2007
    Location:
    Fernhurst, Hampshire
    #2
    Di you have any USB devices attached external hard drives or iPod's. If so then remove all the cables from the iMac.
     
  3. Big-TDI-Guy macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #3
    EDIT: If your keyboard is not working - is it a bluetooth keyboard? If so, tried going to a wired USB keyboard.

    When I installed bootcamp, I first ran an installer program from OSX, burned a drivers CD, and then rebooted the imac.

    If you're reset the pram and no luck. Try powering the computer down, unplugging it from power, press the "power button" to discharge the PS and wait 30 seconds. Restore power, then try a bootup. Be sure to clear the disc from your disc drive.

    Make sure no external drives are installed and wait it out. Holding "alt" or "command" during bootup (immediately following the chime) will show you available bootable partitions. There is a chance your imac is on "network" boot, so it will hang on the grey screen for quite a while searching for netwook boots. Just wait it out (for 2-3 minutes) and see if it moves on.

    If you had reformatted your disc, you would have passed enough warnings to know before hand - so that doesn't sound to be the case.

    Try these from Apple:

    Apple Hardware Test: iMac (Mid 2007)
    Learn how to use Apple Hardware Test (AHT) with your iMac (Mid 2007) computer.

    The iMac (Mid 2007) computer comes with Apple Hardware Test installed on a separate hard drive partition. This partition is not visible in the Finder.

    To run Apple Hardware Test from the internal hard drive

    Restart your computer while pressing and holding the 'D' key on your keyboard during startup.
    Note: If Apple Hardware Test was removed by reformatting the drive, or if you cannot open it from your hard drive, you can still use Apple Hardware Test from the 'iMac OS X Install Disc 1' install DVD that came with your computer.

    To run Apple Hardware Test from the Install DVD

    Insert the 'iMac OS X Install Disc 1' install DVD into the optical drive of your computer>/li>
    Restart the computer while pressing and holding the 'D' key on the keyboard during startup.
    Note: You can restore Apple Hardware Test to the internal hard drive using the 'iMac OS X Install Disc 1' install DVD that came with your iMac (Mid 2007). To do this, use the Restore feature to reinstall your System Software.

    The iMac (20-inch Mid 2007) uses AHT version 3A125.
    The iMac (24-inch Mid 2007) uses AHT version 3A126.

    ________

    Resetting your Mac's PRAM and NVRAM
    This document explains how to reset the parameter random access memory (PRAM) and nonvolatile RAM (NVRAM) on Macintosh computers.

    Important: If your computer does not retain parameter RAM (PRAM) settings when it is turned off, this generally indicates that the battery needs to be changed. Refer to Macintosh Family: Batteries and Part Numbers.

    Resetting PRAM and NVRAM

    Shut down the computer.
    Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    Turn on the computer.
    Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    Release the keys.
    Your computer's PRAM and the NVRAM are reset to the default values. The clock settings may be reset to a default date on some models.

    Resetting PMU on PowerBook or iBook computers

    In some troubleshooting situations, if resetting PRAM does not resolve an issue, resetting the PMU may be the next appropriate step. For information on when this is appropriate and for instructions on how to reset the PMU in your PowerBook computer, see Resetting PowerBook and iBook Power Management Unit (PMU).

    Additional Information

    Resetting NVRAM in Open Firmware

    If your computer is Open Firmware-based and you are unable to reset NVRAM as described above, you may alternatively reset the NVRAM and Open Firmware settings using the steps in the Solution section of Message “To continue booting, type 'mac-boot' and press return”.
     
  4. Casey Burns thread starter macrumors newbie

    Joined:
    Nov 24, 2007
    #4
    andyclarke: no external devices have been attached (except the firewire drive, where noted above).

    bigtdiguy: everything you listed was already in my list of things that i had tried ... except the keyboard, which is wired, and appears to be working, since i'm able to type when single-user mode works.

    my big question is if i can get single user mode to work again, what can i do from there? can i get it to run any tests on my hard drive? remember, last time i got single user mode to work, it only recognized my external firewire drive.
     
  5. Casey Burns thread starter macrumors newbie

    Joined:
    Nov 24, 2007
    #5
    i dropped it off at the apple store, where they told me they had seen this before, and the only way around it was to remove the hard drive and put it into a casing, and wipe it from another computer using disk utility, and then re-install leopard. they said there has been no successful data recovery in any of the cases. ugh.
     
  6. yanksfan17994 macrumors newbie

    Joined:
    Jun 4, 2008
    #6
    take it to the store

    i had this problem, and for free at the mac store they fixed my laptop and offered to give me 40 x-tra gb or memory be cause of the problem. they fixed it!:cool::cool::cool::cool:
     
  7. Brycew macrumors newbie

    Joined:
    May 20, 2008
    #7
    This happened to me as well. Had to drop it off at London drugs where they whipped my Hard drive. Took them two weeks to do it. When I got it back they forgot to put the power cord back in.
     

Share This Page