Intel Mac Pro - non-standard USB hardware? Problem...

Discussion in 'Mac Pro' started by mft, May 16, 2009.

  1. mft macrumors newbie

    Joined:
    Oct 18, 2007
    #1
    I recently bought myself a 2nd-hand Mac Pro (2006, twin dual-core @ 2.66) to use as my main computer. It's wonderful, apart from a single problem that I can't resolve.


    A piece of software I use regularly (to control my vinyl cutter) is Windows only, and I can't find an OS X alternative at a reasonable price. I've tried Fusion, but the software doesn't run properly.

    So... I installed XP, via Bootcamp, which is where the problems start. Something to do with USB seems to be misbehaving. When I install the cutter's drivers, the computer fails to recognise my cutter altogether, and the USB 'ports' section in Device Manager disappears completely. For comparison, I also tried the same process on my Mac Mini and the same thing happened.

    Trouble is, it's still fine on my old Windows PC. The Pro and Mini were installed with exactly the same version of XP as the PC, are equally up to date, and are using exactly the same drivers for the cutter. Keyboard, mouse, and iPod are fine via USB. I did install the Apple drivers for Windows ;)


    I'm wondering: is there any fundamental reason why, despite being ostensibly compatible, Macs handle USB differently, so as to make some, but not all, drivers and/or hardware incompatible? I'm very grateful for any insights offered; I realise that this isn't a pure Mac/OS X problem, but if I can't rectify this, the Pro's going to have to go... :(
     
  2. Tesselator macrumors 601

    Tesselator

    Joined:
    Jan 9, 2008
    Location:
    Japan
    #2
    I dunno how to resolve your specific issue but I believe there might be a demo version of Parallels that might work. Fusion for me, like you, doesn't work properly either. Parallels does tho - everything runs nice and just works (3D is a bit slow and that's about the only drawback). There are other VMs out there as well. If one works it'll be very worth the effort. Booting into and out of Windoze and OS X all the time sucks pretty hard IMO - especially within the work-flow I guess you're using.
     
  3. Spanky Deluxe macrumors 601

    Spanky Deluxe

    Joined:
    Mar 17, 2005
    Location:
    London, UK
    #3
    The USB hardware's nothing special, its the same stuff found in workstation PCs. It sounds like the Mac Pro is disabling the built in USB hub due to the USB device drawing too much power.
     
  4. mft thread starter macrumors newbie

    Joined:
    Oct 18, 2007
    #4
    Will try Parallels :)

    Interesting theory, although:

    1. IIRC Windows gives an error if the USB power draw is too high - I've had this plugging some USB keys into a hub
    2. The cutter has its own power supply
    3. IIRC the driver seems to remove the USB section of Device Manager on its own - this isn't dependent on the cutter being plugged in, or not

    Is there any way I could check the USB power draw?
     

Share This Page