Intel mini HTPC forgets monitor profile when sleeping

Discussion in 'Mac mini' started by OrganMusic, May 26, 2010.

  1. OrganMusic macrumors 6502

    Joined:
    Sep 21, 2008
    Location:
    Chicago
    #1
    Did a bit of searching about this, but couldn't find anything:

    Have a 2009 vintage mini hooked up via VGA to my 40" sony LCD. On the whole it works great -- i don't have any video issues except that usually when waking from sleep the picture comes up squished onto the right side of the screen though the monitors menulet actually reports the correct resolution -- 1920x1080, 60 hz but lists the display as simply "VGA". If I click "detect displays" it resets and all is fine; the menulet then says "Sony TV"

    I think this problem started about the time I got my bluetooth keyboard and magic mouse. I've been running snow leopard on this all along, and it's fully up-to-date.
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    Just to check, are you waking the computer before you turn on the TV? While the MacOS should detect display changes either way, I've had issues with VGA where if the display is off when the computer gets woken up, it doesn't get detected (of course, since at that point there is no display), and for whatever reason the display detect routine doesn't notice the change when the display gets turned on. Maybe now that you have a wireless keyboard/mouse you're waking the computer before the TV is fully on and the Mac has a chance to detect it upon wake--that might explain the difference. (The same thing might happen if you accidentally wake the computer at some point while the TV is off--it wakes, sees no monitor and adjust accordingly, then goes back to sleep, and when it gets woken later is stuck on the previous "no display" setting it saw on last sleep.)

    Also, out of curiosity, is there a reason you're not using HDMI? Depending on the cables it's arguable whether the display quality will be noticeably than VGA, but with my similar setup (2009-era mini and 37" Sharp 1080p via DVI-HDMI) detecting displays seems to be entirely consistent and reliable with a digital connection. That's been my experience in general with digital vs. analog display outputs.

    A related tip, in case you haven't run into it: If you ever shut your mini down, make sure to turn the TV on BEFORE you turn the mini on--otherwise the mini drops into headless mode when it sees no TV and turns off all hardware acceleration for graphics, which will result in tearing and slowness all around. Confused the heck out of myself why video had suddenly gone awful until I figured this out.
     
  3. OrganMusic thread starter macrumors 6502

    Joined:
    Sep 21, 2008
    Location:
    Chicago
    #3
    Very interesting, I was fairly certain it had something to do with that. I'll experiment with it a bit. Interestingly, my TV has a mode where you can make it sleep when there's no input (as most monitors do) and I had been using it in that way. I'll try it with that off for a while and see.

    Interesting -- any way to tell when this is the case, in system profiler for example?
     
  4. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #4
    If your TV has a true "sleep" mode, like VGA monitors, then this should of course work as it would with a monitor. My TV, and I know some other models, however, handle the process somewhat differently--rather than going to sleep when there's no input signal, they actually turn themselves off.

    The obvious difference is whether the TV will wake if the input signal reappears, in which case presumably it'd behave like a monitor. If it needs to be manually turned back on after turning off, then it really is off, not sleeping, and that might be the issue.

    Please post back if disabling that fixes your problem--always good to know for future reference.

    There's probably some easy way to check, but the quickest is probably opening iTunes and bringing up coverflow--if you get a black screen instead of 3D covers, you're in the "low-fi" mode. iTunes will do the same thing, interestingly, if you open it via a remote VNC connection when there's no screen available, but in that case quitting iTunes and re-opening it once the screen is on will kick coveflow back in, while getting the system stuck in that state by booting with no screen will require a reboot to restore full graphics performance.

    Come to think of it, coverflow in Finder will probably do the same thing, so you probably don't even have to open iTunes.

    It'll also be pretty obvious if you open a video and play it fullscreen--it will have obvious and ugly tearing issues if it's not being hardware accelerated, as one of the things that gets turned off is coalesced output. You'll even see tearing if you drag a large Finder window around rapidly.
     
  5. OrganMusic thread starter macrumors 6502

    Joined:
    Sep 21, 2008
    Location:
    Chicago
    #5
    My TV would "sleep" and then "wake" with the computer. Disabling this seems to have solved the problem, but I think it used to work correctly. Perhaps some system update broke it.
     
  6. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #6
    Then it's doing a "monitor style" sleep, and should work fine. Since turning that off fixed it, I've got to assume that it's either waking slowly enough that the Mac doesn't "see" it, or that when it's asleep it's not reporting its proper resolution/clock/whatever to the Mac (although I don't know if that's even how VGA sleep works).

    Unfortunate.

    By the way, you didn't say why you were using VGA instead of DVI or HDMI. No open digital ports on the TV, or just because VGA hardware is what you had on hand?
     

Share This Page