Intel SSD 320M - Secure Erase

Discussion in 'MacBook Pro' started by undesign, Dec 6, 2013.

  1. undesign macrumors regular

    Joined:
    Nov 4, 2013
    #1
    Does anyone have any idea of how to secure erase this drive? Everytime I load of Intel SSD Toolbox its give me some ridiculous crap about it being 'security frozen'. I've looked into help and it says to disconnect and reconnect the SATA cable.

    I've got a 1TB HDD with Windows loaded onto it in my main bay where the stock drive is and the Intel 320M SSD in an optibay where the DVD drive used to be.

    I've tried disconnecting the drive while the laptop was running from both bays, and the security free ********* is still preventing me from securely erasing the drive.

    Any suggestions? I don't have a PC desktop to do this from.
     
  2. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #2
    I've not tried this myself, but if you're willing to pay $5, there's a utility called Parted Magic that you burn to a CD or USB drive. It contains a standalone Linux distribution and actually looks very similar to the bootable toolbox OCZ made for its line of SSDs.

    If you have a USB 2.0 hard drive enclosure or dock, there's a free but more involved method you can use that does the same job. It, too, requires a creating a live CD/USB but this time with GParted. Once you've created the live CD, put it in your Mac then do the following:

    1) Shut down your Mac, remove the SSD you want to erase, place it in the external enclosure/dock, and connect it to your computer.
    2) Start your Mac and hold the alt/option key to bring up the boot menu
    3) Select the CD that says "Windows." Do not select EFI boot
    4) Boot to the GParted using the default options. This might take a couple minutes.
    5) The GParted utility will launch on startup. Ignore any warning messages it produces, and exit the program.
    6) Launch the terminal application and then follow the instructions outlined here. One thing to note is when you get to the step where you have to enter these commands, (without the quotes) "hdparm –user-master u –security-set-pass Eins /dev/sda", then "time hdparm –user-master u –security-erase Eins /dev/sda" or "time hdparm –user-master u –security-erase-enhanced Eins /dev/sda" make sure you use a double dash (--) before 'user' and 'security' or else they will not take. It took me many tries to ultimately figure this out.
    7) Once you've completed this, shut down GParted, install the SSD back in your Mac, then reinstall your OS as usual.

    As I said, the second process takes a bit longer but doesn't cost any money, provided you have a USB dock/enclosure in hand. It works perfectly with my Crucial M500 SSD. The one thing i regret about getting rid of my OCZ drive was that its bootable toolbox was Mac friendly and very easy to use (literally three or four mouse clicks to secure erase the drive and you were done).

    Good luck.
     
  3. undesign thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #3
    Thank you! I'll give it a try, I do have an enclosure I can use and did attempt it with Intel SSD Toolbox, but all my options in the applications were unavailable. I'm at work now so I'll give this a try today or tomorrow.

    *fingers crossed*
     
  4. undesign thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #4
    I tried this yesterday, didn't work. Burned the Gparted ISO to CD (it was a small ISO, no need for DVD) while I was able to get to the boot menu, selecting Windows (not EFI) nothing happened after, as all I got was a black screen with a blinking underscore.

    I'll try parted magic later on.
     

Share This Page