Intel SSD G2 worked internally now only in ext caddy - MBP 13"

Discussion in 'MacBook Pro' started by RealEvil, Mar 19, 2010.

  1. RealEvil macrumors 6502

    Joined:
    Aug 5, 2007
    #1
    Hi,

    Yesterday morning I was using my MacBook Pro (13", 2.25, early 2009 model). OSX crashed so I had to hard power off the machine by holding down the power key (rare, but it happens occasionally). Then when I switched it back on, it would not boot into the SSD.

    So, assuming the SSD was broken, I put in the a external USB caddy and inserted the original 160GB Hitachi drive from the machine into the MacBook Pro. Both worked... i.e. the SSD works in a caddy and the original drive works in the Macbook (on a internal SATA port)

    I did a Disk Utility-Repair on the SSD when it was in a caddy and it did find (and then repair) issues on the SSD. Thing is, when I put the SSD into the internal SATA port, Disk Utility cannot find the drive at all (and I cannot boot from it) - it will only find it when in a caddy.

    Its been working fine for 3 months... PLEASE HELP!
     
  2. stonyc macrumors 65816

    stonyc

    Joined:
    Feb 15, 2005
    Location:
    Michigan
    #2
    Is everything backed up off of your SSD?

    If so, maybe you could just try starting fresh...
    - first, make sure you have the latest firmware for the SSD (intel.com), you'll have to burn an .iso I think, boot into that, then update the firmware through there
    - do a secure erase of your drive, I think there's a tutorial out there for using a GParted live cd, just google that...
    - once that's done, re-install OS X to your SSD and see if that did the trick...

    Don't know if that will actually solve your problem, but whenever I run into disk issues, a clean format (in this case, it could include a secure erase) and re-install usually does the trick... if not, then there's probably something really wrong with your drive.
     
  3. RealEvil thread starter macrumors 6502

    Joined:
    Aug 5, 2007
    #3
    The plot thickens...

    I still cannot get the SSD to work at all in the MBP (it never appears in the list of drives when you hold OPTION and boot) and it never appears in Disk Utility if you boot to the Installer via DVD.

    However, I may have been premature about other drives working in the MBP. I used SuperDuper to clone the SSD and this clone (a 160GB original mechanical HD) which will appear in the list of drives when holding OPTION but it cannot boot to it and the OSX installer will not ever start from the DVD with this drive in the machine but I can also boot from this via USB... However, I can put a different (my last) SATA 2.5" drive into the machine and I am currently attempting a OSX install to that to see if the MBP is faulty... bizarre.
     
  4. fehhkk macrumors 6502a

    fehhkk

    Joined:
    Jun 11, 2009
    Location:
    Chicago, IL
    #4
    You could try removing the optical drive, and plugging the SSD in that SATA port (if you have a newer mid-09 MBP), and see how that works.

    Also, have you tried putting another SATA drive in the port where the SSD cannot be read?
     

Share This Page