Intel X-25M Gen2 owners, is mine performing as it should?

Discussion in 'MacBook Pro' started by Heilage, Sep 29, 2010.

  1. Heilage macrumors 68030

    Heilage

    Joined:
    May 1, 2009
    #1
    Hey guys.

    So, previously I've had a Vertex in my MBP, until it died. But before that, it was lightning fast. Somehow, I feel that the X25-M Gen2 80GB for a few months now, and it kinda doesn't feel as fast.

    So I benched it with XBench, to get some numbers. Can you guys look it over and compare it to your own results of different kinds when using this?

    [​IMG]


    It might just be some placebo stuff. But I want to check it all out. :)
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
  3. Heilage thread starter macrumors 68030

    Heilage

    Joined:
    May 1, 2009
    #3
    I think so, it doesn't look like Intel has released a firmware update since last year, or am I wrong?

    Thanks for the link BTW. Mine seems to be a bit below what those guys are getting, but still not "this is defective"-bad.
     
  4. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #4
  5. Heilage thread starter macrumors 68030

    Heilage

    Joined:
    May 1, 2009
    #5
    Well, since mine was bought in May 2010, I'll assume that I have the latest firmware running. :)
     
  6. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #6
    I would still check that it has the latest firmware, it should be listed in System Profiler. I think the latest firmware for your drive is 02HD.
     
  7. Asylum Design macrumors newbie

    Joined:
    Jun 9, 2010

Share This Page