Intel X25-M Firmware Update?

Discussion in 'MacBook Pro' started by Jazojas12, Mar 27, 2011.

  1. Jazojas12 macrumors regular

    Joined:
    Apr 24, 2009
    #1
    Bought my drive about a year ago and haven't updated the firmware ever. Was wondering how I go about doing this?

    I checked Intel's site and it says for OS: 3 flavors of Windows but no OSX; however, at the bottom it says for Mac?
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18363

    Is that the file I need then?
    Running:
    2011 13" MBP with
    Model: INTEL SSDSA2M080G2GC
    Revision: 2CV102HD
     
  2. axu539 macrumors 6502a

    Joined:
    Dec 31, 2010
    #2
    The firmware is the same for all OSes, so you need to DL that and burn it to a CD using disk utility. Then, with the drive in, you need to boot from the CD, and update the firmware. That being said, my 2011 machine refused to boot from the CD (or a Windows 7 disc) while the Intel SSD was in. I ended up putting the SSD into another computer, and updating the firmware from there. Then, back in my machine, it also started booting just fine from the Windows 7 disc, allowing me to install Windows too.
     
  3. Jazojas12 thread starter macrumors regular

    Joined:
    Apr 24, 2009
    #3
    Did it and when I tried booting from the CD, had a grey screen for 2 minutes then the flashing folder with a ?. I take it I'll have to put the drive in another computer too?
     
  4. fehhkk macrumors 6502a

    fehhkk

    Joined:
    Jun 11, 2009
    Location:
    Chicago, IL
    #4
  5. Jazojas12 thread starter macrumors regular

    Joined:
    Apr 24, 2009
    #5
    Burned it on a Toshiba laptop running Win XP with MagicISO. Put it in, restarted, held option, chose the CD, 2 minutes of grey screen then a folder with a question mark. Am I doing something wrong?
     
  6. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #6
    I just updated my x25-m firmware using the latest CD downloaded from the website, burned with disk utility and booted up on my 2010 MBP.

    I have a 2011 MBP also but no SSD in it, plus I threw away the CD so I can't test.

    But disk utility works fine, and the update utility itself works on my 2010 MBP as well as my older 2008 non-unibody MBP.
     
  7. Jazojas12 thread starter macrumors regular

    Joined:
    Apr 24, 2009
    #7
    Can't comment as to if the CD I burned with disc utility worked but the one I burned on WinXP with MagicISO worked. I had to switch the drive into the Toshiba laptop though then everything went fine.

    Thanks guys.
     
  8. tinymiata macrumors newbie

    tinymiata

    Joined:
    Mar 21, 2011
    #8
    I had to update my x25 in another computer before I was able to install anything under boot camp.
    I used CCC to copy the the original drive to the x25
    I have the 2011 MBP 17in
     
  9. Akira81386 macrumors newbie

    Joined:
    Apr 19, 2010
    #9
    I burned a disc and booted on my 2010 13 inch MBP fine. However, when it checked for an attached SSD it said there was none found. What do you guys think is the problem?
     
  10. smeg36 macrumors regular

    Joined:
    Sep 16, 2009
    #10
    Same system, same results here. I couldn't get it to work, and don't have another computer to update it with.
     
  11. Jazojas12 thread starter macrumors regular

    Joined:
    Apr 24, 2009
    #11
    I couldn't get anything to show up on the Mac but it was a breeze with Windows. If you have another machine that's Windows I would try that first, maybe ask a friend if you don't. But everything should work without the update. Write Intel and complain ;)
     
  12. dlai531 macrumors newbie

    Joined:
    Sep 9, 2010
    #12
    I'm having issues updating my firmware as well..

    plugged the drive into my Dell and the SSD boot disk loads but the updater is saying a intel drive cant be found.

    When i try on my 2011 mbp i get the gray screen and flashing ?? folder like everyone else.

    I'm upgrading from a 5yr old 2,1 macbook and with the SSD in the 2011 takes close to 30seconds to bootup while my old macbook only took 18.

    Any ideas on what can be causing the gray screen or why the Dell isnt recognizing the drive and also on why the much newer mbp is taking so long to boot? thanks
     
  13. Jazojas12 thread starter macrumors regular

    Joined:
    Apr 24, 2009
    #13
    I just added another 80GB SSD into my optical drive. Set it up in RAID and when I went to update the firmware it showed up fine, I had an external DVD drive connected with the update disc.
    Originally when I put the SSD into a Windows machine, I replaced the Windows drive with the SSD. Don't know if you were plugging it in externally but try putting it inside if you aren't.
     
  14. dlai531 macrumors newbie

    Joined:
    Sep 9, 2010
    #14
    thanks for chiming in... I'm plugging the drive in internally. Do I need to tweak something in the bios to make it recognize it?
     
  15. brentsg macrumors 68030

    Joined:
    Oct 15, 2008
    #15
    No problems updating my X25-M G2 here, while in my MBP.
     

Share This Page