interent/snow leopard issues

Discussion in 'macOS' started by Jeremy08, Sep 9, 2009.

  1. Jeremy08 macrumors regular

    Joined:
    Jul 27, 2008
    #1
    I have a linksys wrt54g2 router and a aluminum macbook 2.4ghz running snow leopard. every so often, like when i am torrenting or sharing media to my ps3, my internet will suddenly go dead. The wifi bars are still there, but i have to turn my airport off and on again to get interent again. This is spiratic, but i have no idea what the issue is, any help? Suggestions? BTW i of course have tried restarting my computer.
     
  2. stuiephoto macrumors newbie

    Joined:
    Sep 10, 2009
    #2
    same issue

    Same issue here. Different router (its a belkin, not sure what model).

    On my linksys at home i just lose wireless completely. Most of the time (90% at least) its when a torrent is running. Transmission and utorrent make this happen so I doubt its a client issue. Also happens with Call of duty 4. New DSL modem behind the belkin router does not solve issue. Happened in both leopard and snow.

    On the belkin, I will lose internet connectivity, but the wireless icon states I am still connected. Unable to log into/connect to router via. IP address. Other computers can connect to the router and modify settings.
     
  3. Jeremy08 thread starter macrumors regular

    Joined:
    Jul 27, 2008
    #3
    same here, no computers on the network are having issues like mine..DAMN!
     
  4. stuiephoto macrumors newbie

    Joined:
    Sep 10, 2009
    #4
    Im getting sick of this. I think i have tracked down part of the issue. Both networks im on are assigning me the 192.168.1.100 IP address, no matter what. I do DHCP with manual address and it works much better, but if I close the laptop or boot to windows and back to osx, I lose all network.
     
  5. MICMAC247 macrumors regular

    MICMAC247

    Joined:
    Jul 21, 2009
    #5
    I'm having the same issues as well with the Linksys WRT54G. I just updated the firmware on the router via the Linksys website. Hopefully this does something.
     
  6. MICMAC247 macrumors regular

    MICMAC247

    Joined:
    Jul 21, 2009
    #6
    Well that didn't work, but another quick tip...

    Try changing the broadcast channel on the wireless router. I was on 6, changed to 10 and it seems to have fixed things for the time being. The speed of web browser is also noticeably faster.
     
  7. reubs macrumors 68000

    Joined:
    Jun 22, 2006
    #7
    Having an identical problem using a WRT54G also. I don't notice it when torrenting, but if I have Speed Download going with lots of files I can just see it dropping. Turning the Airport card off and on usually helps with problem, and no other computers in the house are affected by it. I'll try changing the broadcast channel, but do I have to hook up directly to the modem to do that?
     
  8. Acsom macrumors regular

    Joined:
    Jul 10, 2009
    #8
    On the theory that it takes two to make a handshake, I solved a similar issue by resetting the router/modem (Westell 357) and downloading and reinstalling the (Verizon) installation package. I believe that the issue was related to the dynamic assigning of IP addresses on my network (although I don't know that for sure). The best link I found for troubleshooting this issue is this one; at the end of the article he lists other troubleshooting tips; restting the router is on that list.
     
  9. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #9
    Same here, only noticed it since I went to Snow Leopard but not sure if thats a coincidence or not, but I am pretty sure the first time this happened was the first time I ran uTorrent under SL.

    Router is a Linksys and within a few minutes of starting up uTorrent (0.9.1.2) the router makes a click sound, and then dies. Sometimes all red lights, other times it continuously reboots.

    Only fix is cycle the power to the router.
     
  10. Riemann Zeta macrumors 6502a

    Joined:
    Feb 12, 2008
    #10
    These same types of issues are afflicting my machine. Sleep, for example, can easily kill my wireless network connection. Hell, sometimes the connection just dies for no reason. This is on a DLINK WBR-series router. I have DHCP enabled, with the router configured to assign me 192.168.0.100. Power cycling the router or NIC helps, but is a pain in the ass.
     
  11. MICMAC247 macrumors regular

    MICMAC247

    Joined:
    Jul 21, 2009
    #11
    My issues did not begin until I installed Snow Leopard as well. Everything was seamless until then.
     
  12. michael.lauden macrumors 68020

    michael.lauden

    Joined:
    Dec 25, 2008
    #12
    i like how everything is blamed on SL, i'm pretty sure SL did not rewrite how the network card works. sounds like something is wrong in your configurations.
     
  13. Riemann Zeta macrumors 6502a

    Joined:
    Feb 12, 2008
    #13
    Switching from the so-called "TubroG Compression," which mandates channel 6 to wireless channel 10 seems to have helped, as mentioned above. However, as part of the switch, one does have to turn off the pseudo-118mbps software feature (which most 54mbps 802.11g routers have).
     
  14. FSUSem1noles macrumors 68000

    FSUSem1noles

    Joined:
    Feb 23, 2006
    Location:
    Ft. Lauderdale
    #14
    • I just upgraded to SL this evening and I'm experiencing the same problem, when I was on 10.5 my wireless was working great.
    • Since upgrading to SL, my wireless bar is full, but the connection dies, I have to turn off the wireless and turn it back on and it reestablishes a connection.
    • My router is on ch. 6, so I'll try changing it and see what happens..
     
  15. jacketseason macrumors newbie

    Joined:
    Sep 4, 2008
    #15
    Exact same setup/issue as Jeremy08

    I'm running a 15-inch unibody MacBook Pro on 10.6.2, Linksys WRT54G2 router. My connection drops sporadically several times a day -- often while torrenting or streaming video to my PS3 using MediaLink.

    Extremely frustrating. I've tried so many "fixes" to no avail:

    Upgraded the firmware
    Changed the router channel
    Zapped the PRAM
    Dumped the SystemConfiguration folder (~/Library/Preferences/SystemConfiguration) and rebooted
    Switched from WPA2 to WPA
    And all the steps listed at Linksys forums http://forums.linksysbycisco.com/li...ers&message.id=136794&query.id=312689#M136794

    Nothing is fixing the problem. Nada. It's definitely a Snow Leopard bug: Wi-Fi was fine when I was using Leopard. A friend was over with his MacBook running Leopard, and he didn't get disconnected when I did. iPhone does fine with the network even when MBP is disconnected. GRRRRRRRRRRRRR.

    If anybody finds a solution for this, please post the instructions. Unreliable Wi-Fi is driving me crazy.

    Thanks.
     
  16. Nocebo13 macrumors newbie

    Joined:
    Jul 31, 2010
    Location:
    Williamsburg, Virginia
    #16
    One Solution

    So I had the same problem many of you had: after a year or so without error, airport began saying that I was connected to a network, even though I wasn't getting any access to the internet.

    After a long troubleshoot with an Apple guy, I have found at least one fix to this problem. This fix will be for those who are confident their problem isn't hardware.

    Solution: First of all, Snow Leopard caches all the networks you've ever accessed (unless you've changed that particular option). Now for some reason, when you have accessed a fairly large number of networks, the bug comes up where you continue to "connect" to networks without actually connecting to the internet.

    In order to remedy this issue you need to delete your cache of wireless networks.

    To do this, first go to the Network menu in System Preferences. Highlight the Airport device in the box to the left for network devices and then go to advanced options. In this options menu make sure you are on the "Airport" tab. Once you are there, select all the networks that are listed in the Preferred Networks box and click the minus button to delete the cache of networks. With luck, this should free up your wireless.

    If your internet isn't working immediately, I would recommend simply restarting your modem and router if you have access to them.
     

Share This Page