Interesting device problem (apps stopped working)

Discussion in 'iOS Programming' started by 1458279, Mar 22, 2012.

  1. 1458279, Mar 22, 2012
    Last edited: Mar 22, 2012

    1458279 Suspended

    1458279

    Joined:
    May 1, 2010
    Location:
    California
    #1
    I use an IPT as a test device and have about 50 test programs on it. My provisioning profile expired and I noticed the programs stopped working.

    So I figured it was because of the expired profile, as nothing else changed (no updates / upgrades)

    I reset the provisioning profile and compiled and ran a few programs, everything's fine. Except, the older test programs. They start to load, then freeze up. I have to power down the IPT.

    I assumed before this was because of the expired profile, but now they still don't work.

    I tested the same apps in the simulator and they work there. Some of these are the standard Apple API examples (accel graph) So I recreated some of them, and they work when I recompile them.

    This lead me to thing it's a compatibility issue between API's or something, but NOTHING has been updated or upgraded.

    This isn't a huge problem, as they are just my test apps, but I'd like to know what's going on here.

    I had apps compiled and running, then they just stop. No message, nothing. I have to power down the device.

    Is there some log on the device that I can look at to give a clue what's going on?

    Isn't the 'Home' button supposed to override the app and force it to close?

    Mainly I'm concerned about knowing this stuff in depth...

    Edit: on example is Bubble Level, it runs on the simulator, but when I run in now on my IPT, it loads 1/2 the graphics and then goes stops returns back to the OS, I run it a second time and it locks up and I have to power down the device.

    Same with the Space Vikings from a book I'm reading... but I recompile it and now it works fine.
     
  2. firewood macrumors 604

    Joined:
    Jul 29, 2003
    Location:
    Silicon Valley
    #2
    Did you remove the old expired profiles/mobileprovision from the device?
     
  3. 1458279 thread starter Suspended

    1458279

    Joined:
    May 1, 2010
    Location:
    California
    #3
    No, I left the expired provisioning profile in xCode. I didn't do anything with the settings on the device itself.

    I just went back to run one of my test apps without the device being connected to the computer, and they weren't working.
     

Share This Page