Interesting issue with shared library and AppleTvs

Discussion in 'Apple TV and Home Theater' started by jaxhunter, Jul 11, 2016.

  1. jaxhunter macrumors regular

    jaxhunter

    Joined:
    Dec 14, 2012
    Location:
    Arizona
    #1
    Hello All!

    I have an interesting issue with my home setup. I have my iTunes library on a Mac Pro running Yosemite and the latest version of iTunes. Everything's up to date and iTunes is running all the time. I have 5 AppleTVs that connect, 4 of which are 3rd gens. The fifth is a 4th gen. All the AppleTVs are also up to date. The issue is that randomly but frequently one or more of the AppleTVs reports that is cannot connect to my library. Rebooting the AppleTV does not fix the issue. I have to quit iTunes on the Mac Pro and re-launch it and then the issue is resolved - for a little while. I have tried a number of steps to troubleshoot this including making sure that all the AppleTVs have direct access to the Airport Extreme (Gen 6, also up to date), first by connecting 3 of them wired and testing and then all 5 wirelessly, which is how they are set up now. For awhile I assumed it was one of the units "taking control" and making access to the library difficult. At first it seemed like it was always the Living Room unit so I swapped it with another unit on the network, both physically and name-wise. I figured that when the Living Room unit became the Office unit it would still control the system. But no! The "new" Living Room unit now assumed control. Which seemed particularly weird. Now they all have new, but random-ish names and I still have the issue. I've reset all the AppleTVs and have even gone to the step of replacing two of them under warranty and performing a DFU restore on the other 2 and still no success. Additionally I've rebuilt the iTunes library after performing a clean install of the OS. So, I'm out of ideas. Anyone else have any ideas?
     
  2. whathesaid macrumors regular

    Joined:
    Sep 6, 2010
    Location:
    UK
    #2
    Weirdly I have the same issue. I have a TV3 and TV4 connected. The 3 is fine in the bedroom. But the living room 4 is often unable to connect unless I restart iTunes.

    What I have been doing is making sure that the 'Computers' App is closed when I'm done using it. I haven't had the problem for a couple of days since I've been doing that and it seems to be working OK, but that might just be luck. But something isn't quite right. I'm hoping that the issue would be resolved when the new TvOS is released.
     
  3. pjarvi macrumors 65816

    pjarvi

    Joined:
    Jan 11, 2006
    Location:
    Round Lake, IL
    #3
    Two things I would recommend (I used to have this issue and have had no problems this year):
    1.) Configure your router to assign each device a reserved IP address, you will need the MAC (machine) address of each device, Google search is your friend for where to locate it on each device and how to configure your rotuer.
    2.) Next time the issue happens, rather than restarting the computer try restarting the mDNSresponder service (Bonjour service on a Windows PC.)
     

Share This Page