Interesting USB Charging Behavior

Discussion in 'Windows, Linux & Others on the Mac' started by jeigh, May 26, 2010.

  1. jeigh macrumors newbie

    Joined:
    Mar 18, 2010
    Location:
    ELP
    #1
    I have a Dell Precision m4400 and was using Win7 since I received it. Of course, I wasn't able to make full use of the USB charging capabilities for what I thought were low-power USB ports.

    I recently decided to try installing OS X on it. Works great but one thing definitely caught my attention - full-power USB charging! I've now installed VMWare Fusion and noticed that if I pass control of the USB ports and iPad over to my Win7 VM box it goes back to the slower trickle charge.

    Has anybody else noticed this behavior? Particularly, I'd be interested in those with genuine Macs who Boot Camp into Windows. Do you have full-power charging capabilities in Windows or just while in OS X?

    OS X
    [​IMG]

    Win7 (Virtualized in OS X)
    [​IMG]
     
  2. al256 macrumors 6502a

    al256

    Joined:
    Jun 7, 2001
    #2
    Holy crap! You're right. I just booted into Vista on my current gen iMac and yes indeed, my iPad is displaying the 'Not Charging' message. Yes of course, this is directly plugged into the computer.
     
  3. fehhkk macrumors 6502a

    fehhkk

    Joined:
    Jun 11, 2009
    Location:
    Chicago, IL
    #3
    Seems like an OS X "feature" to me ;)

    I'll try it on my Hackintosh...
     
  4. jeigh thread starter macrumors newbie

    Joined:
    Mar 18, 2010
    Location:
    ELP
    #4
    Thanks for verifying.

    So it sounds like this is at least also partially related to the USB drivers in Windows and not solely being a high-power/low-power USB bus issue. If so, it seems like there's at least some of us with high-power USB ports that we aren't able to take advantage of.
     

Share This Page