Interface Builder Issue

Discussion in 'iOS Programming' started by DarkRevenant, Sep 21, 2010.

  1. DarkRevenant macrumors member

    Joined:
    Mar 22, 2008
    #1
    Hello,

    I have recently tried to develop an iPhone app using xcode and interface builder and I am really unable to do anything due to this one issue I've been having. XCode opens fine and I can do whatever I want there. When I click on MainWindow.xib on the side to open a preview of my app it still is ok, the problem I encounter is when I scroll down about halfway in the library on the right, the program freezes from there on out and I need to force quit.

    I've searched through the forums and didn't find anything on this, and when I googled it there were some people with similar problems but never a solution to this. Please help!

    Thanks.
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    Do you see this problem if you build a project from one of the templates and open its nib?

    If so I would uninstall, delete the Developer folder, and reinstall.

    There might be other ways to try to diagnose the problem but that would likely solve it if it's universal for all nibs. If it doesn't fix the problem, and it's universal, then you probably have a corrupted pref file somewhere. Sorry but I don't have a list of the ones you would need to delete.

    What version of Xcode do you have installed? Did you do any kind of update install or always install into a new folder (recommended)?

    One other possibility is a corrupt or failing hard drive. You might want to check it with Disk Utility.
     
  3. DarkRevenant thread starter macrumors member

    Joined:
    Mar 22, 2008
    #3
    Hello, thank you for your replay. I created the file by making a new iPhone project and doing a window based app. I have not tried making any other projects, but I will try.

    When you say uninstall and reinstall, what information will I lose in the developers folder? How will I rerecreate it? Also, the library only fails if I scroll down past the "date picker". Thanks for the advice.
     
  4. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #4
    I assume you haven't added anything to the Developer folder other than running the installer. There won't be anything lost due to uninstalling and reinstalling. Xcode downloads the documentation after its installed so it will do that again.
     
  5. DarkRevenant thread starter macrumors member

    Joined:
    Mar 22, 2008
    #5
    Thanks for the information that was very helpful. To address something you said before, I just used OnyX and it indicates the structure of system files needs to repaired. Could this be causing my XCode issue? Also, could a failing hard drive be linked to a motherboard issue at all? Thank you.
     
  6. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #6
    Hardware problems can cause all kinds of seemingly random software problems. I have an external hard drive that acts up when it gets too warm, and it's been a hot summer.

    Obviously you should fix any kind of file system problems that arise.
     

Share This Page