Interface builder problem from a newbe

Discussion in 'iOS Programming' started by raven99, Feb 5, 2009.

  1. raven99 macrumors newbie

    Joined:
    Feb 5, 2009
    #1
    Hi, I'm a new iPhone developer.

    A few details before I start:
    I use MacBook with Intel Core 2 Duo
    Mac OS X 10.5.6

    I've installed the most recent iPhone SDK (with the iPhone 2.2.1 update)
    I'm working closely with the apple tutorials but, I have problems at the basis level.

    I want to create a "HelloWorld" application, so I've followed the the "First iPhone Application" apple guide from iPhone dev center.

    All went good until I need to handle the interface builder.
    Every time that I activate the interface builder it shows the following error message:

    Assertion Failure
    Interface Builder encountered an internal logic error. Choose "Continue" to continue running Interface Builder in an inconsistent state. Choose "Crash" to halt Interface Builder and file a bug with Crash Reporter. Choosing "Crash" will result in the loss of all unsaved data.


    When I press the "show details" button it shows the following message:

    Assertion Message: Interface Builder encountered an error communicating with the iPhone Simulator. If you choose to file a crash report or radar for this issue, please check Console.app for crash reports for "Interface Builder Cocoa Touch Tool" and include their content in your crash report.

    IBUIViewImageRequester failed to rasterize a UINavigationBar, UINavigationItem, UIToolbar, UIBarButtonItem, UITabBar, UITabBarItem, UITabBarItem, UISearchBar, and UILabel.

    Exception name: NSRangeException
    Exception reason: [NOTE: this exception originated in the server.]
    *** -[NSCFArray objectAtIndex:]: index (1) beyond bounds (1)
    Exception backtrace:
    0. CoreFoundation 0x955e710b _NSExceptionSetRubyToken
    1. libobjc.A.dylib 0x90969e3b objc_exception_throw
    2. CoreFoundation 0x955e6eeb [NSException copyWithZone*:‬]
    3. CoreFoundation 0x955e6f2a [NSException copyWithZone*:‬]
    4. Foundation 0x962857ff [NSValue pointValue]
    5. Foundation 0x96203188 [NSCFArray objectAtIndex*:‬]
    6. Interface Builder Cocoa Touch Tool 0x0000b072 [IBCocoaTouchToolObjectPackage customClasses]

    And the message goes on...

    After that, the interface builder seems to stop working correctly.
    So, what seems to be the problem?
    Am I missing something here?

    I've tried to create other simple iphone apps and run into the same problems over and over with the interface builder.
    So, what seems to be the problem here?

    Appreciate the help...
     
  2. PhoneyDeveloper macrumors 68040

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    These are not normal problems. I've never seen them.

    If you make a project from a template, say navbar app, and the problem occurs if you try to edit the xib file in that project then your installation is probably hosed. If it only happened in one project or one file then I would think the file has gotten corrupted.

    I would run DiskUtility first and check that your hd is ok. If it is then I would reinstall the SDK.
     
  3. ethanby macrumors newbie

    Joined:
    Feb 21, 2009
    #3
    Hello to All,
    I'm an iphone newbe to,
    have the same exact problem (tried to write the "Hello world").
    did you find a solution (tried reinstalling twice - didn't work),
    does anybody have an Idea?

    Thanks,
    Ethan.
     

Share This Page