Intermittant Printing Issue w/HP 4050

Discussion in 'macOS' started by Capt. Pat, Mar 11, 2008.

  1. Capt. Pat macrumors newbie

    Joined:
    Nov 25, 2006
    #1
    I have an intermittent printing issue, when I try to print, documents stack up in the print queue refusing to print, if I reboot the computer the documents print during the boot up cycle. I've tried downloading and installing the most recent driver from HP, tried the Gutenprint Driver and the Generic Postscript Driver all with the same results. I using an HP 4050 connected via USB to a MacPro using OS 10.5.2, the problem was not present before I upgraded to 10.5.2.

    Any ideas/recommendations?

    Thanks

    Pat
     
  2. hodgjy macrumors 6502

    Joined:
    Apr 15, 2005
    #2
    I had a similar problem with my HP 1012. Gutenprint does in fact work, but you have to remove all traces of your old HP driver install, including the HP USB driver kernel extension. The problem with HP printers on OS X is not the driver itself, but its *****ty implementation of the USB backend to CUPS. Gutenprint is much better in this aspect. I forget offhand what the name of the HP USB kernel extension is (because I long ago deleted it), but you can do a spotlight search for .kext files. Delete the one that says HP in the name.
     
  3. Capt. Pat thread starter macrumors newbie

    Joined:
    Nov 25, 2006
    #3
    spotlight search of .kext yields no hits, should I delete the ppd associated with the HP 4050?

    Thanks
     
  4. hodgjy macrumors 6502

    Joined:
    Apr 15, 2005
    #4
    The most important thing to delete is the kernel extension because this is what tells OSX to print using the HP drivers. If you remove it, it will ignore HP and use Gutenprint.

    Go to System folder--Library--Extensions, and delete the file that's names HPIO.kext (or something like that).
     
  5. Capt. Pat thread starter macrumors newbie

    Joined:
    Nov 25, 2006
  6. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #6
    Try reinstalling the driver from HP's website.
     
  7. hodgjy macrumors 6502

    Joined:
    Apr 15, 2005
    #7
    Did you also delete all the HP printer folders? Search spotlight to find them all. Also, did you reboot? You need to to get the kext out of memory.
     
  8. Capt. Pat thread starter macrumors newbie

    Joined:
    Nov 25, 2006
    #8
    Okay, I can get it to work if I un-plug the usb connection from the computer and then plug it back it. Hmmm, printer seems to work fine. I swapped usb connections with no change, could it be the printer cable? Seems an odd thing to fail intermittantly.
     
  9. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #9
    Yeah, it could easily be a loose connection in the cable, that the signal gets through sometimes but not others.
     

Share This Page