Intermittent colour display when mirroring

Discussion in 'MacBook Pro' started by Tacticus, Mar 12, 2015.

  1. Tacticus macrumors newbie

    Joined:
    Feb 18, 2013
    #1
    When mirroring from my MBP to TV via HDMI cable the colour sometimes gets distorted. It seems that one of the RBG colour components is lost (example yellow goes red, blue goes green) and it makes the screen unwatchable. It reverts back if I remove the cable and reinsert it. I have the HDMI connected directly into the HDMI port on the MBP and have changed the cable but still the same result. Any ideas on how to resolve this ?
     
  2. Tacticus thread starter macrumors newbie

    Joined:
    Feb 18, 2013
    #2
    Actually, don't worry about this people .... fixed it.
     
  3. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #3
    What was the resolution? It might help the next person who has this problem.
     
  4. Tacticus thread starter macrumors newbie

    Joined:
    Feb 18, 2013
    #4
  5. Tacticus thread starter macrumors newbie

    Joined:
    Feb 18, 2013
    #5
    Sadly I have this inverse colour problem again since I upgraded my MBPr to Yosemite. It seems the override fix that worked for Lion doesn't work for Yosemite. Does anybody know of a fix that works on Yosemite ?
     
  6. Tacticus thread starter macrumors newbie

    Joined:
    Feb 18, 2013
    #6
    I'm still having a problem with this, has anybody come across a Yosemite fix yet ?
     
  7. Tacticus thread starter macrumors newbie

    Joined:
    Feb 18, 2013
    #7
    I am still getting this problem, has anybody come across a Yosemite fix yet ?
     
  8. Tacticus thread starter macrumors newbie

    Joined:
    Feb 18, 2013

Share This Page