Intermittent Firefox typing bug...

Discussion in 'MacBook Pro' started by NickM, Apr 8, 2009.

  1. NickM macrumors 6502

    Joined:
    Feb 24, 2009
    Location:
    USA
    #1
    My MBP is a bit over a month old. It's been working great so far... no complaints whatsoever.
    However, I have noticed a few times recently that when using Firefox to surf, from time to time no text will show up when I go to type something. I think the only time it's happened is on Google when trying to do searches.

    I can click in the text box over and over, but when I type, nothing shows up. I fix it by clicking in the address bar once, then going back to the search input box. Then it works fine.

    It's only happened a handful of times and it's very infrequent.
    I assume it's just some Firefox bug or something...?
    Anybody else ever get this?
     
  2. 4np macrumors 6502a

    4np

    Joined:
    Feb 23, 2005
    Location:
    The Netherlands
    #2
    Well, I experience slowth in FireFox quite regularly. Probably the Firebug, Developer toolbar and FoxyProxy extentions do not help to speed up things. Perhaps it's better to switch to Safari beta4 as it currently is the speediest browser available.
     
  3. NickM thread starter macrumors 6502

    Joined:
    Feb 24, 2009
    Location:
    USA
    #3
    I've just been a Firefox user for a while now. I don't run any extensions...probably because I've just never really looked into them. I'm sure I would find a bunch of cool stuff that I'd use a lot.

    It isn't really a problem, though. Just a little weird.
    If anyone else experiences this, let me know. I'd like to not be the only one :)
     
  4. eluk macrumors 6502a

    eluk

    Joined:
    Dec 14, 2006
    Location:
    East London, UK
    #4
    I've been running Firefox on this MBP for two-and-a-half years and not witnessed this happen.
     
  5. magamo macrumors 6502

    Joined:
    Apr 6, 2009
    #5
    I've been experiencing the exact same problem for months. It happens on my old white MB but not on my 17" UMB. I always thought having too many add-ons, my bilingual IME or their combination was the cause, but it seems I was wrong.

    It's not that big a problem because I can type normally back again by clicking another text field or, if it fails, by relaunching Firefox. But it sure is annoying. If someone knows how to fix it, I'd love to know it.
     
  6. magallanes macrumors regular

    Joined:
    Jul 12, 2008
    Location:
    South of Jurassic Park
    #6
    i don't known about a fix but i think it is because the control (for some reason) lose the focus. So to fix it is to find which control is taking control of the focus. You always can run firefox in secure mode and see if its happens in this mode.

    And, is it possible to put a scrollbar in firefox?
     
  7. Ramonzuton macrumors newbie

    Joined:
    Oct 31, 2008
    #7
    I'm experiencing this problem every now and then on my unibody MBP... don't know why... don't really care... I've only had this problem with google so refreshing is done in a few milliseconds...
     
  8. NickM thread starter macrumors 6502

    Joined:
    Feb 24, 2009
    Location:
    USA
    #8
    Ok, good ;) At least I'm not the only one.
    It's probably just some Firefox bug, because that's the only place it happens, and it's not very frequent... and only on Google homepage for me.

    I haven't tried reinstalling Firefox yet, but maybe that would do the trick... or maybe a fresh OS X install. (which isn't really worth it to me, but next time I do, I guess I'll find out)
     
  9. ubestbsteppin macrumors regular

    Joined:
    May 23, 2008
    #9
    Same problem here on UMBP 15in late October. Drives me crazy!
     
  10. NickM thread starter macrumors 6502

    Joined:
    Feb 24, 2009
    Location:
    USA
    #10
    Does anyone else notice this outside of Firefox or outside of Google.com??
     
  11. wclement7 macrumors newbie

    Joined:
    Mar 30, 2009
    #11
    I have never had this issue outside of firefox. I have had it happen on google and also on my works wireless authentication page.
     
  12. ubestbsteppin macrumors regular

    Joined:
    May 23, 2008
    #12
    Yes, I notice it in different apps.
     
  13. NickM thread starter macrumors 6502

    Joined:
    Feb 24, 2009
    Location:
    USA
    #13
    Like what? How often?

    Are you also using a UMBP?

    I'm trying to narrow it down and see if it's only a problem for UMBP or what exactly. Until now, it seemed like it was only happening in Firefox.
     
  14. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #14
    IF your getting this in other appz, then I'd advise you to upgrade the firmware for your machine, as patches have been available for a long long time!!
    Apple has resolved the issue of freezing, vanishing, non-responding and keyboards/mouse.
     
  15. wesrk macrumors 6502a

    Joined:
    Nov 4, 2007
    #15
    outside firefox no, outside google yeah, a couple of times but usually in other search boxes related to google, just not on google.com
    I changed to firefox beta 3b, and while it has other little things that come from time to time, it mostly solved this issue, or I haven't seen it happen in a couple weeks.
     
  16. magamo macrumors 6502

    Joined:
    Apr 6, 2009
    #16
    I run Software Update periodically and the firmware should be up-to-date, but I get the problem in another browser too.

    Most of the time it happens when I'm on Firefox and trying to type a query on Google, but sometimes I get a similar problem when using this obscure browser called Thousand to post in a certain forum. I'm not sure if the cause is the same though.

    Anyway, my Firefox is 3.0.8 and I can't remember when was the last time I saw this happen on Firefox. It's like my browser loses the focus only when I need to google something real quick...
     
  17. ayeying macrumors 601

    ayeying

    Joined:
    Dec 5, 2007
    Location:
    Yay Area, CA
    #17
    It depends on how much tabs I have opened. If I have many (50+) opened, it will start lagging pretty badly unless all the sites i've opened has no flash or javascripts. Otherwise, I don't seem to see much of a typing lag.
     
  18. wesrk macrumors 6502a

    Joined:
    Nov 4, 2007
    #18
    It's not a type lag in the sense that the letters are trying to catch up with you (like in those old electric typewriters), it's just that it WON'T type at all.

    For example, you go to google, the page loads, then the cursor is blinking on the search field, you type something but it doesn't show, and you must click somewhere outside the search box (address bar, other part of the page, outside that window, etc.) and then click back in the search field, and NOW what you write shows up in the search bar.
     
  19. ubestbsteppin macrumors regular

    Joined:
    May 23, 2008
    #19
    About once a day. Mainly in Firefox, sometimes in other apps but I can't really remember which particular ones. I have a 15in UMBP.
     

Share This Page