Intermittent Inability to Send Mail

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mhaddy, Aug 19, 2008.

  1. Mhaddy macrumors 6502

    Mhaddy

    Joined:
    Oct 26, 2005
    Location:
    Canada
    #1
    This is an issue that I've had all across 2.0, 2.0.1, and 2.0.2. For any of the mail accounts that I have synced on my phone, I will intermittently experience an inability to send an email. At times I will hit the Send button and the message will disappear as per usual but it will not appear in an Outbox nor do I see it in the Sent items folder -- it will just vanish. Other times the mail will sit in the Outbox and will just refuse to send.

    Anyone else experiencing these problems/know how to fix it/force resend a message?
     
  2. woodyrr macrumors member

    Joined:
    Aug 19, 2008
    #2
    I have experienced the same problem of disappearing emails. I have an original iPhone that has been updated to 2.0.1 and set to retrieve mail every 15 minutes from several accounts. Daily, I will notice that a long period of time has elapsed since an email has appeared. I touch the mail icon and choose one of the accounts, touch the inbox and when the list of emails appears, instead of "Updated 8/19/08 17:37" at the bottom of the screen, I see "Connecting" with the little spinning asterisk. Sometimes it will change to "Checking Mail" with the spinning asterisk, but it doesn't matter how long it sits there, that's all I get.

    I can backtrack to the accounts list and choose another account, but the same thing will happen. The only way to get current email is to shut down, wait a few moments and restart. On restart, bunches of mail that have been holding for hours suddenly show up.

    The similarity to Mhaddy's experience is that when my iPhone is in this state of limbo, if I compose a message and hit send, the message is absolutely gone. It was in trying to understand the fate of my vanished message that I recognized that the issue that I was having involved a periodic inability to both send and receive mail.

    I might mention that I have had this iPhone since November 1, 2007 and before I updated to version 2 of the software, I had no problems email related or otherwise.
     
  3. Mhaddy thread starter macrumors 6502

    Mhaddy

    Joined:
    Oct 26, 2005
    Location:
    Canada
    #3
    I have also experienced the inability to receive mail, with the Connecting or Checking Mail status message seemingly stuck at the bottom of the Mail window. It is during this time that I cannot send emails and they just "disappear". You've just explained my problem much more eloquently than I ever could.

    FWIW I have Fetch set to hourly. I will try turning off Fetch and see if the problem persists. Glad I'm not alone!
     
  4. Denny Crane macrumors member

    Denny Crane

    Joined:
    Jul 8, 2007
    Location:
    Alabama
    #4
    I have a similar problem. I have my mail set to fetch hourly. Often I'll notice that no mail has arrived when it arrived in my computer based mailbox hours ago. I go in and manually attempt to retrieve mail. Nothing happens. I have to turn the phone off and turn it back on. When I go into mail at that point, new emails begin to appear.

    Never had this problem with the first generation iPhone.
     
  5. melonhead macrumors newbie

    Joined:
    Aug 21, 2008
    #5
    Is the sending problem only on 3g/Edge?

    I had a problem where I could only send mail from wifi, but on 3g or Edge, I would get some sort of error code, and the mail would stay in the outbox. To fix it, I changed the outgoing mail server to "Rogers Wireless Data" (I'm from Canada, but I'm sure there is a similar server for AT&T in mail settings, or for any other providers for that matter.
     
  6. Italchef macrumors 6502

    Joined:
    Nov 3, 2003
    Location:
    Maple, Ontario
    #6
    Phew, at least I'm not alone with this one. I was on the phone with Rogers support, ran through all the settings, and still the same thing. I have no idea to fix this but this is one of the features of my first smart phone that I really wanted. I hope they get this fixed.
    Just an aside here, but do any of you know how to fix and junk mail problem? I have 2 rogers accounts, same settings, one filters properly and the other sends it all through to my inbox. Rogers has this fix on the website that has you setting up dummy email accounts etc. There must be an easier fix.

    Mick
     
  7. Denny Crane macrumors member

    Denny Crane

    Joined:
    Jul 8, 2007
    Location:
    Alabama
    #7
    I've had the problem on all three. I suspect the issue is related to the handoffs between the three. In my house, I can't get 3G, but have wifi and Edge available. At work, I have 3G coverage. My guess is that the handoffs knock the email accounts "offline" or something similar.
     
  8. mctheriot macrumors regular

    mctheriot

    Joined:
    Nov 2, 2007
    Location:
    McHenry, IL
    #8
    I've got the same problem -

    "connecting" is there forever and no mail arrives. I've tryed dropping into "Airplane" mode and then back with the same results. I have to power down the unit and then I can get my mail. It seems worse with the last update.

    Mark
     
  9. dkeninitz macrumors regular

    Joined:
    Feb 16, 2003
    Location:
    Germantown, MD
    #9
    I've had this problem several times with my 3G - I do a "restore network settings" action and it fixes the problem, at least until for awhile. The 3G is obviously a work in progress: very buggy.
     
  10. cmegalodon macrumors newbie

    cmegalodon

    Joined:
    Aug 19, 2008
    #10
    Temporary fix - Email reception stops intermittently

    An apple support person suggested going to one of your email accounts and holding down the HOME BUTTON for ten seconds or more. You will see the screen briefly go black the exit to the main menu.

    Apparently there is something he called a "T" buffer (temp buffer?) that does not empty out correctly. When the buffer is full, you cannot receive emails.

    I also notice this happens after using some of the Apps I have purchased.

    It has really helped my 3G 2.0.2 email reception.
     
  11. Mhaddy thread starter macrumors 6502

    Mhaddy

    Joined:
    Oct 26, 2005
    Location:
    Canada
    #11
    Though I haven't modified any settings or changed my mail checking/sending habits, I have not experienced this problem since I made the original post. With that said, the holding down the HOME button until Mail quits fix that cmegalodon mentioned did fix the problem for me when I was experiencing it.
     
  12. woodyrr macrumors member

    Joined:
    Aug 19, 2008
    #12
    RE: post #2 in this thread:

    Mine was beginning to act somewhat more reasonably until I installed the 2.1 update Saturday. For the most part now, it won't get email while it's asleep. If I wake it up, all of a sudden emails that have been stuck in the pipe, start counting up on the little mail icon.

    This is not good.

    This appears to be a common issue with the new release:

    http://forums.macrumors.com/showthread.php?t=562621
     

Share This Page