Intermittent issues with USB/TBolt

Discussion in 'MacBook Air' started by JeffreyMeade, Jun 22, 2017.

  1. JeffreyMeade macrumors newbie

    Joined:
    Jun 22, 2017
    #1
    Hi all,

    Noob here, but not new to the product.

    Specs: Early 2015 13" MBA macOS 10.12.5

    I have started having issues with the external display plugged directly into my MBA (it looses connection, then reconnects) and USB hubs (connections lost, but don't come back).

    Plugging mice and keyboards directly into the MBA work, and there are no issues with the laptop display.

    I tried PRAM and SMC resets with no improvement.

    Any other suggestions?
     
  2. Boyd01 macrumors 68040

    Boyd01

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #2
    I would start by trying another cable with the display, I had a cable problem awhile ago on my MBA. You should also try it with another monitor just to make sure that isn't the problem.

    I have also had issues with a powered USB hub. I replaced it and most of the problems went away, although there is still the odd glitch every now and again. When you mention using a USB keyboard, is it the Apple USB extended keyboard by any chance?

    I have one of these and it worked very inconsistently on my MBA. Would be fine for a long time, then suddenly not recognized. Disconnecting, rebooting and reconnecting would usually fix that, but not always. Then it would only work when directly connected to the left USB port. Did some searching and similar problems with this keyboard are apparently well-known. I never found a solution, but rarely use an external keyboard with my MBA anymore since I now have a quad mini for the desktop. That same Apple keyboard has been connected to the Mini for over a year with absolutely no problems.

    Anyway, I don't see anything in your post to indicate that the thunderbolt and USB issues are related. Both of these things can be a little finicky in my experience, and switching cables and hubs usually fixes things.
     
  3. JeffreyMeade thread starter macrumors newbie

    Joined:
    Jun 22, 2017
    #3
    Thanks.

    Yes, it is an Apple A1243 keyboard. I swapped it with the one on my MacMini, and it is only the MBA that has the issues.

    Tried changing cables... will try another monitor (the 60" in my livingroom is the only other one I own... the MacMini is my media hub.)
     
  4. Boyd01 macrumors 68040

    Boyd01

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #4
    There is just something weird with that keyboard and the way it reacts to USB on certain Macs. Too bad, because I really like it. I would definitely remove it from the equation while troubleshooting, it may also affect other USB peripherals somehow.
     
  5. Chris-L macrumors newbie

    Joined:
    Nov 9, 2017
    #5
    I wish I had an answer but I also have a similar problem. I connect my iphone 8 via USB to my MBA(2014 11" macOS 10.13.1) and it looses connection after a few seconds to a few minutes. Changing cords made no differnece.
     
  6. JeffreyMeade thread starter macrumors newbie

    Joined:
    Jun 22, 2017
    #6
    Somewhere else I saw a comment that it might be a power issue. I was skeptical because the keyboard, mouse, and printer are not power hogs.

    A couple of weeks ago I switched to a powered dock (OWC Thunderbolt 2 Dock) and have not had the problem since.

    Try a powered hub - it doesn't have to be as elaborate as mine!
     

Share This Page