Intermittent MacBook Pro high-pitched whine

Discussion in 'MacBook Pro' started by SethBoy, Feb 11, 2009.

  1. SethBoy macrumors regular

    Joined:
    Jun 23, 2007
    #1
    Hey guys, my classic MBP is about 11 months year old now, and I recently noticed this high pitched sound coming from it. After leaving it on for a night to encode videos into iPod format, I noticed that there's this irritating high-pitched whining noise that is present every now and then.

    Even more annoyingly, it seems to come on every time I get an Adium message. At first I thought it was the message alert sound setting it off, but it seems to happen even when my Mac is mute.

    When I boot the Mac, the boot sound is also accompanied by some noise.

    Any idea what is causing such a problem?
     
  2. Animalk macrumors 6502

    Joined:
    May 27, 2007
    Location:
    Montreal Canada
    #2
    Are you in OS X or a Boot Camped Windows/Linux partition when this occurs?

    The Core Duo and Core 2 Duo family of processors are known to whine when in a particular idle state. In this case, the whine disappears when the processor is given something to process like scrolling up and down a web page or encoding video.

    My MBP does this too but almost always only when running Windows in boot camp. Though the few times where it has occured in OS X, it was after having done several hours of full throttle cpu work...once was 36 hours straight at full load.

    There is lots of information within this forum and other sites regarding this and you should be able to easily tell whether or not it applies to your case.

    I have learned to just accept it as I must be in a really quiet room for me to notice.

    Good Luck.
     
  3. SethBoy thread starter macrumors regular

    Joined:
    Jun 23, 2007
    #3
    In Windows the whine is related to screen brightness, which from what I googled is quite a common thing. In OS X, however, it is less predictable. It comes on every now and then, which makes it more obvious, and it's really high-pitched and really annoying.

    The only pattern I've noticed is that it comes on when I have an Adium message.

    Processor-intensive stuff does not seem to stop it. It still makes the noise when video is encoded.

    Argh I suppose a trip to the service centre is imminent. I hate that.
     

Share This Page