Intermittent wifi issues - MBA2013

Discussion in 'MacBook Air' started by boycecodd, Jan 7, 2014.

  1. boycecodd macrumors newbie

    Joined:
    Aug 4, 2013
    #1
    I've got a 2013 MacBook Air, fully up to date and running Mavericks. I've been getting intermittent wifi dropouts which I think coincide with the upgrade.

    The machine still thinks it's connected, but I can't browse to sites and I can't ping sites (if I already have a ping session running, it will lose connection). If I wait long enough (several minutes) the connection usually comes back, but if I turn wifi off and immediately back on then it comes back straight away.

    Other machines (two Windows PCs and my iPhone and iPad) aren't affected and can continue to browse while this happens, so this definitely appears to be my machine.

    Now here's the odd part - during the drop-outs I can access network resources within the home network (my NAS, the router's admin page). I just can't get out onto the internet as a whole. Despite this I still believe that this is specific to the MacBook as none of the other machines were affected.

    Any ideas? I'm at a loss right now...
     
  2. sigamore macrumors newbie

    Joined:
    Dec 26, 2013
    Location:
    Israel
    #2
    Did you get the same situation since day one with the MBA?
    Might have something to do with your router setting. Try to assign a fixed IP address just for testing purpose.
     
  3. kgolden macrumors newbie

    Joined:
    Jan 9, 2014
    #3
    I do desktop support for a small company and have 3 users experiencing the same issues. Time or turning the wifi off and back on again seem to be the only solutions. I've tried sigamore's suggestion of setting a static IP and that is still not resolving the issue. Like the original post said the weirdest part is I can ping everything on the local network but anything external just fails.
     
  4. Jedi Master macrumors regular

    Joined:
    Apr 5, 2013
    Location:
    ar the moment on the Death Star
    #4
    What browser are you using

    What browser are you using
     
  5. iizmoo macrumors 6502

    Joined:
    Jan 8, 2014
    #5
    Have you tried manually setting the DNS server in network pref instead of auto assignment? Use 8.8.8.8 and 8.8.4.4 (Google's DNS). I have the 2013 MBA and have never experienced this, but I've always set my DNS manually to Google's service.

    If you can hit local net but can't get out, that mean there's something funky with the DNS service's ability to resolve external addresses, you're not getting actual dropped packets.

    Also, does this happen after sleep/hibernation?

    There was a weird bug where some macs can't connect to certain wireless AP hardware after waking up until a power cycle.
     
  6. cerberusss macrumors 6502a

    cerberusss

    Joined:
    Aug 25, 2013
    Location:
    The Netherlands
    #6
    I've had the same. What fixed it for me, was a different router. I got a model with both 2.4 and 5 GHz wireless, a second hand Linksys WRT610N and that fixed the problems.
     
  7. boycecodd thread starter macrumors newbie

    Joined:
    Aug 4, 2013
    #7
    Thanks everyone.

    I've tried setting my IP manually - no joy. I've tried a different AP (my phone!) and the same problem occurs.

    I always put my MBA to sleep, I only ever shut it down if I'm leaving it unpowered for extended intervals (it's usually in clamshell mode on my desk) or if I'm about to boot into BootCamp (due to the other Wifi bug).

    I'll try setting DNS manually and see if that makes any difference, otherwise I'll have to keep restarting the connection, which is infuriating.
     
  8. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #8
    It may be a defective AirPort card as that what was happening to a close friend of mine's mid-2011.
     
  9. luckydcxx macrumors 65816

    luckydcxx

    Joined:
    Jun 13, 2013
    #9
    I am having this same issue. I have a MBP and MBA when I have them side by side the MBA has the same issues you describe. I just bought it 2 weeks ago and it kinda makes me mad. :mad:
     
  10. savetheunstable macrumors newbie

    Joined:
    Nov 1, 2013
    Location:
    Portland, OR
    #10
    Do you have Mavericks too? Seems related, reading about this issue in the forums. Makes me hesitant to upgrade. Some people say the beta version of Mavericks (10.9.2) helped. There are some other suggestions on the Apple forums:

    https://discussions.apple.com/thread/5506422?start=135&tstart=0
     
  11. luckydcxx macrumors 65816

    luckydcxx

    Joined:
    Jun 13, 2013
    #11
    Yes I am running mavericks ... i also have a mac book pro running mavericks with no problems at all. hopefully the update will fix this.
     
  12. IGregory macrumors 6502a

    IGregory

    Joined:
    Aug 5, 2012
    #12
    You're lucky...I have the Mid-2012 rMBP. I've been having this problem with loss internet connection since day one. I was using the Cisco Linksys 3200 router up to last week when I purchased an Apple Airport Time Capsule 2TB. Now I am finding that I loss connection to the Internet more frequently than with the Linksys. I don't believe the problem is in the router or the Airport because my iPad Air and iPhone 5s are not having this problem. Time for a trip to the Genius Bar.
     
  13. ilifecomputer macrumors 6502

    Joined:
    Feb 9, 2005
    Location:
    Los Angeles, CA
    #13
    Apparently a fix is coming in 10.9.2. There is a huuuuuge thread about it in the official apple support forums and some users claim that the new wifi driver has pretty much fixed this issue.

    For the record, my air does the same thing with my router.

    And:
    https://discussions.apple.com/thread/5100655?start=1965&tstart=0
     
  14. fyzle, Jan 30, 2014
    Last edited: Jan 30, 2014

    fyzle macrumors member

    Joined:
    Aug 1, 2004
    #14
    PingFixer

    I made this small app to resolve the variable ping issue. https://gum.co/PingFixer

    It basically does the workaround that is mentioned in various online forums, but it's packed up nicely and does some other things to make sure you're actually keeping the wifi card awake.
     
  15. crossi81 macrumors member

    Joined:
    Aug 13, 2012
  16. fizzler macrumors member

    Joined:
    Jul 5, 2010
    #16
    I know that this thread is a bit out of date, but i have been having similar wifi issues with my 2013 MBA for several months. I stumbled accross this blog on another forum and it seems to have sorted my problems........... so far.

    I don't really understand why this would work, but hey- I ain't complaining!

    http://www.s0hel.com/blog/401/fixed-slow-wifi-issue-with-new-macbook-pro/
     
  17. CJM macrumors 65816

    CJM

    Joined:
    May 7, 2005
    Location:
    U.K.
    #17
    My Wifi struggles to re-establish connection after waking from sleep. I have to turn it off and back on in the menu before it picks up the access point again. Seems to be exactly the same after 10.9.2. Bit of a pain in the neck really. Definitely happens every time at work. Pretty sure it happens at home too, but I'll have to verify it tonight.
     
  18. OldManJimbo, Mar 7, 2014
    Last edited: Mar 7, 2014

    OldManJimbo macrumors 6502

    OldManJimbo

    Joined:
    Jun 1, 2004
    Location:
    California Coast
    #18
    Frustrating Airport issue with 2013 MBA

    Exact same issue with me. Household MBPro, iPads, iPhones do not have this issue, ONLY the MBA.

    Some of the comments on https://discussions.apple.com/thread/5506422?start=135&tstart=0 indicate users have opened their MBA and found loose connections with the Airport card. Is this something a typical user should attempt. Or should I take my laptop to the Apple store and have them do it?
     

Share This Page